# \*\*\* SOLVED \*\*\* Netflow module | Error in visualization

**URL:** https://discuss.elastic.co/t/solved-netflow-module-error-in-visualization/192694
**Category:** Kibana
**Created:** [July 29, 2019, 12:24pm UTC](https://discuss.elastic.co/t/solved-netflow-module-error-in-visualization/192694 "2019-07-29T12:24:23Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![thirty2](https://avatars.discourse-cdn.com/v4/letter/t/a9a28c/32.png) [@thirty2](https://discuss.elastic.co/u/thirty2)
#### Post date: [July 29, 2019, 12:24pm UTC](https://discuss.elastic.co/t/solved-netflow-module-error-in-visualization/192694/1 "2019-07-29T12:24:23Z")

</div>

Hi,

i mange to run Netflow module in ELK. I can see new Dashboard in Kibana. But when i click do display on the Dashboard i am getting this error in Kibana:

> Error in visualization  
> [esaggs] \> Request to Elasticsearch failed: {"error":{"root\_cause":[{"type":"illegal\_argument\_exception","reason":"Fielddata is disabled on text fields by default. Set fielddata=true on [netflow.protocol\_name] in order to load fielddata in memory by uninverting the inverted index. Note that this can however use significant memory. Alternatively use a keyword field instead."},{"type":"illegal\_argument\_exception","reason":"Fielddata is disabled on text fields by default. Set fielddata=true on [netflow.protocol\_name] in order to load fielddata in memory by uninverting the inverted index. Note that this can however use significant memory. Alternatively use a keyword field instead."},{"type":"illegal\_argument\_exception","reason":"Fielddata is disabled on text fields by default. Set fielddata=true on [netflow.protocol\_name] in order to load fielddata in memory by uninverting the inverted index. Note that this can however use significant memory. Alternatively use a keyword field instead."}],"type":"search\_phase\_execution\_exception","reason":"all shards failed","phase":"query","grouped":true,"failed\_shards":[{"shard":0,"index":"netflow-2019.07.29","node":"Fq3UNCrjSEaTq0jH3TxSFg","reason":{"type":"illegal\_argument\_exception","reason":"Fielddata is disabled on text fields by default. Set fielddata=true on [netflow.protocol\_name] in order to load fielddata in memory by uninverting the inverted index. Note that this can however use significant memory. Alternatively use a keyword field instead."}},{"shard":0,"index":"netflow-2019.07.30","node":"qRx8taJTTbqVQqykVmPl7g","reason":{"type":"illegal\_argument\_exception","reason":"Fielddata is disabled on text fields by default. Set fielddata=true on [netflow.protocol\_name] in order to load fielddata in memory by uninverting the inverted index. Note that this can however use significant memory. Alternatively use a keyword field instead."}},{"shard":0,"index":"netflow-2019.07.31","node":"e30n\_h-qSnq7\_uMOAfU6Uw","reason":{"type":"illegal\_argument\_exception","reason":"Fielddata is disabled on text fields by default. Set fielddata=true on [netflow.protocol\_name] in order to load fielddata in memory by uninverting the inverted index. Note that this can however use significant memory. Alternatively use a keyword field instead."}}],"caused\_by":{"type":"illegal\_argument\_exception","reason":"Fielddata is disabled on text fields by default. Set fielddata=true on [netflow.protocol\_name] in order to load fielddata in memory by uninverting the inverted index. Note that this can however use significant memory. Alternatively use a keyword field instead.","caused\_by":{"type":"illegal\_argument\_exception","reason":"Fielddata is disabled on text fields by default. Set fielddata=true on [netflow.protocol\_name] in order to load fielddata in memory by uninverting the inverted index. Note that this can however use significant memory. Alternatively use a keyword field instead."}}},"status":400}

I fix it but runninig:

> curl -X PUT "localhost:9200/netflow-\*/\_mapping" -H 'Content-Type: application/json' -d'  
> {  
> "properties": {  
> "PUT YOUR FILED HERE": {  
> "type": "text",  
> "fielddata": true  
> }  
> }  
> }  
> '

---

<div class="post-metadata">

### Author: ![joelgriffith](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/joelgriffith/32/53738_2.png) [@joelgriffith](https://discuss.elastic.co/u/joelgriffith)
#### Post date: [August 7, 2019, 5:48pm UTC](https://discuss.elastic.co/t/solved-netflow-module-error-in-visualization/192694/2 "2019-08-07T17:48:06Z")

</div>

Thanks for posting your answer! Going to close this out now 🙂

---

<div class="post-metadata">

### Author: ![joelgriffith](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/joelgriffith/32/53738_2.png) [@joelgriffith](https://discuss.elastic.co/u/joelgriffith)
#### Post date: [August 7, 2019, 5:48pm UTC](https://discuss.elastic.co/t/solved-netflow-module-error-in-visualization/192694/3 "2019-08-07T17:48:16Z")

</div>


