# \[Solved\] Update from 6.2.2 to 6.6.1 on Debian failed, forgot to remove X-pack

**URL:** <https://discuss.elastic.co/t/solved-update-from-6-2-2-to-6-6-1-on-debian-failed-forgot-to-remove-x-pack/171812>\
**Category:** Elasticsearch\
**Created:** [March 11, 2019, 4:57pm UTC](https://discuss.elastic.co/t/solved-update-from-6-2-2-to-6-6-1-on-debian-failed-forgot-to-remove-x-pack/171812 "2019-03-11T16:57:37Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![paspao](https://avatars.discourse-cdn.com/v4/letter/p/7bcc69/32.png) [@paspao](https://discuss.elastic.co/u/paspao)\
**Post date:** [March 11, 2019, 4:57pm UTC](https://discuss.elastic.co/t/solved-update-from-6-2-2-to-6-6-1-on-debian-failed-forgot-to-remove-x-pack/171812/1 "2019-03-11T16:57:37Z")

</div>

Hello,

I hope you can help me.

Even if reading step by step docs I forgot to remove xpack plugin before upgrading.

I am on Debian 9 and I get the error:  
Exception in thread "main" java.lang.IllegalStateException: Could not load plugin descriptor for plugin directory [x-pack]

I did not started elastic on this node.

This is part of 3 node cluster now in yellow state.

Can I do something to fix without having to recreate a new node with 6.2.2 version?

Can I update the other nodes removing x-pack plugin?

Hope someone can help.

Thank you.  
P.

---

<div class="post-metadata">

**Author:** ![paspao](https://avatars.discourse-cdn.com/v4/letter/p/7bcc69/32.png) [@paspao](https://discuss.elastic.co/u/paspao)\
**Post date:** [March 11, 2019, 5:36pm UTC](https://discuss.elastic.co/t/solved-update-from-6-2-2-to-6-6-1-on-debian-failed-forgot-to-remove-x-pack/171812/2 "2019-03-11T17:36:30Z")

</div>

Maybe I solved manually removing plugins from /usr/share/elasticsearch/plugins/ as in this other thread: [6.2.1 to 6.4 upgrade results in X-pack 'NoSuchFileException' issue](https://discuss.elastic.co/t/6-2-1-to-6-4-upgrade-results-in-x-pack-nosuchfileexception-issue/145935/7)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 8, 2019, 5:36pm UTC](https://discuss.elastic.co/t/solved-update-from-6-2-2-to-6-6-1-on-debian-failed-forgot-to-remove-x-pack/171812/3 "2019-04-08T17:36:36Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
