# \[Solved\] Update from 6.2.2 to 6.6.1 on Debian failed, forgot to remove X-pack

**URL:** <https://discuss.elastic.co/t/solved-update-from-6-2-2-to-6-6-1-on-debian-failed-forgot-to-remove-x-pack/171812>\
**Category:** Elasticsearch\
**Created:** [March 11, 2019, 4:57pm UTC](https://discuss.elastic.co/t/solved-update-from-6-2-2-to-6-6-1-on-debian-failed-forgot-to-remove-x-pack/171812 "2019-03-11T16:57:37Z")\
**Posts on this page:** 1\
**Showing post:** 2

<div class="post-metadata">

**Author:** ![paspao](https://avatars.discourse-cdn.com/v4/letter/p/7bcc69/32.png) [@paspao](https://discuss.elastic.co/u/paspao)\
**Post date:** [March 11, 2019, 5:36pm UTC](https://discuss.elastic.co/t/solved-update-from-6-2-2-to-6-6-1-on-debian-failed-forgot-to-remove-x-pack/171812/2 "2019-03-11T17:36:30Z")

</div>

Maybe I solved manually removing plugins from /usr/share/elasticsearch/plugins/ as in this other thread: [6.2.1 to 6.4 upgrade results in X-pack 'NoSuchFileException' issue](https://discuss.elastic.co/t/6-2-1-to-6-4-upgrade-results-in-x-pack-nosuchfileexception-issue/145935/7)

---

_[View the full topic](https://discuss.elastic.co/t/solved-update-from-6-2-2-to-6-6-1-on-debian-failed-forgot-to-remove-x-pack/171812)._
