# Sometimes I fail to start up and the error message is as follows.

**URL:** <https://discuss.elastic.co/t/sometimes-i-fail-to-start-up-and-the-error-message-is-as-follows/338174>\
**Category:** Logstash\
**Created:** [July 12, 2023, 6:20am UTC](https://discuss.elastic.co/t/sometimes-i-fail-to-start-up-and-the-error-message-is-as-follows/338174 "2023-07-12T06:20:39Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![pl02206984](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/pl02206984/32/123310_2.png) [@pl02206984](https://discuss.elastic.co/u/pl02206984)\
**Post date:** [July 12, 2023, 6:20am UTC](https://discuss.elastic.co/t/sometimes-i-fail-to-start-up-and-the-error-message-is-as-follows/338174/1 "2023-07-12T06:20:39Z")

</div>

Sometimes I fail to start up and the error message is as follows.

```auto
[2023-07-12T10:50:36,815][ERROR][logstash.config.sourceloader] No configuration found in the configured sources.
[2023-07-12T10:50:36,932][INFO][logstash.agent] Successfully started Logstash API endpoint {:port=>9600}
[2023-07-12T10:50:42,046][INFO][logstash.runner] Logstash shut down.
[2023-07-12T10:50:42,054][FATAL][org.logstash.Logstash] Logstash stopped processing because of an error: (SystemExit) exit
org.jruby.exceptions.SystemExit: (SystemExit) exit
	at org.jruby.RubyKernel.exit(org/jruby/RubyKernel.java:747) ~[jruby-complete-9.2.13.0.jar:?]
	at org.jruby.RubyKernel.exit(org/jruby/RubyKernel.java:710) ~[jruby-complete-9.2.13.0.jar:?]
	at Users.zhujiayu.Desktop.code.tools.logstash_minus_7_dot_12_dot_1.lib.bootstrap.environment.<main>(/Users/zhujiayu/Desktop/code/tools/logstash-7.12.1/lib/bootstrap/environment.rb:89) ~[?:?]
zhujiayu@JONAHZHU-MB0 logstash-7.12.1 %

```

---

<div class="post-metadata">

**Author:** ![PodarcisMuralis](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/podarcismuralis/32/122606_2.png) [@PodarcisMuralis](https://discuss.elastic.co/u/PodarcisMuralis)\
**Post date:** [July 12, 2023, 8:06pm UTC](https://discuss.elastic.co/t/sometimes-i-fail-to-start-up-and-the-error-message-is-as-follows/338174/2 "2023-07-12T20:06:18Z")

</div>

Hi.

I would check firstly logstash-pipeline.conf file under config.(logstash-pipeline can be different in your case) If it exists or the path correct is. Usually it is under config.  
You can start it by going logstash level and giving this command:

```auto
bin/logstash -f /path-to-your-file/config/logstash-pipeline.conf

```

---

<div class="post-metadata">

**Author:** ![Rios](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rios/32/95745_2.png) [@Rios](https://discuss.elastic.co/u/Rios)\
**Post date:** [July 12, 2023, 9:46pm UTC](https://discuss.elastic.co/t/sometimes-i-fail-to-start-up-and-the-error-message-is-as-follows/338174/3 "2023-07-12T21:46:54Z")

</div>

> No configuration found in the configured sources.

After you check PodarcisMuralis suggestion, check permissions. The "logstash" user must have rights to read .conf

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 9, 2023, 9:47pm UTC](https://discuss.elastic.co/t/sometimes-i-fail-to-start-up-and-the-error-message-is-as-follows/338174/4 "2023-08-09T21:47:48Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
