# Spring Boot 1.5.3 and Elastic Search 2.4 error

**URL:** <https://discuss.elastic.co/t/spring-boot-1-5-3-and-elastic-search-2-4-error/85004>\
**Category:** Elasticsearch\
**Created:** [May 9, 2017, 3:51am UTC](https://discuss.elastic.co/t/spring-boot-1-5-3-and-elastic-search-2-4-error/85004 "2017-05-09T03:51:30Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![nixgadget](https://avatars.discourse-cdn.com/v4/letter/n/ee59a6/32.png) [@nixgadget](https://discuss.elastic.co/u/nixgadget)\
**Post date:** [May 9, 2017, 3:51am UTC](https://discuss.elastic.co/t/spring-boot-1-5-3-and-elastic-search-2-4-error/85004/1 "2017-05-09T03:51:30Z")

</div>

I seem to be getting the following error constantly if I run my Spring Boot unit tests which has an autoconfiguration with the properties,

```
spring:
    data:
        elasticsearch:
            cluster-name: onboarding
            properties:
                node:
                    local: true
                    data: true
                path:
                    home: target/elasticsearch_embedded

```

Error,

```
2017-05-09 15:27:34.243 WARN 67335 --- [d_started][T#7]] org.elasticsearch.gateway : [Rom the Spaceknight] [orgdetails][1]: failed to list shard for shard_started on node [uk3AfAKITk-XOjVCyzEYNg]

org.elasticsearch.action.FailedNodeException: Failed node [uk3AfAKITk-XOjVCyzEYNg]
	at org.elasticsearch.action.support.nodes.TransportNodesAction$AsyncAction.onFailure(TransportNodesAction.java:205)
	at org.elasticsearch.action.support.nodes.TransportNodesAction$AsyncAction.access$800(TransportNodesAction.java:107)
	at org.elasticsearch.action.support.nodes.TransportNodesAction$AsyncAction$2.handleException(TransportNodesAction.java:178)
	at org.elasticsearch.transport.TransportService$3.doRun(TransportService.java:353)
	at org.elasticsearch.common.util.concurrent.AbstractRunnable.run(AbstractRunnable.java:37)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
	at java.lang.Thread.run(Thread.java:745)
Caused by: org.elasticsearch.transport.SendRequestTransportException: [Korrek][local[2]][internal:gateway/local/started_shards[n]]
	at org.elasticsearch.transport.TransportService.sendRequest(TransportService.java:340)
	at org.elasticsearch.action.support.nodes.TransportNodesAction$AsyncAction.start(TransportNodesAction.java:165)
	at org.elasticsearch.action.support.nodes.TransportNodesAction$AsyncAction.access$100(TransportNodesAction.java:107)
	at org.elasticsearch.action.support.nodes.TransportNodesAction.doExecute(TransportNodesAction.java:77)
	at org.elasticsearch.action.support.nodes.TransportNodesAction.doExecute(TransportNodesAction.java:46)
	at org.elasticsearch.action.support.TransportAction.execute(TransportAction.java:137)
	at org.elasticsearch.action.support.TransportAction.execute(TransportAction.java:85)
	at org.elasticsearch.gateway.TransportNodesListGatewayStartedShards.list(TransportNodesListGatewayStartedShards.java:76)
	at org.elasticsearch.gateway.AsyncShardFetch.asyncFetch(AsyncShardFetch.java:267)
	at org.elasticsearch.gateway.AsyncShardFetch.fetchData(AsyncShardFetch.java:117)
	at org.elasticsearch.gateway.GatewayAllocator$InternalPrimaryShardAllocator.fetchData(GatewayAllocator.java:156)
	at org.elasticsearch.gateway.PrimaryShardAllocator.allocateUnassigned(PrimaryShardAllocator.java:71)
	at org.elasticsearch.gateway.GatewayAllocator.allocateUnassigned(GatewayAllocator.java:121)
	at org.elasticsearch.cluster.routing.allocation.allocator.ShardsAllocators.allocateUnassigned(ShardsAllocators.java:70)
	at org.elasticsearch.cluster.routing.allocation.AllocationService.reroute(AllocationService.java:258)
	at org.elasticsearch.cluster.routing.allocation.AllocationService.reroute(AllocationService.java:221)
	at org.elasticsearch.cluster.routing.allocation.AllocationService.reroute(AllocationService.java:207)
	at org.elasticsearch.discovery.local.LocalDiscovery$3.execute(LocalDiscovery.java:242)
	at org.elasticsearch.cluster.ClusterStateUpdateTask.execute(ClusterStateUpdateTask.java:45)
	at org.elasticsearch.cluster.service.InternalClusterService.runTasksForExecutor(InternalClusterService.java:480)
	at org.elasticsearch.cluster.service.InternalClusterService$UpdateTask.run(InternalClusterService.java:784)
	at org.elasticsearch.common.util.concurrent.PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.runAndClean(PrioritizedEsThreadPoolExecutor.java:231)
	at org.elasticsearch.common.util.concurrent.PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.run(PrioritizedEsThreadPoolExecutor.java:194)
	... 3 common frames omitted
Caused by: org.elasticsearch.transport.NodeNotConnectedException: [Korrek][local[2]] Node not connected
	at org.elasticsearch.transport.local.LocalTransport.sendRequest(LocalTransport.java:208)
	at org.elasticsearch.transport.TransportService.sendRequest(TransportService.java:329)
	... 25 common frames omitted

```

What could be causing this ?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 6, 2017, 4:04am UTC](https://discuss.elastic.co/t/spring-boot-1-5-3-and-elastic-search-2-4-error/85004/2 "2017-06-06T04:04:24Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
