# SQL data to Elasticsearch using logstash via Mysql connector JDBC plugin

**URL:** <https://discuss.elastic.co/t/sql-data-to-elasticsearch-using-logstash-via-mysql-connector-jdbc-plugin/260686>\
**Category:** Logstash\
**Tags:** elastic-stack-sql\
**Created:** [January 11, 2021, 8:46am UTC](https://discuss.elastic.co/t/sql-data-to-elasticsearch-using-logstash-via-mysql-connector-jdbc-plugin/260686 "2021-01-11T08:46:18Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![panfan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/panfan/32/82008_2.png) [@panfan](https://discuss.elastic.co/u/panfan)\
**Post date:** [January 11, 2021, 8:46am UTC](https://discuss.elastic.co/t/sql-data-to-elasticsearch-using-logstash-via-mysql-connector-jdbc-plugin/260686/1 "2021-01-11T08:46:19Z")

</div>

Hello,  
I am having trouble giving input to the elasticearch from data of MySQL via logstash.  
The following is my simple config file:  
input {  
jdbc {  
clean\_run =\> true  
jdbc\_driver\_library =\> "mysql-connector-java-5.1.49-bin.jar"  
jdbc\_driver\_class =\> "com.mysql.jdbc.Driver"  
jdbc\_connection\_string =\> "jdbc:mysql://localhost:3306/honeypot"  
jdbc\_user =\> "root"  
jdbc\_password =\> "1234"  
statement =\> "SELECT \* from honLogs"  
}  
}

output{  
elasticsearch {  
hosts =\> ["localhost:9200"]  
index =\> "honLogs"   
}  
stdout { codec =\> rubydebug }  
}

* * *

I am getting this error when trying to upload to Kibana via logstash:

 ![logstash erro1](https://us1.discourse-cdn.com/elastic/original/3X/e/a/ea4399a6d4362a0ae20ab6d4fa34561ae212644c.png)

## C:\Elastic\_stack\logstash-7.8.1\>logstash -f config/logstash\_mysql\_1.conf Java HotSpot(TM) 64-Bit Server VM warning: Ignoring option UseConcMarkSweepGC; support was removed in 14.0 Java HotSpot(TM) 64-Bit Server VM warning: Ignoring option CMSInitiatingOccupancyFraction; support was removed in 14.0 Java HotSpot(TM) 64-Bit Server VM warning: Ignoring option UseCMSInitiatingOccupancyOnly; support was removed in 14.0 WARNING: An illegal reflective access operation has occurred WARNING: Illegal reflective access by com.headius.backport9.modules.Modules (file:/C:/Elastic\_stack/logstash-7.8.1/logstash-core/lib/jars/jruby-complete-9.2.11.1.jar) to field java.io.Console.cs WARNING: Please consider reporting this to the maintainers of com.headius.backport9.modules.Modules WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations WARNING: All illegal access operations will be denied in a future release Sending Logstash logs to C:/Elastic\_stack/logstash-7.8.1/logs which is now configured via log4j2.properties [2021-01-11T16:40:44,644][WARN][logstash.config.source.multilocal] Ignoring the 'pipelines.yml' file because modules or command line options are specified [2021-01-11T16:40:44,733][INFO][logstash.runner] Starting Logstash {"logstash.version"=\>"7.8.1", "jruby.version"=\>"jruby 9.2.11.1 (2.5.7) 2020-03-25 b1f55b1a40 Java HotSpot(TM) 64-Bit Server VM 14.0.2+12-46 on 14.0.2+12-46 +indy +jit [mswin32-x86\_64]"} [2021-01-11T16:40:46,066][INFO][org.reflections.Reflections] Reflections took 37 ms to scan 1 urls, producing 21 keys and 41 values [2021-01-11T16:40:47,048][INFO][logstash.outputs.elasticsearch][main] Elasticsearch pool URLs updated {:changes=\>{:removed=\>, :added=\>[[http://localhost:9200/](http://localhost:9200/)]}} [2021-01-11T16:40:47,200][WARN][logstash.outputs.elasticsearch][main] Restored connection to ES instance {:url=\>"[http://localhost:9200/](http://localhost:9200/)"} [2021-01-11T16:40:47,240][INFO][logstash.outputs.elasticsearch][main] ES Output version determined {:es\_version=\>7} [2021-01-11T16:40:47,244][WARN][logstash.outputs.elasticsearch][main] Detected a 6.x and above cluster: the `type` event field won't be used to determine the document \_type {:es\_version=\>7} [2021-01-11T16:43:45,772][ERROR][logstash.javapipeline][main][0de6c206ed3e0338a2d4327f3f018becd4ad4987b50eabb1f550d6d5a664c387] A plugin had an unrecoverable error. Will restart this plugin. Pipeline\_id:main Plugin: \<LogStash::Inputs::Jdbc jdbc\_user=\>"root", jdbc\_password=\>, statement=\>"SELECT \* from honLogs", clean\_run=\>true, jdbc\_driver\_library=\>"mysql-connector-java-5.1.49-bin.jar", jdbc\_connection\_string=\>"jdbc:mysql://localhost:3306/honeypot", id=\>"0de6c206ed3e0338a2d4327f3f018becd4ad4987b50eabb1f550d6d5a664c387", jdbc\_driver\_class=\>"com.mysql.jdbc.Driver", enable\_metric=\>true, codec=\>\<LogStash::Codecs::Plain id=\>"plain\_c8b47113-95c9-4912-82bb-fb9645950746", enable\_metric=\>true, charset=\>"UTF-8"\>, jdbc\_paging\_enabled=\>false, jdbc\_page\_size=\>100000, jdbc\_validate\_connection=\>false, jdbc\_validation\_timeout=\>3600, jdbc\_pool\_timeout=\>5, sql\_log\_level=\>"info", connection\_retry\_attempts=\>1, connection\_retry\_attempts\_wait\_time=\>0.5, plugin\_timezone=\>"utc", last\_run\_metadata\_path=\>"C:\Users\itlab/.logstash\_jdbc\_last\_run", use\_column\_value=\>false, tracking\_column\_type=\>"numeric", record\_last\_run=\>true, lowercase\_column\_names=\>true, use\_prepared\_statements=\>false\> Error: unable to load mysql-connector-java-5.1.49-bin.jar from :jdbc\_driver\_library, file not readable (please check user and group permissions for the path) Exception: LogStash::PluginLoadingError Stack: C:/Elastic\_stack/logstash-7.8.1/vendor/bundle/jruby/2.5.0/gems/logstash-integration-jdbc-5.0.5/lib/logstash/plugin\_mixins/jdbc/common.rb:47:in `block in load_driver_jars' org/jruby/RubyArray.java:1809:in `each' C:/Elastic\_stack/logstash-7.8.1/vendor/bundle/jruby/2.5.0/gems/logstash-integration-jdbc-5.0.5/lib/logstash/plugin\_mixins/jdbc/common.rb:42:in `load_driver_jars' C:/Elastic_stack/logstash-7.8.1/vendor/bundle/jruby/2.5.0/gems/logstash-integration-jdbc-5.0.5/lib/logstash/plugin_mixins/jdbc/common.rb:25:in `load\_driver' C:/Elastic\_stack/logstash-7.8.1/vendor/bundle/jruby/2.5.0/gems/logstash-integration-jdbc-5.0.5/lib/logstash/inputs/jdbc.rb:275:in `run' C:/Elastic_stack/logstash-7.8.1/logstash-core/lib/logstash/java_pipeline.rb:374:in `inputworker' C:/Elastic\_stack/logstash-7.8.1/logstash-core/lib/logstash/java\_pipeline.rb:365:in `block in start\_input'

Let me know what's the mistake how it can be rectified  
Thank you in advance.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 8, 2021, 8:46am UTC](https://discuss.elastic.co/t/sql-data-to-elasticsearch-using-logstash-via-mysql-connector-jdbc-plugin/260686/2 "2021-02-08T08:46:53Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
