# Sql module, pb with DB password characters

**URL:** https://discuss.elastic.co/t/sql-module-pb-with-db-password-characters/345375
**Category:** Beats
**Tags:** metricbeat
**Created:** [October 19, 2023, 10:02am UTC](https://discuss.elastic.co/t/sql-module-pb-with-db-password-characters/345375 "2023-10-19T10:02:27Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![ppic](https://avatars.discourse-cdn.com/v4/letter/p/3da27b/32.png) [@ppic](https://discuss.elastic.co/u/ppic)
#### Post date: [October 19, 2023, 10:02am UTC](https://discuss.elastic.co/t/sql-module-pb-with-db-password-characters/345375/1 "2023-10-19T10:02:27Z")

</div>

Hello,  
I use Elastic 7.17 with metricbeat and the sql module.  
The DB connection fails with this line in the log:

```auto
error opening connection: testing connection: parse "sqlserver://elk:J6": invalid port ":J6" after host

```

The DB user is 'elk' and its password begins with 'J6#p'

So I guess the character # in the password is forbidden.  
What are the others ?  
Where are the rules ? (I couldn't find in the docs)

Thank you

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [November 16, 2023, 12:03pm UTC](https://discuss.elastic.co/t/sql-module-pb-with-db-password-characters/345375/2 "2023-11-16T12:03:26Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
