# SQL Server JDBC on Linux box

**URL:** <https://discuss.elastic.co/t/sql-server-jdbc-on-linux-box/17322>\
**Category:** Elasticsearch\
**Created:** [May 2, 2014, 7:29pm UTC](https://discuss.elastic.co/t/sql-server-jdbc-on-linux-box/17322 "2014-05-02T19:29:54Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![anthony\_2](https://avatars.discourse-cdn.com/v4/letter/a/bcef8e/32.png) [@anthony\_2](https://discuss.elastic.co/u/anthony_2)\
**Post date:** [May 2, 2014, 7:29pm UTC](https://discuss.elastic.co/t/sql-server-jdbc-on-linux-box/17322/1 "2014-05-02T19:29:54Z")

</div>

Hello - I am trying to get ElasticSearch run on Linux. I got it running on  
Windows, where I have some competence, but on Linux I am really struggling.  
It is actually running on the Linux box, but no matter what I do to try to  
talk to the SQL Server where the data is, I cannot get the app to find the  
JDBC diriver. I updated classpath ES\_CLASSPATH and moved sqljdbc4 and then  
sqljdbc.jar files to the directory /var/lib but that was a no-go as well. I  
am running out of ways to try to get ElasticSearch to recognize this JDBC  
driver. ANy ideas how to FORCE this to work? I can hit ElasticSearch from  
another box on :9200 using Marvel sense, but when I try to populate the  
river...BOOM - class not found

- "error": "NoClassSettingsException[Failed to load class with value  
[jdbc]]; nested: ClassNotFoundException[jdbc]; ",\*

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/46771095-0be2-4897-accd-86ab5f2603c7%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/46771095-0be2-4897-accd-86ab5f2603c7%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [May 2, 2014, 7:39pm UTC](https://discuss.elastic.co/t/sql-server-jdbc-on-linux-box/17322/2 "2014-05-02T19:39:13Z")

</div>

put your jdbc jar files in /plugins/river-jdbc dir and it should work.

That said, I think that your river command creation is incorrect but hard to tell without more details.

--  
David Pilato | Technical Advocate | [Elasticsearch.com](http://Elasticsearch.com)  
@dadoonet | @elasticsearchfr

Le 2 mai 2014 à 21:29:57, anthony@neo-liberalism.org (anthony@neo-liberalism.org) a écrit:

Hello - I am trying to get ElasticSearch run on Linux. I got it running on Windows, where I have some competence, but on Linux I am really struggling. It is actually running on the Linux box, but no matter what I do to try to talk to the SQL Server where the data is, I cannot get the app to find the JDBC diriver. I updated classpath ES\_CLASSPATH and moved sqljdbc4 and then sqljdbc.jar files to the directory /var/lib but that was a no-go as well. I am running out of ways to try to get ElasticSearch to recognize this JDBC driver. ANy ideas how to FORCE this to work? I can hit ElasticSearch from another box on :9200 using Marvel sense, but when I try to populate the river...BOOM - class not found

## "error": "NoClassSettingsException[Failed to load class with value [jdbc]]; nested: ClassNotFoundException[jdbc]; ",

You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/46771095-0be2-4897-accd-86ab5f2603c7%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/46771095-0be2-4897-accd-86ab5f2603c7%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/etPan.5363f461.613efdc5.2280%40MacBook-Air-de-David.local](https://groups.google.com/d/msgid/elasticsearch/etPan.5363f461.613efdc5.2280%40MacBook-Air-de-David.local).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![anthony\_2](https://avatars.discourse-cdn.com/v4/letter/a/bcef8e/32.png) [@anthony\_2](https://discuss.elastic.co/u/anthony_2)\
**Post date:** [May 2, 2014, 8:00pm UTC](https://discuss.elastic.co/t/sql-server-jdbc-on-linux-box/17322/3 "2014-05-02T20:00:35Z")

</div>

Hello - That was a no-go unfortunately...same error after I copied to that  
path. I am using same JSON I used to set up river on Windows and it  
worked, so I would think the river command is fine. The error specifically  
references the jdbc driver. I saw some postings about case sensitivity  
when referencing the the driver, but that is not an issue in my  
command...case is correct

On Friday, May 2, 2014 12:39:13 PM UTC-7, David Pilato wrote:

> put your jdbc jar files in /plugins/river-jdbc dir and it should work.
> 
> That said, I think that your river command creation is incorrect but hard  
> to tell without more details.
> 
> --  
> _David Pilato_ | _Technical Advocate_ | _[Elasticsearch.com](http://Elasticsearch.com)_  
> @dadoonet [https://twitter.com/dadoonet](https://twitter.com/dadoonet) | @elasticsearchfr[https://twitter.com/elasticsearchfr](https://twitter.com/elasticsearchfr)
> 
> Le 2 mai 2014 à 21:29:57, [ant...@neo-liberalism.org](mailto:ant...@neo-liberalism.org) \<javascript:\> (  
> [ant...@neo-liberalism.org](mailto:ant...@neo-liberalism.org) \<javascript:\>) a écrit:
> 
> Hello - I am trying to get Elasticsearch run on Linux. I got it running on  
> Windows, where I have some competence, but on Linux I am really struggling.  
> It is actually running on the Linux box, but no matter what I do to try to  
> talk to the SQL Server where the data is, I cannot get the app to find the  
> JDBC diriver. I updated classpath ES\_CLASSPATH and moved sqljdbc4 and then  
> sqljdbc.jar files to the directory /var/lib but that was a no-go as well. I  
> am running out of ways to try to get Elasticsearch to recognize this JDBC  
> driver. ANy ideas how to FORCE this to work? I can hit Elasticsearch from  
> another box on :9200 using Marvel sense, but when I try to populate the  
> river...BOOM - class not found
> 
> - "error": "NoClassSettingsException[Failed to load class with value  
> [jdbc]]; nested: ClassNotFoundException[jdbc]; ",\*  
> --  
> You received this message because you are subscribed to the Google Groups  
> "elasticsearch" group.  
> To unsubscribe from this group and stop receiving emails from it, send an  
> email to [elasticsearc...@googlegroups.com](mailto:elasticsearc...@googlegroups.com) \<javascript:\>.  
> To view this discussion on the web visit  
> [https://groups.google.com/d/msgid/elasticsearch/46771095-0be2-4897-accd-86ab5f2603c7%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/46771095-0be2-4897-accd-86ab5f2603c7%40googlegroups.com)[https://groups.google.com/d/msgid/elasticsearch/46771095-0be2-4897-accd-86ab5f2603c7%40googlegroups.com?utm\_medium=email&utm\_source=footer](https://groups.google.com/d/msgid/elasticsearch/46771095-0be2-4897-accd-86ab5f2603c7%40googlegroups.com?utm_medium=email&utm_source=footer)  
> .  
> For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/496d57dd-73d6-4f87-8ca0-bbb9d624d753%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/496d57dd-73d6-4f87-8ca0-bbb9d624d753%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![jprante](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jprante/32/44941_2.png) [@jprante](https://discuss.elastic.co/u/jprante)\
**Post date:** [May 3, 2014, 12:47pm UTC](https://discuss.elastic.co/t/sql-server-jdbc-on-linux-box/17322/4 "2014-05-03T12:47:08Z")

</div>

From the single line I can read (_Failed to load class with value [jdbc]]_),  
you did not install the JDBC river correctly, it does not start at all.

If you can give a list of commands you used to install, and the files plus  
file attributes in all the directories in Elasticsearch plugins folder, and  
a complete log file of the node startup sequence, it would be a lot easier  
to help.

Jörg

On Fri, May 2, 2014 at 10:00 PM, [anthony@neo-liberalism.org](mailto:anthony@neo-liberalism.org) wrote:

> Hello - That was a no-go unfortunately...same error after I copied to that  
> path. I am using same JSON I used to set up river on Windows and it  
> worked, so I would think the river command is fine. The error specifically  
> references the jdbc driver. I saw some postings about case sensitivity  
> when referencing the the driver, but that is not an issue in my  
> command...case is correct

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/CAKdsXoGyRRGX2rASvjSRFMMTbmhGjr7CJyZGG1s58DE2fKYaUw%40mail.gmail.com](https://groups.google.com/d/msgid/elasticsearch/CAKdsXoGyRRGX2rASvjSRFMMTbmhGjr7CJyZGG1s58DE2fKYaUw%40mail.gmail.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![anthony\_2](https://avatars.discourse-cdn.com/v4/letter/a/bcef8e/32.png) [@anthony\_2](https://discuss.elastic.co/u/anthony_2)\
**Post date:** [May 6, 2014, 7:41pm UTC](https://discuss.elastic.co/t/sql-server-jdbc-on-linux-box/17322/5 "2014-05-06T19:41:31Z")

</div>

OK,I am back with good news. I got things to work on my Ubuntu laptop.  
My problem appears to have been related to the original River install. I  
was getting errors in the log that I did not notice and then I started  
moving JAR files around and made a mess of things. I backed away, deleted  
my bad version of the JDBC plugin and reinstalled the correct version for  
the version of Elasticsearch I had on the box, then put the JAR files in  
the new river-jdbc directory Viola! She worked.  
Yahoo!  
Thanks,  
~aw

On Saturday, May 3, 2014 5:47:08 AM UTC-7, Jörg Prante wrote:

> From the single line I can read (_Failed to load class with value [jdbc]]_),  
> you did not install the JDBC river correctly, it does not start at all.
> 
> If you can give a list of commands you used to install, and the files plus  
> file attributes in all the directories in Elasticsearch plugins folder, and  
> a complete log file of the node startup sequence, it would be a lot easier  
> to help.
> 
> Jörg
> 
> On Fri, May 2, 2014 at 10:00 PM, \<[ant...@neo-liberalism.org](mailto:ant...@neo-liberalism.org) \<javascript:\>\>wrote:
> 
> > Hello - That was a no-go unfortunately...same error after I copied to  
> > that path. I am using same JSON I used to set up river on Windows and it  
> > worked, so I would think the river command is fine. The error specifically  
> > references the jdbc driver. I saw some postings about case sensitivity  
> > when referencing the the driver, but that is not an issue in my  
> > command...case is correct

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/77c86853-ea7c-41bc-805b-30d47a247c1c%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/77c86853-ea7c-41bc-805b-30d47a247c1c%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 1:31am UTC](https://discuss.elastic.co/t/sql-server-jdbc-on-linux-box/17322/6 "2017-07-06T01:31:17Z")

</div>


