# Sqlite plugin encountering error

**URL:** <https://discuss.elastic.co/t/sqlite-plugin-encountering-error/93245>\
**Category:** Logstash\
**Created:** [July 14, 2017, 9:44pm UTC](https://discuss.elastic.co/t/sqlite-plugin-encountering-error/93245 "2017-07-14T21:44:27Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![rsaeks](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rsaeks/32/5068_2.png) [@rsaeks](https://discuss.elastic.co/u/rsaeks)\
**Post date:** [July 14, 2017, 9:44pm UTC](https://discuss.elastic.co/t/sqlite-plugin-encountering-error/93245/1 "2017-07-14T21:44:27Z")

</div>

I'm using the sqlite logstash input plugin (logstash-input-sqlite (3.0.1)) and have built the following configuration:

input {  
sqlite {  
path =\> "/tmp/db2.sqlite"  
type =\> weblogs  
}  
}  
output {  
file { path =\> "/tmp/munkireport.log" }  
}

When starting logstash using my config file I receive the following output:

16:37:37.481 [[main]-pipeline-manager] INFO logstash.pipeline - Starting pipeline {"id"=\>"main", "pipeline.workers"=\>1, "pipeline.batch.size"=\>125, "pipeline.batch.delay"=\>5, "pipeline.max\_inflight"=\>125}  
16:37:37.738 [[main]-pipeline-manager] INFO logstash.inputs.sqlite - Registering sqlite input {:database=\>"/tmp/db2.sqlite"}  
16:37:40.066 [[main]-pipeline-manager] INFO logstash.pipeline - Pipeline main started  
16:37:40.123 [[main]\<sqlite] ERROR logstash.pipeline - A plugin had an unrecoverable error. Will restart this plugin.  
Plugin: \<LogStash::Inputs::Sqlite path=\>"/tmp/db2.sqlite", type=\>"weblogs", id=\>"323b83b85615a5218856bbe86bdc9f0e06d35a20-1", enable\_metric=\>true, codec=\>\<LogStash::Codecs::Plain id=\>"plain\_4cdffeab-4b4f-49e8-a5f9-7580a8684c6e", enable\_metric=\>true, charset=\>"UTF-8"\>, batch=\>5\>  
Error: Missing Valuefier handling for full class name=org.jruby.RubyObject, simple name=RubyObject  
16:37:40.168 [Api Webserver] INFO logstash.agent - Successfully started Logstash API endpoint {:port=\>9600}  
16:37:41.146 [[main]\<sqlite] ERROR logstash.pipeline - A plugin had an unrecoverable error. Will restart this plugin.  
Plugin: \<LogStash::Inputs::Sqlite path=\>"/tmp/db2.sqlite", type=\>"weblogs", id=\>"323b83b85615a5218856bbe86bdc9f0e06d35a20-1", enable\_metric=\>true, codec=\>\<LogStash::Codecs::Plain id=\>"plain\_4cdffeab-4b4f-49e8-a5f9-7580a8684c6e", enable\_metric=\>true, charset=\>"UTF-8"\>, batch=\>5\>  
Error: Missing Valuefier handling for full class name=org.jruby.RubyObject, simple name=RubyObject

The plugin then continues to relaunch until manually stopped. The line of interest from there is:  
Error: Missing Valuefier handling for full class name=org.jruby.RubyObject, simple name=RubyObject

Does anyone know what that means and how to get the issue resolved? This is on the Logstash 5.5

Thanks!

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 11, 2017, 9:44pm UTC](https://discuss.elastic.co/t/sqlite-plugin-encountering-error/93245/2 "2017-08-11T21:44:47Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
