# SQS Input Not working - SOLVED

**URL:** <https://discuss.elastic.co/t/sqs-input-not-working-solved/82458>\
**Category:** Logstash\
**Created:** [April 15, 2017, 1:19am UTC](https://discuss.elastic.co/t/sqs-input-not-working-solved/82458 "2017-04-15T01:19:26Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Wayne\_Taylor](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/wayne_taylor/32/45984_2.png) [@Wayne\_Taylor](https://discuss.elastic.co/u/Wayne_Taylor)\
**Post date:** [April 15, 2017, 1:19am UTC](https://discuss.elastic.co/t/sqs-input-not-working-solved/82458/1 "2017-04-15T01:19:26Z")

</div>

Hi,

I have a very simple conf right now. Logstash 5.3.0.

```
input{
sqs{
	queue => "somename"
}
}

```

If i run I get the following error:

> [2017-04-14T20:08:55,084][INFO][logstash.pipeline] Starting pipeline {"id"=\>"main", "pipeline.workers"=\>8, "pipeline.batch.size"=\>125, "pipeline.batch.delay"=\>5, "pipeline.max\_inflight"=\>1000}  
> [2017-04-14T20:08:55,222][INFO][logstash.inputs.sqs] Registering SQS input {:queue=\>"arn:aws:sqs:us-east-1:blah:gblah"}  
> [2017-04-14T20:08:56,477][ERROR][logstash.pipeline] Error registering plugin {:plugin=\>"\<LogStash::Inputs::SQS queue=\>"arn:aws:sqs:us-east-1:blah:blah", access\_key\_id=\>"mykey", secret\_access\_key=\>"mykey", id=\>"1e091a08a7008d264edbfa83ca39eb34bc07b0b9-1", enable\_metric=\>true, codec=\>\<LogStash::Codecs::JSON id=\>"json\_ddba32fe-101d-4023-94f6-d1bfeaf70eaa", enable\_metric=\>true, charset=\>"UTF-8"\>, threads=\>1, region=\>"us-east-1", polling\_frequency=\>20\>", :error=\>"uninitialized constant Aws::Client::Errors"}  
> [2017-04-14T20:08:56,523][ERROR][logstash.agent] Pipeline aborted due to error {:exception=\>#\<NameError: uninitialized constant Aws::Client::Errors\>, :backtrace=\>["org/jruby/RubyModule.java:2719:in `const_missing'", "org/jruby/RubyModule.java:2638:in `const\_get'", "/Users/wtaylor/Downloads/logstash-5.3.0/vendor/bundle/jruby/1.9/gems/aws-sdk-core-2.3.22/lib/aws-sdk-co

If i run AWS CLI Commands it works fine:

> wtaylor@wtaylor-mbp  ~/Downloads/logstash-5.3.0/bin  aws sqs receive-message --queue-url=[https://sqs.us-east-1.amazonaws.com/blah/queuq](https://sqs.us-east-1.amazonaws.com/blah/queuq)  
> {  
> "Messages": [  
> {  
> "Body": "{\n "Type" : "Notification",\n "MessageId" : "11c9db02-598b-58e1-8412-8a6928294f77 etc....

Any Ideas?

Thanks  
Wayne

---

<div class="post-metadata">

**Author:** ![Wayne\_Taylor](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/wayne_taylor/32/45984_2.png) [@Wayne\_Taylor](https://discuss.elastic.co/u/Wayne_Taylor)\
**Post date:** [May 1, 2017, 5:45pm UTC](https://discuss.elastic.co/t/sqs-input-not-working-solved/82458/2 "2017-05-01T17:45:26Z")

</div>

Two issues here:

1. Appears I was using ARN vs the Queue name.
2. Jruby issue.. Putting into debug mode doesn't help troubleshoot. I noticed an open issue

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 29, 2017, 5:48pm UTC](https://discuss.elastic.co/t/sqs-input-not-working-solved/82458/3 "2017-05-29T17:48:43Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
