# SSL Error when using SSL with TCP output plugin

**URL:** <https://discuss.elastic.co/t/ssl-error-when-using-ssl-with-tcp-output-plugin/181277>\
**Category:** Logstash\
**Created:** [May 15, 2019, 10:14pm UTC](https://discuss.elastic.co/t/ssl-error-when-using-ssl-with-tcp-output-plugin/181277 "2019-05-15T22:14:23Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Tieis](https://avatars.discourse-cdn.com/v4/letter/t/ee7513/32.png) [@Tieis](https://discuss.elastic.co/u/Tieis)\
**Post date:** [May 15, 2019, 10:14pm UTC](https://discuss.elastic.co/t/ssl-error-when-using-ssl-with-tcp-output-plugin/181277/1 "2019-05-15T22:14:23Z")

</div>

Hi,

I'm trying to use ssl for tcp output plugin for logstash. The workflow goes to a nginx-proxy ssl termination point for logstash that will forward the logs to a logstash pod that takes in tcp input.  
My output part for logstash looks like this:  
output {  
tcp {  
host =\> "172.20.45.41"  
port =\> 30002  
ssl\_enable =\> true  
ssl\_verify =\> false  
ssl\_cacert =\> "/usr/share/logstash/ca/ca.crt.pem"  
ssl\_cert =\> "/usr/share/ssl/client.crt"  
ssl\_key =\> "/usr/share/ssl/client.key"  
codec =\> json\_lines  
}  
}  
The client.crt and key have been created from the client cert/private key pair in the nginx-proxy server.

Has anyone seen an error like this?  
SSL Error {:exception=\>#\<OpenSSL::SSL::SSLError: Socket closed\>, :backtrace=\>["org/jruby/ext/openssl/SSLSocket.java:266:in `connect'", "/usr/share/logstash/vendor/bundle/jruby/2.3.0/gems/logstash-output-tcp-5.0.3/lib/logstash/outputs/tcp.rb:179:in`block in connect'", "/usr/share/logstash/vendor/bundle/jruby/2.3.0/gems/stud-0.0.23/lib/stud/try.rb:79:in `block in try'", "/usr/share/logstash/vendor/bundle/jruby/2.3.0/gems/stud-0.0.23/lib/stud/try.rb:95:in`block in try'", "/usr/share/logstash/vendor/bundle/jruby/2.3.0/gems/stud-0.0.23/lib/stud/try.rb:20:in `each'", "/usr/share/logstash/vendor/bundle/jruby/2.3.0/gems/stud-0.0.23/lib/stud/try.rb:91:in`try'", "/usr/share/logstash/vendor/bundle/jruby/2.3.0/gems/stud-0.0.23/lib/stud/try.rb:123:in `try'", "/usr/share/logstash/vendor/bundle/jruby/2.3.0/gems/logstash-output-tcp-5.0.3/lib/logstash/outputs/tcp.rb:174:in`connect'", "/usr/share/logstash/vendor/bundle/jruby/2.3.0/gems/logstash-output-tcp-5.0.3/lib/logstash/outputs/tcp.rb:151:in `block in register'", "/usr/share/logstash/vendor/bundle/jruby/2.3.0/gems/logstash-codec-json_lines-3.0.6/lib/logstash/codecs/json_lines.rb:48:in`encode'", "/usr/share/logstash/vendor/bundle/jruby/2.3.0/gems/logstash-output-tcp-5.0.3/lib/logstash/outputs/tcp.rb:201:in `receive'", "/usr/share/logstash/logstash-core/lib/logstash/outputs/base.rb:89:in`block in multi\_receive'", "org/jruby/RubyArray.java:1734:in `each'", "/usr/share/logstash/logstash-core/lib/logstash/outputs/base.rb:89:in`multi\_receive'", "org/logstash/config/ir/compiler/OutputStrategyExt.java:114:in `multi_receive'", "org/logstash/config/ir/compiler/AbstractOutputDelegatorExt.java:97:in`multi\_receive'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:373:in `block in output_batch'", "org/jruby/RubyHash.java:1343:in`each'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:372:in `output_batch'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:324:in`worker\_loop'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:286:in `block in start\_workers'"]}

---

<div class="post-metadata">

**Author:** ![Tieis](https://avatars.discourse-cdn.com/v4/letter/t/ee7513/32.png) [@Tieis](https://discuss.elastic.co/u/Tieis)\
**Post date:** [May 21, 2019, 4:14pm UTC](https://discuss.elastic.co/t/ssl-error-when-using-ssl-with-tcp-output-plugin/181277/2 "2019-05-21T16:14:30Z")

</div>

Found the cause last week; it was because of the certificate I was using was being revoked by CRL in nginx proxy.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 18, 2019, 4:14pm UTC](https://discuss.elastic.co/t/ssl-error-when-using-ssl-with-tcp-output-plugin/181277/3 "2019-06-18T16:14:32Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
