# Start from zero with a new cluster

**URL:** <https://discuss.elastic.co/t/start-from-zero-with-a-new-cluster/263843>\
**Category:** Elasticsearch\
**Created:** [February 10, 2021, 8:12am UTC](https://discuss.elastic.co/t/start-from-zero-with-a-new-cluster/263843 "2021-02-10T08:12:14Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![grillo](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/grillo/32/84079_2.png) [@grillo](https://discuss.elastic.co/u/grillo)\
**Post date:** [February 10, 2021, 8:12am UTC](https://discuss.elastic.co/t/start-from-zero-with-a-new-cluster/263843/1 "2021-02-10T08:12:14Z")

</div>

Hi all,

I've been working with this ELK solution for a few years and I can't restart all the nodes in a cluster to ... start from zero with a new cluster

1st - Delete all stored data

I can delete indexes ... (from command line)

curl -X DELETE "node: port / index\_name"

for example a full erase

curl -X DELETE "192.168.72.10:9200/\*"

2nd - Configure a new cluster - clean

**My new cluster**

**Node: prso-home-1 (192.168.72.4)**

cluster.name: PRSO\_2021

node.name: prso-home-1

node.ingest: true

node.data: true

node.master: true

path.data: / var / lib / elasticsearch

path.logs: / var / log / elasticsearch

network.host: 192.168.72.4

discovery.seed\_hosts: ["192.168.72.4", "192.168.72.5", "192.168.72.10", "192.168.72.20"]

cluster.initial\_master\_nodes: ["prso-elk-viten-1", "prso-home-1", "prso-elk-dm-1"]

**Node: prso-elk-dm-1 (192.168.72.10)**

cluster.name: PRSO\_2021

node.name: prso-elk-dm-1

node.ingest: true

node.data: true

node.master: true

path.data: / var / lib / elasticsearch

path.logs: / var / log / elasticsearch

network.host: 192.168.72.10

discovery.seed\_hosts: ["192.168.72.10", "192.168.72.4", "192.168.72.5", "192.168.72.20"]

cluster.initial\_master\_nodes: ["prso-elk-viten-1", "prso-home-1", "prso-elk-dm-1"]

**Node: prso-elk-viten-1 (192.168.72.20)**

cluster.name: PRSO\_2021

node.name: prso-elk-viten-1

node.ingest: true

node.data: true

node.master: true

path.data: / var / lib / elasticsearch

path.logs: / var / log / elasticsearch

network.host: 192.168.72.20

discovery.seed\_hosts: ["192.168.72.20", "192.168.72.4", "192.168.72.5", "192.168.72.10"]

cluster.initial\_master\_nodes: ["prso-elk-viten-1", "prso-home-1", "prso-elk-dm-1"]

**The node 192.168.72.5 I have not yet turned on**

Errors - received:

**Prso-home-1 node**

[2021-02-10T07: 47: 43,900] [WARN] [oeccCoordinator] [prso-home-1] failed to validate incoming join request from node [{prso-elk-viten-1} {ZPUhwBeiRM65AllVbmAnPA} {deSn9qdBRO-MxBuwWIOqNA } {192.168.72.20} {192.168.72.20:9300} {cdhilmrstw} {ml.machine\_memory = 8589934592, ml.max\_open\_jobs = 20, xpack.installed = true, transform.node = true}]

org.elasticsearch.transport.RemoteTransportException: [prso-elk-viten-1] [192.168.72.20:9300] [internal: cluster / coordination / join / validate]

**Prso-elk-viten-1 node**

Caused by: org.elasticsearch.transport.RemoteTransportException: [prso-elk-viten-1] [192.168.72.20:9300] [internal: cluster / coordination / join / validate]

Caused by: org.elasticsearch.cluster.coordination.CoordinationStateRejectedException: join validation on cluster state with a different cluster uuid 1epEQFGfRgqPhi7Z1qfQ1Q than local cluster uuid nx6DeRiiTXS1zwX3gf6BvQ, rejecting

**Prso-elk-dm-1 node**

[2021-02-10T00: 40: 59,182] [INFO] [oecsClusterApplierService] [prso-elk-dm-1] master node changed {previous [{prso-home-1} {X-qTdaIoSuKqud-1AIayZQ} {BKUNpp47SaW82wXMMgmgyw} {192.168.72.4} {192.168.72.4:9300} {cdhilmrstw} {ml.machine\_memory = 7516192768, ml.max\_open\_jobs = 20, xpack.installed = true, transform.node = true}], current }, term: 475 , version: 191, reason: becoming candidate: onLeaderFailure

**Objective -** reset the nodes to initialize a new cluster - clean and with new roles

Some advice before uninstalling elasticsearch - delete all files - reinstall elasticsearch ... let's see what happens.

Thank you very much

Pablo

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 10, 2021, 8:12am UTC](https://discuss.elastic.co/t/start-from-zero-with-a-new-cluster/263843/2 "2021-03-10T08:12:15Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
