# Start\_position =\> "end"

**URL:** <https://discuss.elastic.co/t/start-position-end/141536>\
**Category:** Logstash\
**Created:** [July 25, 2018, 9:58am UTC](https://discuss.elastic.co/t/start-position-end/141536 "2018-07-25T09:58:43Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![Pierre2](https://avatars.discourse-cdn.com/v4/letter/p/da6949/32.png) [@Pierre2](https://discuss.elastic.co/u/Pierre2)\
**Post date:** [July 25, 2018, 9:58am UTC](https://discuss.elastic.co/t/start-position-end/141536/1 "2018-07-25T09:58:43Z")

</div>

Hello,

I used to set the start position to "beginning" but now I want to set the value to "end". The problem is that after setting the start\_position to "end" logstash does not parse my logs anymore.

I already tried to erase the start\_position line from my config file beacause "end" is the default value but the result is the same.

---

<div class="post-metadata">

**Author:** ![guyboertje](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/guyboertje/32/31592_2.png) [@guyboertje](https://discuss.elastic.co/u/guyboertje)\
**Post date:** [July 25, 2018, 10:03am UTC](https://discuss.elastic.co/t/start-position-end/141536/2 "2018-07-25T10:03:11Z")

</div>

What version of the file input are you using?

---

<div class="post-metadata">

**Author:** ![Pierre2](https://avatars.discourse-cdn.com/v4/letter/p/da6949/32.png) [@Pierre2](https://discuss.elastic.co/u/Pierre2)\
**Post date:** [July 25, 2018, 10:08am UTC](https://discuss.elastic.co/t/start-position-end/141536/3 "2018-07-25T10:08:44Z")

</div>

I use logstash 6.3 if that's your question. There is my input config. If I change the "end" to "beginning" it works.

> input {  
> file{  
> path =\> "C:\Users\u1\Docs\Elasticsearch\Logs\CDR-SBC\*"  
> start\_position =\> "end"  
> sincedb\_path =\> "/dev/null"  
> tags =\> ["cdr"]  
> codec =\> plain {  
> charset =\> "ISO-8859-1"  
> }  
> }  
> }

---

<div class="post-metadata">

**Author:** ![guyboertje](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/guyboertje/32/31592_2.png) [@guyboertje](https://discuss.elastic.co/u/guyboertje)\
**Post date:** [July 25, 2018, 10:12am UTC](https://discuss.elastic.co/t/start-position-end/141536/4 "2018-07-25T10:12:47Z")

</div>

the plugin version.

`bin/logstash-plugin list --verbose | grep "input-file"`

---

<div class="post-metadata">

**Author:** ![Pierre2](https://avatars.discourse-cdn.com/v4/letter/p/da6949/32.png) [@Pierre2](https://discuss.elastic.co/u/Pierre2)\
**Post date:** [July 25, 2018, 10:14am UTC](https://discuss.elastic.co/t/start-position-end/141536/5 "2018-07-25T10:14:38Z")

</div>

I'm using logstash-input-file 4.0.5

I just tied to update my plugins but I got a error :

Error Bundler::HTTPError, retrying 1/10  
Could not fetch specs from [https://rubygems.org/](https://rubygems.org/)

---

<div class="post-metadata">

**Author:** ![guyboertje](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/guyboertje/32/31592_2.png) [@guyboertje](https://discuss.elastic.co/u/guyboertje)\
**Post date:** [July 25, 2018, 10:31am UTC](https://discuss.elastic.co/t/start-position-end/141536/6 "2018-07-25T10:31:28Z")

</div>

You need v4.1.5. A regression bug was fixed in that version that concerned the handling of `start_position`.

Is your Logstash machine connected to the internet?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 22, 2018, 11:11am UTC](https://discuss.elastic.co/t/start-position-end/141536/8 "2018-08-22T11:11:09Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
