# Start up logstash

**URL:** <https://discuss.elastic.co/t/start-up-logstash/130852>\
**Category:** Logstash\
**Created:** [May 7, 2018, 2:50pm UTC](https://discuss.elastic.co/t/start-up-logstash/130852 "2018-05-07T14:50:11Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![MrNerd](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mrnerd/32/30763_2.png) [@MrNerd](https://discuss.elastic.co/u/MrNerd)\
**Post date:** [May 7, 2018, 2:50pm UTC](https://discuss.elastic.co/t/start-up-logstash/130852/1 "2018-05-07T14:50:12Z")

</div>

Hy there!

I have already install logstash 6.2 version and try to start it and it shows an error

> root@Logstash:~# service logstash status -l  
> ● logstash.service - logstash  
> Loaded: loaded (/etc/systemd/system/logstash.service; disabled)  
> Active: failed (Result: start-limit) since lun 2018-05-07 16:41:36 CEST; 15s ago  
> Process: 1581 ExecStart=/usr/share/logstash/bin/logstash --path.settings /etc/logstash (code=exited, status=1/FAILURE)  
> Main PID: 1581 (code=exited, status=1/FAILURE)  
> may 07 16:41:36 Logstash systemd[1]: logstash.service: main process exited, code=exited, status=1/FAILURE  
> may 07 16:41:36 Logstash systemd[1]: Unit logstash.service entered failed state.  
> may 07 16:41:36 Logstash systemd[1]: logstash.service holdoff time over, scheduling restart.  
> may 07 16:41:36 Logstash systemd[1]: Stopping logstash...  
> may 07 16:41:36 Logstash systemd[1]: Starting logstash...  
> may 07 16:41:36 Logstash systemd[1]: logstash.service start request repeated too quickly, refusing to start.  
> may 07 16:41:36 Logstash systemd[1]: Failed to start logstash.  
> may 07 16:41:36 Logstash systemd[1]: Unit logstash.service entered failed state.

i have tried to do it in this way too but keeps the error:

> root@Logstash:~# systemctl stop logstash.service  
> root@Logstash:~# systemctl start logstash.service  
> ● logstash.service - logstash  
> Loaded: loaded (/etc/systemd/system/logstash.service; disabled)  
> Active: failed (Result: start-limit) since lun 2018-05-07 16:43:48 CEST; 6s ago  
> Process: 1722 ExecStart=/usr/share/logstash/bin/logstash --path.settings /etc/logstash (code=exited, status=1/FAILURE)  
> Main PID: 1722 (code=exited, status=1/FAILURE)  
> may 07 16:43:48 Logstash systemd[1]: logstash.service: main process exited, code=exited, status=1/FAILURE  
> may 07 16:43:48 Logstash systemd[1]: Unit logstash.service entered failed state.  
> may 07 16:43:48 Logstash systemd[1]: logstash.service holdoff time over, scheduling restart.  
> may 07 16:43:48 Logstash systemd[1]: Stopping logstash...  
> may 07 16:43:48 Logstash systemd[1]: Starting logstash...  
> may 07 16:43:48 Logstash systemd[1]: logstash.service start request repeated too quickly, refusing to start.  
> may 07 16:43:48 Logstash systemd[1]: Failed to start logstash.  
> may 07 16:43:48 Logstash systemd[1]: Unit logstash.service entered failed state.

my **java version** is this one:

> root@Logstash:~# java -version  
> java version "1.7.0\_171"  
> OpenJDK Runtime Environment (IcedTea 2.6.13) (7u171-2.6.13-1~deb8u1)  
> OpenJDK 64-Bit Server VM (build 24.171-b02, mixed mode)

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [May 7, 2018, 2:56pm UTC](https://discuss.elastic.co/t/start-up-logstash/130852/2 "2018-05-07T14:56:38Z")

</div>

As per the [Support Matrix](https://www.elastic.co/support/matrix#matrix_jvm), Logstash 6.2 requires Java8.

---

<div class="post-metadata">

**Author:** ![MrNerd](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mrnerd/32/30763_2.png) [@MrNerd](https://discuss.elastic.co/u/MrNerd)\
**Post date:** [May 7, 2018, 3:12pm UTC](https://discuss.elastic.co/t/start-up-logstash/130852/3 "2018-05-07T15:12:59Z")

</div>

@Christian_Dahlqvist I upgraded java and everithing is working fine. Thanks!!!

MrNerd

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 4, 2018, 3:13pm UTC](https://discuss.elastic.co/t/start-up-logstash/130852/4 "2018-06-04T15:13:13Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
