# Starting elasticsearch \[linux\] - failure

**URL:** <https://discuss.elastic.co/t/starting-elasticsearch-linux-failure/61530>\
**Category:** Elasticsearch\
**Created:** [September 26, 2016, 7:02pm UTC](https://discuss.elastic.co/t/starting-elasticsearch-linux-failure/61530 "2016-09-26T19:02:06Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![markdavis](https://avatars.discourse-cdn.com/v4/letter/m/e19adc/32.png) [@markdavis](https://discuss.elastic.co/u/markdavis)\
**Post date:** [September 26, 2016, 7:02pm UTC](https://discuss.elastic.co/t/starting-elasticsearch-linux-failure/61530/1 "2016-09-26T19:02:06Z")

</div>

I've installed elasticsearch v2.4 into our RHEL Linux server using the latest 2.4 RPM.  
Separately, I've installed Java Oracle version "1.8.0\_71".

I try to start elasticsearch

> sudo -i service elasticsearch start

I'm getting the following error mesage:

> Sep 26 13:04:29 [devpywdcdaas101.sl.bluecloud.ibm.com](http://devpywdcdaas101.sl.bluecloud.ibm.com) systemd[1]: Starting Elasticsearch...  
> Sep 26 13:04:29 [devpywdcdaas101.sl.bluecloud.ibm.com](http://devpywdcdaas101.sl.bluecloud.ibm.com) systemd[1]: Started Elasticsearch.  
> Sep 26 13:04:29 [devpywdcdaas101.sl.bluecloud.ibm.com](http://devpywdcdaas101.sl.bluecloud.ibm.com) systemd[1]: elasticsearch.service: main process exited, code=exited, status=1/FAILURE  
> Sep 26 13:04:29 [devpywdcdaas101.sl.bluecloud.ibm.com](http://devpywdcdaas101.sl.bluecloud.ibm.com) systemd[1]: Unit elasticsearch.service entered failed state.  
> Sep 26 13:04:29 [devpywdcdaas101.sl.bluecloud.ibm.com](http://devpywdcdaas101.sl.bluecloud.ibm.com) systemd[1]: elasticsearch.service failed.

> Starting elasticsearch: which: no java in (/sbin:/usr/sbin:/bin:/usr/bin)  
> Could not find any executable java binary. Please install java in your PATH or set JAVA\_HOME [FAILED]

The Java JDK was installed in the /opt/jdk1.8.0\_71

I've tried setting my JAVA\_HOME, JRE\_HOME and $PATH but it doesn't seem to matter.

> export JAVA\_HOME=/opt/jdk1.8.0\_71  
> export JRE\_HOME=/opt/jdk1.8.0\_71/jre/  
> export PATH=$PATH:/opt/jdk1.8.0\_71/bin:/opt/jdk1.8.0\_71/jre/bin

I do not know what should be done to allow elasticsearch to recognize the Java JDK.  
Is there a specific elasticsearch file which must be modified to allow this?

---

<div class="post-metadata">

**Author:** ![dakrone](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dakrone/32/23351_2.png) [@dakrone](https://discuss.elastic.co/u/dakrone)\
**Post date:** [September 26, 2016, 9:38pm UTC](https://discuss.elastic.co/t/starting-elasticsearch-linux-failure/61530/2 "2016-09-26T21:38:27Z")

</div>

Are you exporting the `JAVA_HOME` variable in your shell, or where elasticsearch starts?

It's possible you may need to put it in the environment configuration file, which I believe (if you installed from RPM) lives in `/etc/sysconfig/elasticsearch`.

---

<div class="post-metadata">

**Author:** ![markdavis](https://avatars.discourse-cdn.com/v4/letter/m/e19adc/32.png) [@markdavis](https://discuss.elastic.co/u/markdavis)\
**Post date:** [September 29, 2016, 11:18pm UTC](https://discuss.elastic.co/t/starting-elasticsearch-linux-failure/61530/3 "2016-09-29T23:18:24Z")

</div>

Thanks for your reply...  
Here's what my environment variables look like for the 'mesadmin' user in the shell..

> mesadmin@devpywdcdaas101 ~]$ export | grep PATH  
> **declare -x**  **PATH="/opt/jdk1.8.0\_71/bin:/opt/jdk1.8.0\_71/jre/bin:/usr/local/bin:/usr/bin:/usr/local/sbin:/usr/sbin:/home/mesadmin/.local/bin:/home/mesadmin/bin"**  
> [mesadmin@devpywdcdaas101 ~]$ export | grep JAVA\_HOME  
> **declare -x JAVA\_HOME="/opt/jdk1.8.0\_71"**  
> [mesadmin@devpywdcdaas101 ~]$ export | grep JRE\_HOME  
> **declare -x JRE\_HOME="/opt/jdk1.8.0\_71/jre"**

I attempt to run the elasticsearch service as "sudo", but I try to run w/ the` -E` opton to preserve the environment variables  
`sudo -E service elasticsearch start`

Yes, I did manually download/install via RPM.  
I have modified the elasticsearch configuration file you suggested.  
`/etc/sysconfig/elasticsearch`

Here's a portion of that file's contents...

```
**JAVA_HOME=/opt/jdk1.8.0_71**

################################
# Elasticsearch
################################
# Elasticsearch home directory
#ES_HOME=/usr/share/elasticsearch

# Elasticsearch configuration directory
#CONF_DIR=/etc/elasticsearch

# Elasticsearch data directory
#DATA_DIR=/var/lib/elasticsearch

# Elasticsearch logs directory
LOG_DIR=/var/log/elasticsearch

# Elasticsearch PID directory

```

aarg! I am still unable to start elasticsearch!

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 5, 2017, 10:16pm UTC](https://discuss.elastic.co/t/starting-elasticsearch-linux-failure/61530/4 "2017-07-05T22:16:00Z")

</div>


