# Starting elasticsearch on Debian jessie with systemd

**URL:** <https://discuss.elastic.co/t/starting-elasticsearch-on-debian-jessie-with-systemd/20744>\
**Category:** Elasticsearch\
**Created:** [November 14, 2014, 7:54am UTC](https://discuss.elastic.co/t/starting-elasticsearch-on-debian-jessie-with-systemd/20744 "2014-11-14T07:54:54Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Alexandr\_Bravo](https://avatars.discourse-cdn.com/v4/letter/a/a4c791/32.png) [@Alexandr\_Bravo](https://discuss.elastic.co/u/Alexandr_Bravo)\
**Post date:** [November 14, 2014, 7:54am UTC](https://discuss.elastic.co/t/starting-elasticsearch-on-debian-jessie-with-systemd/20744/1 "2014-11-14T07:54:54Z")

</div>

Hi,

I'm installing ElasticSearch from .deb package (from elasticsearch  
repository) on the Linux server with Debian jessie (testing). This is a  
second node I installed, the first one was done about 3 month ago also on  
Debian jessie but before the distriv was switched to systemd. And I had no  
any problems with that first node.

Now, on the fresh install, when I try to start the service by:

/etc/init.d/elasticsearch start

I get an error message:

[....] Starting elasticsearch (via systemctl): elasticsearch.serviceFailed  
to start elasticsearch.service: Unit elasticsearch.service failed to load:  
No such file or directory.  
failed!

As I understand for starting service with systemd (I skip all words about  
the idea to switch to it) I need first to register/enable it via something  
like:

/bin/systemctl enable elasticsearch.service

But config file "elasticsearch.service" is included only in RPM package and not available in .deb.

Two questions:

1. For developers - is it possible to include in elasticsearch.deb package all config files that are needed for systemd?
2. Can anybody to share the working examples of such configs to start elasticsearch with systemd under Debian jessie?

Many thanks,  
Alexandr

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/96535eab-3cb6-4e59-baa0-c8a6ceb80dd9%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/96535eab-3cb6-4e59-baa0-c8a6ceb80dd9%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![Jiri\_Jagos](https://avatars.discourse-cdn.com/v4/letter/j/b487fb/32.png) [@Jiri\_Jagos](https://discuss.elastic.co/u/Jiri_Jagos)\
**Post date:** [January 5, 2015, 8:53pm UTC](https://discuss.elastic.co/t/starting-elasticsearch-on-debian-jessie-with-systemd/20744/2 "2015-01-05T20:53:37Z")

</div>

After some panic and searching the way mentioned in the docs  
[http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/setup-repositories.html#\_yum](http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/setup-repositories.html#_yum)  
(at the end of the section) worked for me.

For impatient:

sudo /bin/systemctl daemon-reload # this line was the one I missed before  
sudo /bin/systemctl enable elasticsearch.service

On Friday, November 14, 2014 8:54:54 AM UTC+1, Alexandr Bravo wrote:

> Hi,
> 
> I'm installing Elasticsearch from .deb package (from elasticsearch  
> repository) on the Linux server with Debian jessie (testing). This is a  
> second node I installed, the first one was done about 3 month ago also on  
> Debian jessie but before the distriv was switched to systemd. And I had no  
> any problems with that first node.
> 
> Now, on the fresh install, when I try to start the service by:
> 
> /etc/init.d/elasticsearch start
> 
> I get an error message:
> 
> [....] Starting elasticsearch (via systemctl): elasticsearch.serviceFailed  
> to start elasticsearch.service: Unit elasticsearch.service failed to load:  
> No such file or directory.  
> failed!
> 
> As I understand for starting service with systemd (I skip all words about  
> the idea to switch to it) I need first to register/enable it via something  
> like:
> 
> /bin/systemctl enable elasticsearch.service
> 
> But config file "elasticsearch.service" is included only in RPM package and not available in .deb.
> 
> Two questions:
> 
> 1. For developers - is it possible to include in elasticsearch.deb package all config files that are needed for systemd?
> 2. Can anybody to share the working examples of such configs to start elasticsearch with systemd under Debian jessie?
> 
> Many thanks,  
> Alexandr

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/fd214d2a-1cf2-4a04-8a96-fad00da16f7f%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/fd214d2a-1cf2-4a04-8a96-fad00da16f7f%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 12:40am UTC](https://discuss.elastic.co/t/starting-elasticsearch-on-debian-jessie-with-systemd/20744/3 "2017-07-06T00:40:45Z")

</div>


