# Starting ElasticSearch

**URL:** https://discuss.elastic.co/t/starting-elasticsearch/80329
**Category:** Elasticsearch
**Created:** [March 28, 2017, 4:44pm UTC](https://discuss.elastic.co/t/starting-elasticsearch/80329 "2017-03-28T16:44:24Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![tias](https://avatars.discourse-cdn.com/v4/letter/t/dc4da7/32.png) [@tias](https://discuss.elastic.co/u/tias)
#### Post date: [March 28, 2017, 4:44pm UTC](https://discuss.elastic.co/t/starting-elasticsearch/80329/1 "2017-03-28T16:44:24Z")

</div>

Hello,

just installed ElasticSearch 5.2.2 through RPM packages on Redhat 7, VMware VM x64.  
when starting, ES throws an error:

Mar 28 18:36:54 rcsloggen02bp elasticsearch: 2017-03-28 18:36:54,812 main ERROR Could not register mbeans java.security.AccessControlException: access denied ("javax.management.MBeanTrustPermission" "register")  
Mar 28 18:36:54 rcsloggen02bp elasticsearch: at java.security.AccessControlContext.checkPermission(AccessControlContext.java:472)  
Mar 28 18:36:54 rcsloggen02bp elasticsearch: at java.lang.SecurityManager.checkPermission(SecurityManager.java:585)  
Mar 28 18:36:54 rcsloggen02bp elasticsearch: at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.checkMBeanTrustPermission(DefaultMBeanServerInterceptor.java:1848)  
Mar 28 18:36:54 rcsloggen02bp elasticsearch: at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.registerMBean(DefaultMBeanServerInterceptor.java:322)  
Mar 28 18:36:54 rcsloggen02bp elasticsearch: at com.sun.jmx.mbeanserver.JmxMBeanServer.registerMBean(JmxMBeanServer.java:522)  
Mar 28 18:36:54 rcsloggen02bp elasticsearch: at org.apache.logging.log4j.core.jmx.Server.register(Server.java:389)  
Mar 28 18:36:54 rcsloggen02bp elasticsearch: at org.apache.logging.log4j.core.jmx.Server.reregisterMBeansAfterReconfigure(Server.java:167)  
Mar 28 18:36:54 rcsloggen02bp elasticsearch: at org.apache.logging.log4j.core.jmx.Server.reregisterMBeansAfterReconfigure(Server.java:140)  
Mar 28 18:36:54 rcsloggen02bp elasticsearch: at org.apache.logging.log4j.core.LoggerContext.setConfiguration(LoggerContext.java:541)  
Mar 28 18:36:54 rcsloggen02bp elasticsearch: at org.apache.logging.log4j.core.LoggerContext.start(LoggerContext.java:258)  
Mar 28 18:36:54 rcsloggen02bp elasticsearch: at org.apache.logging.log4j.core.impl.Log4jContextFactory.getContext(Log4jContextFactory.java:206)  
Mar 28 18:36:54 rcsloggen02bp elasticsearch: at org.apache.logging.log4j.core.config.Configurator.initialize(Configurator.java:220)  
Mar 28 18:36:54 rcsloggen02bp elasticsearch: at org.apache.logging.log4j.core.config.Configurator.initialize(Configurator.java:197)  
Mar 28 18:36:54 rcsloggen02bp elasticsearch: at org.elasticsearch.common.logging.LogConfigurator.configureStatusLogger(LogConfigurator.java:125)  
Mar 28 18:36:54 rcsloggen02bp elasticsearch: at org.elasticsearch.common.logging.LogConfigurator.configureWithoutConfig(LogConfigurator.java:67)  
Mar 28 18:36:54 rcsloggen02bp elasticsearch: at org.elasticsearch.cli.Command.main(Command.java:85)  
Mar 28 18:36:54 rcsloggen02bp elasticsearch: at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:89)  
Mar 28 18:36:54 rcsloggen02bp elasticsearch: at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:82)  
Mar 28 18:36:55 rcsloggen02bp elasticsearch: 2017-03-28 18:36:55,235 main ERROR Could not register mbeans java.security.AccessControlException: access denied ("javax.management.MBeanTrustPermission" "register")  
Mar 28 18:36:55 rcsloggen02bp elasticsearch: at java.security.AccessControlContext.checkPermission(AccessControlContext.java:472)  
Mar 28 18:36:55 rcsloggen02bp elasticsearch: at java.lang.SecurityManager.checkPermission(SecurityManager.java:585)  
Mar 28 18:36:55 rcsloggen02bp elasticsearch: at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.checkMBeanTrustPermission(DefaultMBeanServerInterceptor.java:1848)  
Mar 28 18:36:55 rcsloggen02bp elasticsearch: at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.registerMBean(DefaultMBeanServerInterceptor.java:322)  
Mar 28 18:36:55 rcsloggen02bp elasticsearch: at com.sun.jmx.mbeanserver.JmxMBeanServer.registerMBean(JmxMBeanServer.java:522)  
Mar 28 18:36:55 rcsloggen02bp elasticsearch: at org.apache.logging.log4j.core.jmx.Server.register(Server.java:389)  
Mar 28 18:36:55 rcsloggen02bp elasticsearch: at org.apache.logging.log4j.core.jmx.Server.reregisterMBeansAfterReconfigure(Server.java:167)  
Mar 28 18:36:55 rcsloggen02bp elasticsearch: at org.apache.logging.log4j.core.jmx.Server.reregisterMBeansAfterReconfigure(Server.java:140)  
Mar 28 18:36:55 rcsloggen02bp elasticsearch: at org.apache.logging.log4j.core.LoggerContext.setConfiguration(LoggerContext.java:541)  
Mar 28 18:36:55 rcsloggen02bp elasticsearch: at org.apache.logging.log4j.core.LoggerContext.start(LoggerContext.java:258)  
Mar 28 18:36:55 rcsloggen02bp elasticsearch: at org.elasticsearch.common.logging.LogConfigurator.configure(LogConfigurator.java:116)  
Mar 28 18:36:55 rcsloggen02bp elasticsearch: at org.elasticsearch.common.logging.LogConfigurator.configure(LogConfigurator.java:83)  
Mar 28 18:36:55 rcsloggen02bp elasticsearch: at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:299)  
Mar 28 18:36:55 rcsloggen02bp elasticsearch: at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:121)  
Mar 28 18:36:55 rcsloggen02bp elasticsearch: at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:112)  
Mar 28 18:36:55 rcsloggen02bp elasticsearch: at org.elasticsearch.cli.SettingCommand.execute(SettingCommand.java:54)  
Mar 28 18:36:55 rcsloggen02bp elasticsearch: at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:122)  
Mar 28 18:36:55 rcsloggen02bp elasticsearch: at org.elasticsearch.cli.Command.main(Command.java:88)  
Mar 28 18:36:55 rcsloggen02bp elasticsearch: at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:89)  
Mar 28 18:36:55 rcsloggen02bp elasticsearch: at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:82)

I had found some posts about those permission denied, but they did not help.

- tried to chown -R elasticsearch /usr/share/elasticsearch  
=\> same error
- reverted back to how it was before
- tried to setenforce 0  
=\> same error

from the logs I cannot find the culprit.

did anyone get something similar ?

thank you, best regards

Mathias

---

<div class="post-metadata">

### Author: ![tias](https://avatars.discourse-cdn.com/v4/letter/t/dc4da7/32.png) [@tias](https://discuss.elastic.co/u/tias)
#### Post date: [March 28, 2017, 5:03pm UTC](https://discuss.elastic.co/t/starting-elasticsearch/80329/2 "2017-03-28T17:03:08Z")

</div>

I modified "/usr/share/elasticsearch/bin/elasticsearch"  
with  
ES\_JVM\_OPTIONS="-DproxyPort=1234 -DproxyHost=X.X.X.X -Dlog4j2.disable.jmx=true"

but no go...  
thanks

Mathias

---

<div class="post-metadata">

### Author: ![tias](https://avatars.discourse-cdn.com/v4/letter/t/dc4da7/32.png) [@tias](https://discuss.elastic.co/u/tias)
#### Post date: [March 30, 2017, 8:36am UTC](https://discuss.elastic.co/t/starting-elasticsearch/80329/3 "2017-03-30T08:36:50Z")

</div>

I have reinstalled fully redhat v7, installed ES v 5.3  
and it seems to work now.  
this discussion should now be closed.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [April 27, 2017, 8:37am UTC](https://discuss.elastic.co/t/starting-elasticsearch/80329/4 "2017-04-27T08:37:11Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
