# Starting error caused by content of config file that it doesn't actually include

**URL:** <https://discuss.elastic.co/t/starting-error-caused-by-content-of-config-file-that-it-doesnt-actually-include/273133>\
**Category:** Logstash\
**Tags:** elastic-stack-security\
**Created:** [May 17, 2021, 6:54am UTC](https://discuss.elastic.co/t/starting-error-caused-by-content-of-config-file-that-it-doesnt-actually-include/273133 "2021-05-17T06:54:53Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![111475](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/111475/32/88825_2.png) [@111475](https://discuss.elastic.co/u/111475)\
**Post date:** [May 17, 2021, 6:54am UTC](https://discuss.elastic.co/t/starting-error-caused-by-content-of-config-file-that-it-doesnt-actually-include/273133/1 "2021-05-17T06:54:53Z")

</div>

I have this config file (/etc/logstash/conf.g/my.config).  
...  
output {  
elasticsearch {  
hosts =\> ["XXXX"]  
index =\> "search\_log-%{+YYYY.MM.dd}"  
user =\> "XXXX"  
password =\> "XXXX"  
ssl =\> true  
**cacert =\> "/etc/logstash/certs"**  
}  
#stdout{}  
}

When start logstash, syslog print this error log.

May 17 02:53:42 localhost logstash[1860]: [2021-05-17T02:53:42,125][ERROR][logstash.outputs.elasticsearch] Invalid setting for elasticsearch output plugin:  
May 17 02:53:42 localhost logstash[1860]: output {  
May 17 02:53:42 localhost logstash[1860]: elasticsearch {  
May 17 02:53:42 localhost logstash[1860]: # This setting must be a path  
May 17 02:53:42 localhost logstash[1860]: # File does not exist or cannot be opened certs/chainca.crt  
May 17 02:53:42 localhost logstash[1860]: **cacert =\> "certs/chainca.crt"**  
May 17 02:53:42 localhost logstash[1860]: ...  
May 17 02:53:42 localhost logstash[1860]: }  
May 17 02:53:42 localhost logstash[1860]: }  
May 17 02:53:42 localhost logstash[1860]: [2021-05-17T02:53:42,139][ERROR][logstash.licensechecker.licensereader] Unable to retrieve license information from license server {:message=\>"Something is wrong with your configuration."}  
May 17 02:53:42 localhost logstash[1860]: [2021-05-17T02:53:42,160][ERROR][logstash.monitoring.internalpipelinesource] Failed to fetch X-Pack information from Elasticsearch. This is likely due to failure to reach a live Elasticsearch cluster.  
....  
....  
....  
"pipeline.sources"=\>["/etc/logstash/conf.d/my.conf"],  
....  
....

In this error log, contents of the config file is different from ours. But here, this file directory appear the same as our config file. (I have only one config file '/etc/logstash/conf.d/my.config')  
Like above config file, I already edited cacert part to directory.

version - 7.10.2

Help me. . . .

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 14, 2021, 6:55am UTC](https://discuss.elastic.co/t/starting-error-caused-by-content-of-config-file-that-it-doesnt-actually-include/273133/2 "2021-06-14T06:55:34Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
