# Starting Fscrawler with SSL error

**URL:** <https://discuss.elastic.co/t/starting-fscrawler-with-ssl-error/375028>\
**Category:** Elasticsearch\
**Created:** [February 25, 2025, 2:56pm UTC](https://discuss.elastic.co/t/starting-fscrawler-with-ssl-error/375028 "2025-02-25T14:56:25Z")\
**Posts on this page:** 1\
**Showing post:** 35

<div class="post-metadata">

**Author:** ![RainTown](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/raintown/32/140206_2.png) [@RainTown](https://discuss.elastic.co/u/RainTown)\
**Post date:** [March 5, 2025, 5:41pm UTC](https://discuss.elastic.co/t/starting-fscrawler-with-ssl-error/375028/35 "2025-03-05T17:41:41Z")

</div>

I wonder if this is now a permissions issue.

btw, you dont need to be root user to run the curl command. Usually elasticsearch runs as a non-root user, maybe after your tidy up some file/directory has ended up as being owned by root.

See:

```auto
$ ls -ld /var/lib/elasticsearch/
drwxr-s--- 5 elasticsearch elasticsearch 4096 Mar 4 21:28 /var/lib/elasticsearch/

```

so this whole tree is owned by the "elasticsearch" user (this is Ubuntu)

```auto
$ sudo find /var/lib/elasticsearch/ /var/log/elasticsearch/ \! -user elasticsearch -ls
$

```

no output, everything in those trees is owned by elastsearch user.

```auto
$ sudo find /var/lib/elasticsearch/ -user elasticsearch -type f | wc
   2878 2878 206668
$ sudo find /var/log/elasticsearch/ -user elasticsearch -type f | wc
     47 47 2160
$

```

The error you have now has been seen before, eg

> [@Auto-generated deafult password hash error](https://discuss.elastic.co/t/auto-generated-deafult-password-hash-error/365401):
>
> so as i am following [Tutorial 1: Installing a self-managed Elastic Stack](https://www.elastic.co/guide/en/elastic-stack/8.15/installing-stack-demo-self.html#install-stack-self-elasticsearch-first) at the end of [step 3](https://www.elastic.co/guide/en/elastic-stack/8.15/installing-stack-demo-self.html#install-stack-self-elasticsearch-start) i should be able to run curl command and see some sort of default message that indicate my set up was fine but instead i get the following error: {"error":{"root\_cause":[{"type":"status\_exception","reason":"Cluster state has not been recovered yet, cannot write to the [null] index"}],"type":"authentication\_processing\_error","reason":"failed to promote the auto-configured elastic password hash","caused…

and there its not clear what was wrong but the summary was:

> This means that your cluster is not in a state where it can read/write data. I cannot tell you what caused that, but it almost certainly has nothing to do with your password setup - the root of the problem is that security cannot do its job if it cannot read and write data from the cluster.

and the suggestion was to check cluster.initial\_master\_nodes setting. as you want just a single node cluster then

```auto
cluster.initial_master_nodes: []

```

should be fine.

---

_[View the full topic](https://discuss.elastic.co/t/starting-fscrawler-with-ssl-error/375028)._
