# Startup failure - arch64 - crashes - arm64 - fedora, rocky9, centos9, macbook m4, docker

**URL:** <https://discuss.elastic.co/t/startup-failure-arch64-crashes-arm64-fedora-rocky9-centos9-macbook-m4-docker/371708>\
**Category:** Elasticsearch\
**Tags:** runtime-fields\
**Created:** [December 9, 2024, 2:19pm UTC](https://discuss.elastic.co/t/startup-failure-arch64-crashes-arm64-fedora-rocky9-centos9-macbook-m4-docker/371708 "2024-12-09T14:19:26Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![contactnkm](https://avatars.discourse-cdn.com/v4/letter/c/b4bc9f/32.png) [@contactnkm](https://discuss.elastic.co/u/contactnkm)\
**Post date:** [December 9, 2024, 2:19pm UTC](https://discuss.elastic.co/t/startup-failure-arch64-crashes-arm64-fedora-rocky9-centos9-macbook-m4-docker/371708/1 "2024-12-09T14:19:26Z")

</div>

Get the following error whenever trying to install and run elasticsearch on aarch64 rocky9.5 or fedora 6.11.4

stdoout:

```auto
#
# A fatal error has been detected by the Java Runtime Environment:
#
# SIGILL (0x4) at pc=0x0000ffff97d410a8, pid=2022, tid=2031
#
# JRE version: (23.0+37) (build )
# Java VM: OpenJDK 64-Bit Server VM (23+37-2369, mixed mode, sharing, tiered, compressed oops, compressed class ptrs, serial gc, linux-aarch64)
# Problematic frame:
# j java.lang.System.registerNatives()V+0 java.base@23
#
# Core dump will be written. Default location: Core dumps may be processed with "/usr/lib/systemd/systemd-coredump %P %u %g %s %t %c %h" (or dumping to /usr/share/elasticsearch/core.2022)
#
# An error report file with more information is saved as:
# /usr/share/elasticsearch/hs_err_pid2022.log
[0.015s][warning][os] Loading hsdis library failed
#
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#
Aborted

```

uname:  
Linux localhost.localdomain 6.11.4-301.fc41.aarch64 #1 SMP PREEMPT\_DYNAMIC Sun Oct 20 15:21:05 UTC 2024 aarch64 GNU/Linux

JAVA Bundled:

````auto
/usr/share/elasticsearch/jdk/bin$ sudo ./java --version
#
# A fatal error has been detected by the Java Runtime Environment:
#
# SIGILL (0x4) at pc=0x0000ffff93d411a8, pid=2112, tid=2113
#
# JRE version: (23.0+37) (build )
# Java VM: OpenJDK 64-Bit Server VM (23+37-2369, mixed mode, sharing, tiered, compressed oops, compressed class ptrs, g1 gc, linux-aarch64)
# Problematic frame:
# j java.lang.System.registerNatives()V+0 java.base@23
#
# Core dump will be written. Default location: Core dumps may be processed with "/usr/lib/systemd/systemd-coredump %P %u %g %s %t %c %h" (or dumping to /usr/share/elasticsearch/jdk/bin/core.2112)
#
# An error report file with more information is saved as:
# /usr/share/elasticsearch/jdk/bin/hs_err_pid2112.log
[0.015s][warning][os] Loading hsdis library failed
#
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#
Aborted```

YUM:
elasticsearch-0:8.16.1-1.aarch64

```sudo yum install --enablerepo=elasticsearch elasticsearch
Updating and loading repositories:
 Elasticsearch repository for 8.x packages 100% | 9.7 KiB/s | 1.3 KiB | 00m00s
Repositories loaded.
Package Arch Version Repository Size
Installing:
 elasticsearch aarch64 8.16.1-1 elasticsearch 733.1 MiB

Transaction Summary:
 Installing: 1 package

Total size of inbound packages is 461 MiB. Need to download 461 MiB.
After this operation, 733 MiB extra will be used (install 733 MiB, remove 0 B).
Is this ok [y/N]: y
[1/1] elasticsearch-0:8.16.1-1.aarch64 100% | 21.1 MiB/s | 460.9 MiB | 00m22s
-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
[1/1] Total 100% | 21.1 MiB/s | 460.9 MiB | 00m22s
Running transaction
[1/3] Verify package files 100% | 1.0 B/s | 1.0 B | 00m01s
[2/3] Prepare transaction 100% | 23.0 B/s | 1.0 B | 00m00s
[3/3] Installing elasticsearch-0:8.16.1-1.aarch64 100% [==================] | 324.6 MiB/s | 733.3 MiB | -00m00s
>>> Running post-transaction scriptlet: elasticsearch-0:8.16.1-1.aarch64
>>> Non-critical error in post-transaction scriptlet: elasticsearch-0:8.16.1-1.aarch64
>>> Scriptlet output:
[3/3] Installing elasticsearch-0:8.16.1-1.aarch64 100% | 270.1 MiB/s | 733.3 MiB | 00m03s
>>> Running post-transaction scriptlet: elasticsearch-0:8.16.1-1.aarch64
>>> Non-critical error in post-transaction scriptlet: elasticsearch-0:8.16.1-1.aarch64
>>> Scriptlet output:
>>> #
>>> # A fatal error has been detected by the Java Runtime Environment:
>>> #
>>> # SIGILL (0x4) at pc=0x0000ffff87d410a8, pid=1627, tid=1636
>>> #
>>> # JRE version: (23.0+37) (build )
>>> # Java VM: OpenJDK 64-Bit Server VM (23+37-2369, mixed mode, sharing, tiered, compressed oops, compressed class ptrs, serial gc, linux-aarch64)
>>> # Problematic frame:
>>> # j java.lang.System.registerNatives()V+0 java.base@23
>>> #
>>> # Core dump will be written. Default location: Core dumps may be processed with "/usr/lib/systemd/systemd-coredump %P %u %g %s %t %c %h" (or dumping to /usr/share/elasticsearch/core.1627)
>>> #
>>> # An error report file with more information is saved as:
>>> # /usr/share/elasticsearch/hs_err_pid1627.log
>>> [0.007s][warning][os] Loading hsdis library failed
>>> #
>>> # The crash happened outside the Java Virtual Machine in native code.
>>> # See problematic frame for where to report the bug.
>>> #
>>> /var/tmp/rpm-tmp.ErwOMr: line 27: 1627 Aborted (core dumped) /usr/share/elasticsearch/bin/elasticsearch-keystore create
>>>
>>> Stop post-transaction scriptlet: elasticsearch-0:8.16.1-1.aarch64
Complete!```
````

---

<div class="post-metadata">

**Author:** ![contactnkm](https://avatars.discourse-cdn.com/v4/letter/c/b4bc9f/32.png) [@contactnkm](https://discuss.elastic.co/u/contactnkm)\
**Post date:** [December 9, 2024, 2:46pm UTC](https://discuss.elastic.co/t/startup-failure-arch64-crashes-arm64-fedora-rocky9-centos9-macbook-m4-docker/371708/2 "2024-12-09T14:46:27Z")

</div>

Also in AWS ec2 instances:

```auto
uname -a
Linux ip-172-31-26-166.ec2.internal 5.14.0-511.el9.aarch64 #1 SMP PREEMPT_DYNAMIC Thu Sep 19 07:04:53 UTC 2024 aarch64 aarch64 aarch64 GNU/Linux

```

Install:

```auto
sudo yum install -y --enablerepo=elasticsearch elasticsearch
CentOS Stream 9 - BaseOS 11 MB/s | 9.5 MB 00:00
CentOS Stream 9 - AppStream 20 MB/s | 19 MB 00:00
CentOS Stream 9 - Extras packages 91 kB/s | 19 kB 00:00
Elasticsearch repository for 8.x packages 17 MB/s | 80 MB 00:04
Killed

```

Ignore aws that worked with increased mem and el8

---

<div class="post-metadata">

**Author:** ![contactnkm](https://avatars.discourse-cdn.com/v4/letter/c/b4bc9f/32.png) [@contactnkm](https://discuss.elastic.co/u/contactnkm)\
**Post date:** [December 10, 2024, 6:49am UTC](https://discuss.elastic.co/t/startup-failure-arch64-crashes-arm64-fedora-rocky9-centos9-macbook-m4-docker/371708/3 "2024-12-10T06:49:15Z")

</div>

Same for Docker on Macbook m4:

```auto
docker run --name es01 --net elastic -p 9200:9200 -it -m 1GB docker.elastic.co/elasticsearch/elasticsearch:8.16.1
#
# A fatal error has been detected by the Java Runtime Environment:
#
# SIGILL (0x4) at pc=0x0000ffff7bd400a8, pid=7, tid=16
#
# JRE version: (23.0+37) (build )
# Java VM: OpenJDK 64-Bit Server VM (23+37-2369, mixed mode, sharing, tiered, compressed oops, compressed class ptrs, serial gc, linux-aarch64)
# Problematic frame:
# j java.lang.System.registerNatives()V+0 java.base@23
#
# No core dump will be written. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
#
# An error report file with more information is saved as:
# /usr/share/elasticsearch/hs_err_pid7.log
[0.032s][warning][os] Loading hsdis library failed
#
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#

```

---

<div class="post-metadata">

**Author:** ![journeadrien](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/journeadrien/32/139944_2.png) [@journeadrien](https://discuss.elastic.co/u/journeadrien)\
**Post date:** [December 11, 2024, 9:43pm UTC](https://discuss.elastic.co/t/startup-failure-arch64-crashes-arm64-fedora-rocky9-centos9-macbook-m4-docker/371708/4 "2024-12-11T21:43:53Z")

</div>

Same issue, I think it happened after updating macOS Sequoia 15.2.

---

<div class="post-metadata">

**Author:** ![niemyjski](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/niemyjski/32/5189_2.png) [@niemyjski](https://discuss.elastic.co/u/niemyjski)\
**Post date:** [December 12, 2024, 6:32pm UTC](https://discuss.elastic.co/t/startup-failure-arch64-crashes-arm64-fedora-rocky9-centos9-macbook-m4-docker/371708/5 "2024-12-12T18:32:31Z")

</div>

Happening for me on M4 Mac running 15.2. I created an issue here: [macOS 15.2 M4: Unable to launch Elasticsearch Docker container · Issue #118583 · elastic/elasticsearch · GitHub](https://github.com/elastic/elasticsearch/issues/118583)

---

<div class="post-metadata">

**Author:** ![niemyjski](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/niemyjski/32/5189_2.png) [@niemyjski](https://discuss.elastic.co/u/niemyjski)\
**Post date:** [December 12, 2024, 7:35pm UTC](https://discuss.elastic.co/t/startup-failure-arch64-crashes-arm64-fedora-rocky9-centos9-macbook-m4-docker/371708/6 "2024-12-12T19:35:30Z")

</div>

Did anyone find a work around? Please upvote the GitHub issue above.

---

<div class="post-metadata">

**Author:** ![contactnkm](https://avatars.discourse-cdn.com/v4/letter/c/b4bc9f/32.png) [@contactnkm](https://discuss.elastic.co/u/contactnkm)\
**Post date:** [January 14, 2025, 8:18am UTC](https://discuss.elastic.co/t/startup-failure-arch64-crashes-arm64-fedora-rocky9-centos9-macbook-m4-docker/371708/7 "2025-01-14T08:18:58Z")

</div>

> <https://github.com/elastic/elasticsearch/issues/49178>
>
> \*\*Elasticsearch version\*\* (\`bin/elasticsearch --version\`):
> 
> Version: 7.3.2, Bu…ild: default/deb/1c1faf1/2019-09-06T14:40:30.409026Z, JVM: 12.0.2
> 
> \*\*Plugins installed\*\*: \[\]
> 
> \*\*JVM version\*\* (\`java -version\`):
> 
> \# /usr/share/elasticsearch/jdk/bin/java -version
> openjdk version "12.0.2" 2019-07-16
> OpenJDK Runtime Environment (build 12.0.2+10)
> OpenJDK 64-Bit Server VM (build 12.0.2+10, mixed mode, sharing)
> 
> \*\*OS version\*\* (\`uname -a\` if on a Unix-like system):
> Linux bill03 4.4.0-166-generic #195-Ubuntu SMP Tue Oct 1 09:35:25 UTC 2019 x86\_64 x86\_64 x86\_64 GNU/Linux
> 
> \*\*Description of the problem including expected versus actual behavior\*\*:
> 
> Elasticsearch can not start, crashed with the following error:
> 
> \#
> \# A fatal error has been detected by the Java Runtime Environment:
> \#
> \# SIGILL (0x4) at pc=0x00007fd5e4856948, pid=62249, tid=62343
> \#
> \# JRE version: OpenJDK Runtime Environment (12.0.2+10) (build 12.0.2+10)
> \# Java VM: OpenJDK 64-Bit Server VM (12.0.2+10, mixed mode, tiered, concurrent mark sweep gc, linux-amd64)
> \# Problematic frame:
> \# J 5337 c2 com.fasterxml.jackson.core.sym.ByteQuadsCanonicalizer.findName(\[II)Ljava/lang/String; (198 bytes) @ 0x00007fd5e4856948 \[0x00007fd5e4856840+0x0000000000000108\]
> \#
> \# Core dump will be written. Default location: Core dumps may be processed with "/usr/share/apport/apport %p %s %c %d %P" (or dumping to /usr/share/elasticsearch/core.62249)
> \#
> \# An error report file with more information is saved as:
> \# /var/log/elasticsearch/hs\_err\_pid62249.log
> Could not load hsdis-amd64.so; library not loadable; PrintAssembly is disabled
> \#
> \# If you would like to submit a bug report, please visit:
> \# http://bugreport.java.com/bugreport/crash.jsp
> \#
> Aborted (core dumped)
> 
> \*\*Steps to reproduce\*\*:
> 
> 1. start elasticsearch
> 2. 
> 3.
> 
> \*\*Provide logs (if relevant)\*\*:
> 
> https://gist.githubusercontent.com/ndanl/4a39c126712e6f25de20f5dc8722b521/raw/4cb3d2692a9c5bf3d500096b2764a33a5e33ef5b/gistfile1.txt

---

<div class="post-metadata">

**Author:** ![xeraa](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/xeraa/32/48181_2.png) [@xeraa](https://discuss.elastic.co/u/xeraa)\
**Post date:** [January 14, 2025, 10:35am UTC](https://discuss.elastic.co/t/startup-failure-arch64-crashes-arm64-fedora-rocky9-centos9-macbook-m4-docker/371708/8 "2025-01-14T10:35:49Z")

</div>

That's IMO a different bug / problem.

What seems to work is the following and we're also [adding this to start-local](https://github.com/elastic/start-local/pull/29) now:

```auto
- 'ES_JAVA_OPTS=-XX:UseSVE=0'
- 'CLI_JAVA_OPTS=-XX:UseSVE=0'

```
