# Stats command

**URL:** https://discuss.elastic.co/t/stats-command/149200
**Category:** Kibana
**Created:** [September 19, 2018, 10:13pm UTC](https://discuss.elastic.co/t/stats-command/149200 "2018-09-19T22:13:45Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![koocaroo](https://avatars.discourse-cdn.com/v4/letter/k/8edcca/32.png) [@koocaroo](https://discuss.elastic.co/u/koocaroo)
#### Post date: [September 19, 2018, 10:13pm UTC](https://discuss.elastic.co/t/stats-command/149200/1 "2018-09-19T22:13:45Z")

</div>

I am coming from a Splunk environment and I am struggling a little bit with the search syntax in Kibana. Are there Kibana equivalents to commands like stats?

For example when looking at intrusion prevention logs I would do "index=firepower | stats count by sig,dest\_ip"

This would yield a list of the number of times that signature was seen at each unique destination ip. How can something similar be achieved with Kibana and ES?

---

<div class="post-metadata">

### Author: ![lukas](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/lukas/32/6812_2.png) [@lukas](https://discuss.elastic.co/u/lukas)
#### Post date: [September 19, 2018, 10:39pm UTC](https://discuss.elastic.co/t/stats-command/149200/2 "2018-09-19T22:39:05Z")

</div>

You'll want to create a data table visualization, and select for metrics the unique count of signature, then select for buckets a terms aggregation on destination IP. Let me know if that works!

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [October 17, 2018, 10:51pm UTC](https://discuss.elastic.co/t/stats-command/149200/3 "2018-10-17T22:51:43Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
