# statusCode:429 - High fielddata memory usage

**URL:** https://discuss.elastic.co/t/statuscode-429-high-fielddata-memory-usage/215774
**Category:** Elasticsearch
**Created:** [January 20, 2020, 3:54pm UTC](https://discuss.elastic.co/t/statuscode-429-high-fielddata-memory-usage/215774 "2020-01-20T15:54:02Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![Djaswan](https://avatars.discourse-cdn.com/v4/letter/d/71c47a/32.png) [@Djaswan](https://discuss.elastic.co/u/Djaswan)
#### Post date: [January 20, 2020, 3:54pm UTC](https://discuss.elastic.co/t/statuscode-429-high-fielddata-memory-usage/215774/1 "2020-01-20T15:54:02Z")

</div>

Hi,

We experienced some strange behavior from Kibana, while opening Kibana we got the following error:

```
    Error:
    {"statusCode":429,"error":"Too Many Requests","message":"[circuit_breaking_exception] [parent] Data too large, data for [<http_request>] would be [4093269000/3.8gb], which is larger than the limit of [4063657984/3.7gb], real usage: [4093269000/3.8gb], new bytes reserved: [0/0b], with { bytes_wanted=4093269000 & bytes_limit=4063657984 & durability=\"PERMANENT\" }"}

```

We ran the command: "GET /\_cat/fielddata?v&fields=\*" and discovered that the problem was caused by a fielddata with high memory usage (3GB). This activated the circuit breaker and the errors in Kibana. The related node was also operating with high memory (95%). Clearing the fielddata memory solved the errors in Kibana and stabilized the node.

We still don’t know why the fielddata memory was that high and why it’s being used. We thought that by default the usage of fielddata was disabled. We also checked the index that contains the problem field, but I don’t see any mappings with “text” type fields.

Can someone help me out and clarify how the fielddata usage works and which factors can lead to the high memory usage.

---

<div class="post-metadata">

### Author: ![azasypkin](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/azasypkin/32/42216_2.png) [@azasypkin](https://discuss.elastic.co/u/azasypkin)
#### Post date: [January 20, 2020, 4:13pm UTC](https://discuss.elastic.co/t/statuscode-429-high-fielddata-memory-usage/215774/2 "2020-01-20T16:13:58Z")

</div>

It seems this question is more appropriate for the Elasticsearch Discuss hub - I'll forward it there.

---

<div class="post-metadata">

### Author: ![DavidTurner](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/davidturner/32/22453_2.png) [@DavidTurner](https://discuss.elastic.co/u/DavidTurner)
#### Post date: [January 20, 2020, 4:35pm UTC](https://discuss.elastic.co/t/statuscode-429-high-fielddata-memory-usage/215774/3 "2020-01-20T16:35:59Z")

</div>

What was the field with the high usage? Apart from `text` fields, a common culprit is [the `_id` field](https://www.elastic.co/guide/en/elasticsearch/reference/current/mapping-id-field.html), if you accidentally try and sort or aggregate by `_id`. A [setting is in the works](https://github.com/elastic/elasticsearch/pull/49166) to allow you to reject searches that would cause this.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [February 17, 2020, 4:36pm UTC](https://discuss.elastic.co/t/statuscode-429-high-fielddata-memory-usage/215774/4 "2020-02-17T16:36:00Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
