# "statusCode":500 when going to localhost:5601

**URL:** https://discuss.elastic.co/t/statuscode-500-when-going-to-localhost-5601/242017
**Category:** Kibana
**Created:** [July 21, 2020, 11:41am UTC](https://discuss.elastic.co/t/statuscode-500-when-going-to-localhost-5601/242017 "2020-07-21T11:41:12Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![eslepakurov](https://avatars.discourse-cdn.com/v4/letter/e/b9bd4f/32.png) [@eslepakurov](https://discuss.elastic.co/u/eslepakurov)
#### Post date: [July 21, 2020, 11:41am UTC](https://discuss.elastic.co/t/statuscode-500-when-going-to-localhost-5601/242017/1 "2020-07-21T11:41:13Z")

</div>

Hi, I've installed everything like here [https://www.youtube.com/watch?v=FImTcHECpC0](https://www.youtube.com/watch?v=FImTcHECpC0)

When I paste [http://localhost:5601/](http://localhost:5601/) to browser, `{"statusCode":500,"error":"Internal Server Error","message":"An internal server error occurred"}` occured

Here is a terminal message:  
` TypeError [ERR_INVALID_CHAR]: Invalid character in header content ["kbn-name"] at ServerResponse.setHeader (_http_outgoing.js:473:3) at Object.internals.writeHead (/Users/User/kibana-7.8.0-darwin-x86_64/node_modules/hapi/lib/transmit.js:323:21) at Object.internals.transmit (/Users/User/kibana-7.8.0-darwin-x86_64/node_modules/hapi/lib/transmit.js:105:15) at Object.exports.send (/Users/User/kibana-7.8.0-darwin-x86_64/node_modules/hapi/lib/transmit.js:32:25)`

I'm not modifying anything.  
Does anyone have any idea what's going wrong?

MacOS, 10.14.6  
Safari and Chrome browsers

Thanks a lot

---

<div class="post-metadata">

### Author: ![Mikhail\_Shustov](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mikhail_shustov/32/49186_2.png) [@Mikhail\_Shustov](https://discuss.elastic.co/u/Mikhail_Shustov)
#### Post date: [July 23, 2020, 12:11pm UTC](https://discuss.elastic.co/t/statuscode-500-when-going-to-localhost-5601/242017/2 "2020-07-23T12:11:55Z")

</div>

> [@eslepakurov](#):
>
> MacOS, 10.14.6  
> Safari and Chrome browsers

If `server.name` not specified in the `kibana.yml`, it falls back to `hostname` provided by OS. Probably it contains some invalid characters. Would mind configuring `server.name` in `kibana.yml` config file explicitly? For example:

```yml
server.name: "my-kibana"

```

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [August 20, 2020, 12:11pm UTC](https://discuss.elastic.co/t/statuscode-500-when-going-to-localhost-5601/242017/3 "2020-08-20T12:11:57Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
