# {"statusCode":503,"error":"Service Unavailable","message":"License is not available."}

**URL:** <https://discuss.elastic.co/t/statuscode-503-error-service-unavailable-message-license-is-not-available/319150>\
**Category:** Kibana\
**Created:** [November 17, 2022, 8:32am UTC](https://discuss.elastic.co/t/statuscode-503-error-service-unavailable-message-license-is-not-available/319150 "2022-11-17T08:32:57Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![auser](https://avatars.discourse-cdn.com/v4/letter/a/5e9695/32.png) [@auser](https://discuss.elastic.co/u/auser)\
**Post date:** [November 17, 2022, 8:32am UTC](https://discuss.elastic.co/t/statuscode-503-error-service-unavailable-message-license-is-not-available/319150/1 "2022-11-17T08:32:57Z")

</div>

I recently configured https for kibana running in three different environments. One of them works fine while the other two have issue as mentioned below -  
1 - {"statusCode":503,"error":"Service Unavailable","message":"License is not available."} I get this error when i try to browse kibana.  
2 - "Kibana server is not ready yet" I get this error for the third instance of kibana.

Not sure what is wrong as i have same configuration for all the three instances. Please some one help here it is a bit urgent. Thanks!

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [November 17, 2022, 8:34am UTC](https://discuss.elastic.co/t/statuscode-503-error-service-unavailable-message-license-is-not-available/319150/2 "2022-11-17T08:34:36Z")

</div>

Welcome to our community! 😃

Please share your Kibana log.

---

<div class="post-metadata">

**Author:** ![auser](https://avatars.discourse-cdn.com/v4/letter/a/5e9695/32.png) [@auser](https://discuss.elastic.co/u/auser)\
**Post date:** [November 17, 2022, 9:03am UTC](https://discuss.elastic.co/t/statuscode-503-error-service-unavailable-message-license-is-not-available/319150/3 "2022-11-17T09:03:07Z")

</div>

This is for the 1st issue -

'{"type":"log","@timestamp":"2022-11-17T08:57:43+00:00","tags":["warning","plugins","licensing"],"pid":7,"message":"License information could not be obtained from Elasticsearch due to {"error":{"root\_cause":[{"type":"security\_exception","reason":"unable to authenticate user [elastic] for REST request [/\_xpack?accept\_enterprise=true]","header":{"WWW-Authenticate":"Basic realm=\"security\" charset=\"UTF-8\""}}],"type":"security\_exception","reason":"unable to authenticate user [elastic] for REST request [/\_xpack?accept\_enterprise=true]","header":{"WWW-Authenticate":"Basic realm=\"security\" charset=\"UTF-8\""}},"status":401} error"}  
{"type":"log","@timestamp":"2022-11-17T08:57:45+00:00","tags":["warning","plugins","licensing"],"pid":7,"message":"License information could not be obtained from Elasticsearch due to {"error":{"root\_cause":[{"type":"security\_exception","reason":"unable to authenticate user [elastic] for REST request [/\_xpack?accept\_enterprise=true]","header":{"WWW-Authenticate":"Basic realm=\"security\" charset=\"UTF-8\""}}],"type":"security\_exception","reason":"unable to authenticate user [elastic] for REST request [/\_xpack?accept\_enterprise=true]","header":{"WWW-Authenticate":"Basic realm=\"security\" charset=\"UTF-8\""}},"status":401} error"}'

---

<div class="post-metadata">

**Author:** ![auser](https://avatars.discourse-cdn.com/v4/letter/a/5e9695/32.png) [@auser](https://discuss.elastic.co/u/auser)\
**Post date:** [November 17, 2022, 9:04am UTC](https://discuss.elastic.co/t/statuscode-503-error-service-unavailable-message-license-is-not-available/319150/4 "2022-11-17T09:04:59Z")

</div>

logs for 2nd issue - "Kibana server is not ready yet"

{"type":"log","@timestamp":"2022-11-17T09:03:24Z","tags":["license","warning","xpack"],"pid":1,"message":"License information from the X-Pack plugin could not be obtained from Elasticsearch for the [data] cluster. [security\_exception] failed to authenticate user [elastic], with { header={ WWW-Authenticate="Basic realm=\"security\" charset=\"UTF-8\"" } } :: {"path":"/\_xpack","statusCode":401,"response":"{\"error\":{\"root\_cause\":[{\"type\":\"security\_exception\",\"reason\":\"failed to authenticate user [elastic]\",\"header\":{\"WWW-Authenticate\":\"Basic realm=\\\"security\\\" charset=\\\"UTF-8\\\"\"}}],\"type\":\"security\_exception\",\"reason\":\"failed to authenticate user [elastic]\",\"header\":{\"WWW-Authenticate\":\"Basic realm=\\\"security\\\" charset=\\\"UTF-8\\\"\"}},\"status\":401}","wwwAuthenticateDirective":"Basic realm=\"security\" charset=\"UTF-8\""}"}  
{"type":"log","@timestamp":"2022-11-17T09:03:26Z","tags":["warning","task\_manager"],"pid":1,"message":"PollError [security\_exception] failed to authenticate user [elastic], with { header={ WWW-Authenticate="Basic realm=\"security\" charset=\"UTF-8\"" } }"}  
{"type":"log","@timestamp":"2022-11-17T09:03:29Z","tags":["warning","task\_manager"],"pid":1,"message":"PollError [security\_exception] failed to authenticate user [elastic], with { header={ WWW-Authenticate="Basic realm=\"security\" charset=\"UTF-8\"" } }"}

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [November 17, 2022, 9:52am UTC](https://discuss.elastic.co/t/statuscode-503-error-service-unavailable-message-license-is-not-available/319150/5 "2022-11-17T09:52:47Z")

</div>

Both of these are the same thing, so you need to check your auth details.

> [@auser](#):
>
> unable to authenticate user [elastic]

I wouldn't be using the `elastic` user for Kibana anyway, as that's the equivalent of using root.

---

<div class="post-metadata">

**Author:** ![auser](https://avatars.discourse-cdn.com/v4/letter/a/5e9695/32.png) [@auser](https://discuss.elastic.co/u/auser)\
**Post date:** [November 17, 2022, 10:10am UTC](https://discuss.elastic.co/t/statuscode-503-error-service-unavailable-message-license-is-not-available/319150/6 "2022-11-17T10:10:44Z")

</div>

> [@auser](#):
>
> unable to authenticate user [elastic]

Do you have any article or some reference which I can use to look into it? I am sorry, I am new to these configurations.

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [November 21, 2022, 2:04am UTC](https://discuss.elastic.co/t/statuscode-503-error-service-unavailable-message-license-is-not-available/319150/7 "2022-11-21T02:04:09Z")

</div>

Take a look at [Setting passwords for native and built-in users | Elasticsearch Guide [8.5] | Elastic](https://www.elastic.co/guide/en/elasticsearch/reference/8.5/change-passwords-native-users.html).

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 19, 2022, 2:04am UTC](https://discuss.elastic.co/t/statuscode-503-error-service-unavailable-message-license-is-not-available/319150/8 "2022-12-19T02:04:53Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
