# Stopping plugin restart in logstash

**URL:** <https://discuss.elastic.co/t/stopping-plugin-restart-in-logstash/235503>\
**Category:** Logstash\
**Created:** [June 3, 2020, 9:28am UTC](https://discuss.elastic.co/t/stopping-plugin-restart-in-logstash/235503 "2020-06-03T09:28:34Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Akash\_raj](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/akash_raj/32/45644_2.png) [@Akash\_raj](https://discuss.elastic.co/u/Akash_raj)\
**Post date:** [June 3, 2020, 9:28am UTC](https://discuss.elastic.co/t/stopping-plugin-restart-in-logstash/235503/1 "2020-06-03T09:28:34Z")

</div>

My config

`input{ jdbc{ jdbc_driver_library => "${JAVA_DIR}/ojdbc8-12.2.0.1.jar" jdbc_driver_class => "Java::oracle.jdbc.OracleDriver" jdbc_connection_string => "${JDBC_CONNECTION_STRING}" jdbc_user => "${JDBC_USER}" jdbc_password => "${JDBC_PASSWORD}" statement_filepath => "${FILE_PATH}" last_run_metadata_path => "${APP_ROOT}/last_run_metadata" jdbc_fetch_size => 1000 connection_retry_attempts => "${ATTEMPTS}" connection_retry_attempts_wait_time => "${WAIT_TIME}" } }`

Exception:  
Unable to connect to database. Trying again {:error\_message=\>"Java::JavaSql::SQLException: ORA-01017: invalid username/password; logon denied\n"}  
[2020-06-03T08:42:20,004][ERROR][logstash.inputs.jdbc] Unable to connect to database. Trying again {:error\_message=\>"Java::JavaSql::SQLException: ORA-01017: invalid username/password; logon denied\n"}  
[2020-06-03T08:42:21,172][ERROR][logstash.inputs.jdbc] Unable to connect to database. Trying again {:error\_message=\>"Java::JavaSql::SQLException: ORA-01017: invalid username/password; logon denied\n"}  
[2020-06-03T08:42:22,248][ERROR][logstash.inputs.jdbc] Unable to connect to database. Trying again {:error\_message=\>"Java::JavaSql::SQLException: ORA-01017: invalid username/password; logon denied\n"}  
[2020-06-03T08:42:23,343][ERROR][logstash.inputs.jdbc] Unable to connect to database. Tried 5 times {:error\_message=\>"Java::JavaSql::SQLException: ORA-01017: invalid username/password; logon denied\n"}  
[2020-06-03T08:42:23,344][ERROR][logstash.javapipeline] A plugin had an unrecoverable error. Will restart this plugin.

I am using wrong password here. in order see how connection failure will be handled .  
and i don't want my plugin to restart . can anyone help please

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 1, 2020, 9:28am UTC](https://discuss.elastic.co/t/stopping-plugin-restart-in-logstash/235503/2 "2020-07-01T09:28:36Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
