# Strange error - 'provisioner-\*' index pattern doesn't have a scripted field called 'kubernetes.labels.eks\_amazonaws\_com'

**URL:** https://discuss.elastic.co/t/strange-error-provisioner-index-pattern-doesnt-have-a-scripted-field-called-kubernetes-labels-eks-amazonaws-com/266621
**Category:** Elasticsearch
**Created:** [March 9, 2021, 12:13am UTC](https://discuss.elastic.co/t/strange-error-provisioner-index-pattern-doesnt-have-a-scripted-field-called-kubernetes-labels-eks-amazonaws-com/266621 "2021-03-09T00:13:52Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![pingz](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/pingz/32/58555_2.png) [@pingz](https://discuss.elastic.co/u/pingz)
#### Post date: [March 9, 2021, 12:13am UTC](https://discuss.elastic.co/t/strange-error-provisioner-index-pattern-doesnt-have-a-scripted-field-called-kubernetes-labels-eks-amazonaws-com/266621/1 "2021-03-09T00:13:52Z")

</div>

```auto
I have an elastic index pattern named "provisoner-*" that contains field "kubernetes.labels.eks_amazonaws_com/component"
I noticed that whenever I tried to edit a field that contains character '/', in Kinana index patterns page, Kibana will throw the error above.

Please notice that the fields with character '/' were automatically created by filebeat's kubernetes processor. 
What I would like to do is to change the index field format to url so I can create links

Elastic, Kibana and filebeat 7.10.0 are used.

Is there a workaround? Character '/' is used common in Kubernetes labels, does filebeat Kubernetes processor have a config setting to escape character '/' ?

```

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [April 6, 2021, 12:14am UTC](https://discuss.elastic.co/t/strange-error-provisioner-index-pattern-doesnt-have-a-scripted-field-called-kubernetes-labels-eks-amazonaws-com/266621/2 "2021-04-06T00:14:07Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
