# Stuck running docker logstash with pipelines.yml (binding)

**URL:** <https://discuss.elastic.co/t/stuck-running-docker-logstash-with-pipelines-yml-binding/245225>\
**Category:** Logstash\
**Created:** [August 17, 2020, 11:16am UTC](https://discuss.elastic.co/t/stuck-running-docker-logstash-with-pipelines-yml-binding/245225 "2020-08-17T11:16:49Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![nino](https://avatars.discourse-cdn.com/v4/letter/n/b9bd4f/32.png) [@nino](https://discuss.elastic.co/u/nino)\
**Post date:** [August 17, 2020, 11:16am UTC](https://discuss.elastic.co/t/stuck-running-docker-logstash-with-pipelines-yml-binding/245225/1 "2020-08-17T11:16:50Z")

</div>

Dear all,

i can't get logstash working multipipeline mode inside a docker container.

**pipelines.yml (inside container)**

```
/usr/share/logstash/config
bash-4.2$ stat pipelines.yml 
  File: ‘pipelines.yml’
Access: (0644/-rw-r--r--) Uid: ( 1000/logstash) Gid: ( 0/ root)

```

**docker-compose.yml** volume section

```
volumes:
  - type: bind
      source: ./logstash/config/logstash.yml
      target: /usr/share/logstash/config/logstash.yml
      read_only: true

- type: bind
     source: ./logstash/pipeline
     target: /usr/share/logstash/pipeline
     read_only: true

- type: bind
     source: ./logstash/config/pipelines.yml
     target: /usr/share/logstash/config/pipelines.yml
     read_only: true

```

No way to bind pipelines.yml i am getting this error when trying to bind pipelines.yml

`ERROR: for logstash Cannot start service logstash: OCI runtime create failed: container_linux.go:346: starting container process caused "process_linux.go:449: container init caused \"rootfs_linux.go:58: mounting \\\"/home/user/docker-elk/logstash/config/pipelines.yml\\\" to rootfs \\\"/var/lib/docker/overlay2/49aeb7ecb70e07930c316ffc8e7d0d5a18a151da91c8b40990bf7f7ee3306158/merged\\\" at \\\"/var/lib/docker/overlay2/49aeb7ecb70e07930c316ffc8e7d0d5a18a151da91c8b40990bf7f7ee3306158/merged/usr/share/logstash/config/pipelines.yml\\\" caused \\\"not a directory\\\"\"": unknown: Are you trying to mount a directory onto a file (or vice-versa)? Check if the specified host path exists and is the expected type`

---

<div class="post-metadata">

**Author:** ![Xavier\_Krantz](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/xavier_krantz/32/59812_2.png) [@Xavier\_Krantz](https://discuss.elastic.co/u/Xavier_Krantz)\
**Post date:** [August 17, 2020, 3:58pm UTC](https://discuss.elastic.co/t/stuck-running-docker-logstash-with-pipelines-yml-binding/245225/2 "2020-08-17T15:58:00Z")

</div>

Hi @nino ,

Usually, when I face this kind of error message, the source of the volume is wrong.

Have you checked that `./logstash/config/pipelines.yml` exists ?

---

<div class="post-metadata">

**Author:** ![nino](https://avatars.discourse-cdn.com/v4/letter/n/b9bd4f/32.png) [@nino](https://discuss.elastic.co/u/nino)\
**Post date:** [August 17, 2020, 5:03pm UTC](https://discuss.elastic.co/t/stuck-running-docker-logstash-with-pipelines-yml-binding/245225/3 "2020-08-17T17:03:10Z")

</div>

Thanks Xavier, that's it!. pipelines.yml does not exit in host.

Best

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 14, 2020, 5:03pm UTC](https://discuss.elastic.co/t/stuck-running-docker-logstash-with-pipelines-yml-binding/245225/4 "2020-09-14T17:03:13Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
