Successfully started Logstash API endpoint {:port=>9600}

new to elk i am facing below errors
filebeats.yaml
filebeat.inputs:

Each - is an input. Most options can be set at the input level, so

you can use different inputs for various configurations.

Below are the input specific configurations.

  • type: log

    Change to true to enable this input configuration.

    enabled: true
    fields:
    source: 'ip-10-39-241-95.ec2.internal'
    fields_under_root: true

    Paths that should be crawled and fetched. Glob based paths.

    paths:

    • /home/ec2-user/log/pymnts_batch1_log
      #- /var/log/*.log
      #- c:\programdata\elasticsearch\logs*
      #- pipeline.id: main

path.config: "/etc/logstash/conf.d/*.conf"

logstash:
pipe.yml

  • pipeline.id: beats-server
    config.string: |
    input { beats { port => 5044 } }
    output {
    if [source] == 'ip-10-39-241-95.ec2.internal' {
    pipeline { send_to => payment }
    }
    }

  • pipeline.id: a-processing
    path.config: "/etc/logstash/conf.d/test-sample.conf"

conf file:
input { pipeline { address => payment } }
filter {
json {
source => "message"
}
}
output {
elasticsearch {
hosts => ["https://225b99c3f7f04df3843f271ef5a498ce.elklog.useast1.corpprod.awswuintranet.net:443"]
ssl_certificate_verification => false
user => elastic
password => hXs9MV8KJfeLQomvBHoMmT0U
manage_template => true
index => "logstash-%{+YYYY.MM.dd}"
}

}

logs:
2020-07-24T07:42:44,782][WARN ][logstash.outputs.elasticsearch][a-processing] Restored connection to ES instance {:url=>"https://elastic:xxxxxx@225b99c3f7f04df3843f271ef5a498ce.elklog.useast1.corpprod.awswuintranet.net:443/"}
[2020-07-24T07:42:44,861][INFO ][logstash.inputs.beats ][beats-server] Beats inputs: Starting input listener {:address=>"0.0.0.0:5044"}
[2020-07-24T07:42:44,879][INFO ][logstash.javapipeline ][beats-server] Pipeline started {"pipeline.id"=>"beats-server"}
[2020-07-24T07:42:44,892][INFO ][logstash.outputs.elasticsearch][a-processing] ES Output version determined {:es_version=>7}
[2020-07-24T07:42:44,900][WARN ][logstash.outputs.elasticsearch][a-processing] Detected a 6.x and above cluster: the type event field won't be used to determine the document _type {:es_version=>7}
[2020-07-24T07:42:44,946][INFO ][org.logstash.beats.Server][beats-server][b25816bf99f459771403646f73d9730fe9ed3ac6ead16ec23c7184ff18b8a6ec] Starting server on port: 5044
[2020-07-24T07:42:44,956][INFO ][logstash.outputs.elasticsearch][a-processing] New Elasticsearch output {:class=>"LogStash::Outputs::ElasticSearch", :hosts=>["https://225b99c3f7f04df3843f271ef5a498ce.elklog.useast1.corpprod.awswuintranet.net:443"]}
[2020-07-24T07:42:44,968][INFO ][logstash.javapipeline ][a-processing] Starting pipeline {:pipeline_id=>"a-processing", "pipeline.workers"=>16, "pipeline.batch.size"=>125, "pipeline.batch.delay"=>50, "pipeline.max_inflight"=>2000, "pipeline.sources"=>["/etc/logstash/conf.d/test-sample.conf"], :thread=>"#<Thread:0x2c41b4f4@/usr/share/logstash/logstash-core/lib/logstash/pipeline_action/create.rb:54 run>"}
[2020-07-24T07:42:45,047][INFO ][logstash.javapipeline ][a-processing] Pipeline started {"pipeline.id"=>"a-processing"}
[2020-07-24T07:42:45,057][INFO ][logstash.outputs.elasticsearch][a-processing] Using default mapping template
[2020-07-24T07:42:45,072][INFO ][logstash.agent ] Pipelines running {:count=>2, :running_pipelines=>[:"beats-server", :"a-processing"], :non_running_pipelines=>}
[2020-07-24T07:42:45,105][INFO ][logstash.outputs.elasticsearch][a-processing] Attempting to install template {:manage_template=>{"index_patterns"=>"logstash-", "version"=>60001, "settings"=>{"index.refresh_interval"=>"5s", "number_of_shards"=>1}, "mappings"=>{"dynamic_templates"=>[{"message_field"=>{"path_match"=>"message", "match_mapping_type"=>"string", "mapping"=>{"type"=>"text", "norms"=>false}}}, {"string_fields"=>{"match"=>"", "match_mapping_type"=>"string", "mapping"=>{"type"=>"text", "norms"=>false, "fields"=>{"keyword"=>{"type"=>"keyword", "ignore_above"=>256}}}}}], "properties"=>{"@timestamp"=>{"type"=>"date"}, "@version"=>{"type"=>"keyword"}, "geoip"=>{"dynamic"=>true, "properties"=>{"ip"=>{"type"=>"ip"}, "location"=>{"type"=>"geo_point"}, "latitude"=>{"type"=>"half_float"}, "longitude"=>{"type"=>"half_float"}}}}}}}
[2020-07-24T07:42:45,190][INFO ][logstash.agent ] Successfully started Logstash API endpoint {:port=>9600}

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.