# Support needed (Install Issues)

**URL:** <https://discuss.elastic.co/t/support-needed-install-issues/288151>\
**Category:** Elasticsearch\
**Created:** [November 1, 2021, 3:01pm UTC](https://discuss.elastic.co/t/support-needed-install-issues/288151 "2021-11-01T15:01:11Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![Hondo](https://avatars.discourse-cdn.com/v4/letter/h/aeb1de/32.png) [@Hondo](https://discuss.elastic.co/u/Hondo)\
**Post date:** [November 1, 2021, 3:01pm UTC](https://discuss.elastic.co/t/support-needed-install-issues/288151/1 "2021-11-01T15:01:12Z")

</div>

Hello,

our webhoster have issius to install "Elasticsearch" on our ded. Rootserver with Almalinnux 8.4.0

He`s write

> Blockquote  
> Regarding the Elasticsearch application issue, it seems that you may need to further check with the application support regarding the error.

As the application is a third party application we already assist to install the application and enable based on courtesy basis.

However, it seems that the are error when we restarting the Elasticsearch service. Upon checking the error log (/var/log/elasticsearch/elasticsearch.log) we getting below error log

++++  
unable to load JNA native support library, native methods will be disabled.  
java.lang.UnsatisfiedLinkError: /tmp/elasticsearch-7892321421911741073/jna9000367171271507316.tmp: /tmp/elasticsearch-7892321421911741073/jna9000367171271507316.tmp: failed to map segment from shared object  
++++

We have tried to troubleshooting this error by refer to the forum as below but it seems that it doesn't solve the issue and causing the application unable to be running

> <https://stackoverflow.com/questions/31677563/elasticsearch-failed-to-connect-to-localhost-port-9200-connection-refused>

> [@ELK curl: (7) Failed to connect to localhost port 9200: Connection refused](https://discuss.elastic.co/t/elk-curl-7-failed-to-connect-to-localhost-port-9200-connection-refused/184500/9):
>
> This is all the elasticsearch log folder sudo ls -l /var/log/elasticsearch/ total 788 -rw-r--r-- 1 elasticsearch elasticsearch 0 Jun 6 06:39 elasticsearch\_audit.json -rw-r--r-- 1 elasticsearch elasticsearch 0 Jun 6 06:39 elasticsearch\_deprecation.json -rw-r--r-- 1 elasticsearch elasticsearch 0 Jun 6 06:39 elasticsearch\_deprecation.log -rw-r--r-- 1 elasticsearch elasticsearch 0 Jun 6 06:39 elasticsearch\_index\_indexing\_slowlog.json -rw-r--r-- 1 elasticsearch elasticsearch …

Thus, we suggest you to seek for Elasticsearch support assistance in order to further assist you with the further troubleshooting as the application is developed from their side

Kindly let us know if you need our further clarification

Thank you

> Blockquote

Can everybody help to fix this problem`?

best regards 🙂

---

<div class="post-metadata">

**Author:** ![rugenl](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rugenl/32/12887_2.png) [@rugenl](https://discuss.elastic.co/u/rugenl)\
**Post date:** [November 1, 2021, 3:14pm UTC](https://discuss.elastic.co/t/support-needed-install-issues/288151/2 "2021-11-01T15:14:02Z")

</div>

Have you verified that elastic is functional? Start with a basic `curl localhost:9200`. If you are using ssl and login, you will have to add those to the curl.

When this works, try the same command from the client OS. When that works, move to curl queries for your specific app.

---

<div class="post-metadata">

**Author:** ![Hondo](https://avatars.discourse-cdn.com/v4/letter/h/aeb1de/32.png) [@Hondo](https://discuss.elastic.co/u/Hondo)\
**Post date:** [November 1, 2021, 3:34pm UTC](https://discuss.elastic.co/t/support-needed-install-issues/288151/3 "2021-11-01T15:34:10Z")

</div>

> [@rugenl](#):
>
> `curl localhost:9200`

Via Terminal come the Message  
"curl: (7) Failed to connect to localhost port 9200: Connection refused"

best regards

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [November 1, 2021, 10:55pm UTC](https://discuss.elastic.co/t/support-needed-install-issues/288151/4 "2021-11-01T22:55:00Z")

</div>

Welcome to our community! 😃

Can you please post the Elasticsearch logs, usually under `/var/log/elasticsearch/`. Please format your code/logs/config using the `</>` button, or markdown style back ticks. It helps to make things easy to read which helps us help you 🙂

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 29, 2021, 10:55pm UTC](https://discuss.elastic.co/t/support-needed-install-issues/288151/5 "2021-11-29T22:55:31Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
