# Support of mongodb+srv to connect with Atlas Mongo

**URL:** <https://discuss.elastic.co/t/support-of-mongodb-srv-to-connect-with-atlas-mongo/298445>\
**Category:** Logstash\
**Created:** [February 28, 2022, 8:26pm UTC](https://discuss.elastic.co/t/support-of-mongodb-srv-to-connect-with-atlas-mongo/298445 "2022-02-28T20:26:55Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![zvazquez](https://avatars.discourse-cdn.com/v4/letter/z/c0e974/32.png) [@zvazquez](https://discuss.elastic.co/u/zvazquez)\
**Post date:** [February 28, 2022, 8:26pm UTC](https://discuss.elastic.co/t/support-of-mongodb-srv-to-connect-with-atlas-mongo/298445/1 "2022-02-28T20:26:55Z")

</div>

Hi,

I am trying to push data coming into Logstash to MongoDB on Atlas. My output configuration is as following:

```auto
mongodb {
        id => "logs"
        collection => "logentries"
        database => "logs"
        uri => "mongodb+srv://<user>:<password>@uswest2dev.3qbyg.mongodb.net/logs?ssl=true&w=majority"
        codec => "json"
      }

```

Seems that the plugin does not know how to interpret "mongodb+srv" which is needed as DNS Seed List to connect to the proper Atlas Mongo node within the cluster.

```auto
[ERROR] 2022-02-28 20:23:38.497 [[main]-pipeline-manager] javapipeline - Pipeline error {:pipeline_id=>"main", :exception=>#<Mongo::Error::InvalidURI: MongoDB URI must be in the following format: mongodb://[username:password@]host1[:port1][,host2[:port2],...[,hostN[:portN]]][/[database][?options]]

Please see the following URL for more information: http://docs.mongodb.org/manual/reference/connection-string/

Bad URI: mongodb+srv://cxmdev_rw1:@uswest2dev.3qbyg.mongodb.net/readAccessLogging?ssl=true&w=majority>, :backtrace=>["/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/mongo-2.0.6/lib/mongo/uri.rb:127:in `initialize'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/mongo-2.0.6/lib/mongo/client.rb:266:in `create_from_uri'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/mongo-2.0.6/lib/mongo/client.rb:150:in `initialize'", "/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-output-mongodb-3.1.5/lib/logstash/outputs/mongodb.rb:55:in `register'", "org/logstash/config/ir/compiler/OutputStrategyExt.java:131:in `register'", "org/logstash/config/ir/compiler/AbstractOutputDelegatorExt.java:68:in `register'", "/usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:228:in `block in register_plugins'", "org/jruby/RubyArray.java:1809:in `each'", "/usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:227:in `register_plugins'", "/usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:585:in `maybe_setup_out_plugins'", "/usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:240:in `start_workers'", "/usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:185:in `run'", "/usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:137:in `block in start'"], "pipeline.sources"=>["/usr/share/logstash/pipeline/logstash.conf"], :thread=>"#<Thread:0x44ec91b1@/usr/share/logstash/logstash-core/lib/logstash/java_pipeline.rb:125 run>"}

[INFO] 2022-02-28 20:23:38.498 [[main]-pipeline-manager] javapipeline - Pipeline terminated {"pipeline.id"=>"main"}

[ERROR] 2022-02-28 20:23:38.509 [Converge PipelineAction::Create<main>] agent - Failed to execute action {:id=>:main, :action_type=>LogStash::ConvergeResult::FailedAction, :message=>"Could not execute action: PipelineAction::Create<main>, action_result: false", :backtrace=>nil}

[INFO] 2022-02-28 20:23:38.597 [LogStash::Runner] runner - Logstash shut down.

```

**Is there any support connection string to send data from Logstash into Atlas Mongo clusters?**

Thanks,

Zareh

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 28, 2022, 8:27pm UTC](https://discuss.elastic.co/t/support-of-mongodb-srv-to-connect-with-atlas-mongo/298445/2 "2022-03-28T20:27:04Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
