# Syntax error shown in EQL queries for correlation

**URL:** <https://discuss.elastic.co/t/syntax-error-shown-in-eql-queries-for-correlation/296836>\
**Category:** Elastic Security\
**Created:** [February 10, 2022, 12:25pm UTC](https://discuss.elastic.co/t/syntax-error-shown-in-eql-queries-for-correlation/296836 "2022-02-10T12:25:26Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![wsouza](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/wsouza/32/92547_2.png) [@wsouza](https://discuss.elastic.co/u/wsouza)\
**Post date:** [February 10, 2022, 12:25pm UTC](https://discuss.elastic.co/t/syntax-error-shown-in-eql-queries-for-correlation/296836/1 "2022-02-10T12:25:26Z")

</div>

Hi folks!

I'm running a query, through EQL, for event correlation, however, it's returning a syntax error. The strange thing is that the same query is made in another Elastic SIEM and it doesn't return an error. Has anyone had these problems?

I currently use Elastic SIEM version 7.16.1 on both servers on one of them it worked. In the other not. I tested it on version 14 and it worked. This occurs on my second server that I monitor.

```auto
verification_exception: Found 2 problems line 2:5: Cannot use field [event.category] due to ambiguities being mapped as [2] incompatible types: [text] in [packetbeat-7.16.1, packetbeat-7.16.2, winlogbeat-7.15.0], [keyword] in [.ds-logs-endpoint.alerts-default-2022.01.07-000001

```

```auto
sequence with maxspan=2m
  [authentication where event.code == "4625"]
  [network where destination.port == "3389"]
![evidence|690x263](upload://fv7WU7ktM4h5ajxDT7xIH6yWxOu.png)

```

 ![evidence](https://us1.discourse-cdn.com/elastic/original/3X/6/c/6ca5683dbac8173637680c56e711e01ea5be9d0e.png)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 10, 2022, 12:25pm UTC](https://discuss.elastic.co/t/syntax-error-shown-in-eql-queries-for-correlation/296836/2 "2022-03-10T12:25:47Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
