# System has not been booted with systemd as init system (PID 1)

**URL:** <https://discuss.elastic.co/t/system-has-not-been-booted-with-systemd-as-init-system-pid-1/255422>\
**Category:** Logstash\
**Created:** [November 15, 2020, 5:04am UTC](https://discuss.elastic.co/t/system-has-not-been-booted-with-systemd-as-init-system-pid-1/255422 "2020-11-15T05:04:03Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Naba01](https://avatars.discourse-cdn.com/v4/letter/n/ecae2f/32.png) [@Naba01](https://discuss.elastic.co/u/Naba01)\
**Post date:** [November 15, 2020, 5:04am UTC](https://discuss.elastic.co/t/system-has-not-been-booted-with-systemd-as-init-system-pid-1/255422/1 "2020-11-15T05:04:03Z")

</div>

I have installed elasticsearch and kibana on my WSL.Able to start services using "sudo /etc/init.d/" command  
But unable to start services for logstash

Below command is not working:  
root@Flamingo:~# sudo systemctl start logstash

System has not been booted with systemd as init system (PID 1). Can't operate.  
Failed to connect to bus: Host is down

Any suggestion or workaround for starting logstash. Below the os details:  
root@Flamingo:~# uname -a  
Linux Flamingo 4.4.0-19041-Microsoft #488-Microsoft Mon Sep 01 13:43:00 PST 2020 x86\_64 x86\_64 x86\_64 GNU/Linux

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 13, 2020, 5:04am UTC](https://discuss.elastic.co/t/system-has-not-been-booted-with-systemd-as-init-system-pid-1/255422/2 "2020-12-13T05:04:07Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
