# Task record not created when wait\_for\_completion=false and server under load

**URL:** https://discuss.elastic.co/t/task-record-not-created-when-wait-for-completion-false-and-server-under-load/244080
**Category:** Elasticsearch
**Created:** [August 6, 2020, 6:10pm UTC](https://discuss.elastic.co/t/task-record-not-created-when-wait-for-completion-false-and-server-under-load/244080 "2020-08-06T18:10:31Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![redec](https://avatars.discourse-cdn.com/v4/letter/r/47e85d/32.png) [@redec](https://discuss.elastic.co/u/redec)
#### Post date: [August 6, 2020, 6:10pm UTC](https://discuss.elastic.co/t/task-record-not-created-when-wait-for-completion-false-and-server-under-load/244080/1 "2020-08-06T18:10:31Z")

</div>

Hi all. I'm experiencing a problem where I'm issuing update\_by\_query/delete\_by\_query requests, specifying wait\_for\_completion=false....and I get back a task id as I should, but when I attempt to GET that task I get resource\_not\_found\_exception. It only happens very sporadically and seemingly only when the cluster is under a good amount of load. Around the same time I am seeing other requests get rejected because the write queue is full (es\_rejected\_execution\_exception) ....is it possible that the update-by-query request has been accepted and is executing, but internally the insertion of the task record was rejected because the write queue was full? It seems like a bug that it would return me a task id that doesn't exist. Does anyone have any theories what's going on here or possible workarounds? Thanks 🙂

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [September 3, 2020, 6:10pm UTC](https://discuss.elastic.co/t/task-record-not-created-when-wait-for-completion-false-and-server-under-load/244080/2 "2020-09-03T18:10:43Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
