# Tcp.go WARN DNS lookup failure no such host

**URL:** https://discuss.elastic.co/t/tcp-go-warn-dns-lookup-failure-no-such-host/121048
**Category:** Beats
**Created:** [February 22, 2018, 12:44pm UTC](https://discuss.elastic.co/t/tcp-go-warn-dns-lookup-failure-no-such-host/121048 "2018-02-22T12:44:53Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![fabifrank](https://avatars.discourse-cdn.com/v4/letter/f/3da27b/32.png) [@fabifrank](https://discuss.elastic.co/u/fabifrank)
#### Post date: [February 22, 2018, 12:44pm UTC](https://discuss.elastic.co/t/tcp-go-warn-dns-lookup-failure-no-such-host/121048/1 "2018-02-22T12:44:54Z")

</div>

Today I set up metricbeat on a kubernetes cluster and cant make it connect to the elastic search logging pod.

I followed this example here: [https://www.elastic.co/guide/en/beats/metricbeat/current/running-on-kubernetes.html](https://www.elastic.co/guide/en/beats/metricbeat/current/running-on-kubernetes.html)

The singleton instance seems to be fine connecting, but the other deamons are not - thats the output of one of the deamons:

```
2018/02/22 12:29:12.156143 tcp.go:36: WARN DNS lookup failure "elasticsearch-logging.kube-system.svc.cluster.local": lookup elasticsearch-logging.kube-system.svc.cluster.local: no such host

```

2018/02/22 12:29:13.156380 output.go:74: ERR Failed to connect: Get [http://elasticsearch-logging.kube-system.svc.cluster.local:9200](http://elasticsearch-logging.kube-system.svc.cluster.local:9200): lookup elasticsearch-logging.kube-system.svc.cluster.local: no such host  
2018/02/22 12:29:13.157815 tcp.go:36: WARN DNS lookup failure "elasticsearch-logging.kube-system.svc.cluster.local": lookup elasticsearch-logging.kube-system.svc.cluster.local: no such host  
2018/02/22 12:29:15.158009 output.go:74: ERR Failed to connect: Get [http://elasticsearch-logging.kube-system.svc.cluster.local:9200](http://elasticsearch-logging.kube-system.svc.cluster.local:9200): lookup elasticsearch-logging.kube-system.svc.cluster.local: no such host  
2018/02/22 12:29:15.173593 tcp.go:36: WARN DNS lookup failure "elasticsearch-logging.kube-system.svc.cluster.local": lookup elasticsearch-logging.kube-system.svc.cluster.local: no such host  
2018/02/22 12:29:19.173815 output.go:74: ERR Failed to connect: Get [http://elasticsearch-logging.kube-system.svc.cluster.local:9200](http://elasticsearch-logging.kube-system.svc.cluster.local:9200): lookup elasticsearch-logging.kube-system.svc.cluster.local: no such host  
2018/02/22 12:29:19.178753 tcp.go:36: WARN DNS lookup failure "elasticsearch-logging.kube-system.svc.cluster.local": lookup elasticsearch-logging.kube-system.svc.cluster.local: no such host

Where's that error coming from?

---

<div class="post-metadata">

### Author: ![ruflin](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ruflin/32/3116_2.png) [@ruflin](https://discuss.elastic.co/u/ruflin)
#### Post date: [March 3, 2018, 11:54pm UTC](https://discuss.elastic.co/t/tcp-go-warn-dns-lookup-failure-no-such-host/121048/2 "2018-03-03T23:54:39Z")

</div>

Could you share your config file(s)?

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [March 15, 2018, 12:45pm UTC](https://discuss.elastic.co/t/tcp-go-warn-dns-lookup-failure-no-such-host/121048/3 "2018-03-15T12:45:32Z")

</div>

This topic was automatically closed after 21 days. New replies are no longer allowed.
