# Template ERROR reason: Root mapping definition has unsupported parameters

**URL:** https://discuss.elastic.co/t/template-error-reason-root-mapping-definition-has-unsupported-parameters/220411
**Category:** Elasticsearch
**Created:** [February 21, 2020, 4:00pm UTC](https://discuss.elastic.co/t/template-error-reason-root-mapping-definition-has-unsupported-parameters/220411 "2020-02-21T16:00:39Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![Rama\_Krishna\_S](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rama_krishna_s/32/63117_2.png) [@Rama\_Krishna\_S](https://discuss.elastic.co/u/Rama_Krishna_S)
#### Post date: [February 21, 2020, 4:00pm UTC](https://discuss.elastic.co/t/template-error-reason-root-mapping-definition-has-unsupported-parameters/220411/1 "2020-02-21T16:00:40Z")

</div>

unable to create template following is my template.

#! Deprecation: [types removal] The parameter include\_type\_name should be explicitly specified in get template requests to prepare for 7.0. In 7.0 include\_type\_name will default to 'false', which means responses will omit the type name in mapping definitions.  
{  
"logstash" : {  
"order" : 0,  
"index\_patterns" : [  
"logstash\*"  
],  
"settings" : {  
"index" : {  
"analysis" : {  
"filter" : {  
"firsttoken" : {  
"type" : "pattern\_capture",  
"preserve\_original" : "false",  
"patterns" : [  
"""^([^.]_).?._""" ] }, "secondtoken" : { "type" : "pattern\_capture", "preserve\_original" : "false", "patterns" : ["""^[^\.]\*\.([^\.]\*)\.?.\*"""  
]  
},  
"thirdtoken" : {  
"type" : "pattern\_capture",  
"preserve\_original" : "false",  
"patterns" : [  
"""^[^.]_.[^.]_.([^.]_).?._$"""  
]  
}  
},  
"analyzer" : {  
"firsttoken" : {  
"filter" : [  
"firsttoken"  
],  
"tokenizer" : "keyword"  
},  
"secondtoken" : {  
"filter" : [  
"secondtoken"  
],  
"tokenizer" : "keyword"  
},  
"thirdtoken" : {  
"filter" : [  
"thirdtoken"  
],  
"tokenizer" : "keyword"  
}  
}  
}  
}  
},  
"mappings" : {  
"dynamic" : false,  
"events" : {  
"properties" : {  
"msg" : {  
"type" : "text",  
"fields" : {  
"raw" : {  
"type" : "keyword"  
}  
}  
},  
"requestId" : {  
"type" : "keyword"  
},  
"logger" : {  
"type" : "keyword"  
},  
"host" : {  
"type" : "keyword"  
},  
"jwtOwner" : {  
"type" : "keyword"  
},  
"requestOriginator" : {  
"type" : "keyword"  
},  
"tag" : {  
"analyzer" : "firsttoken",  
"fields" : {  
"disambiguator" : {  
"analyzer" : "keyword",  
"type" : "text"  
}  
},  
"type" : "text"  
},  
"jwtAuthenticatedUser" : {  
"type" : "keyword"  
},  
"thread" : {  
"type" : "keyword"  
},  
"requestChainOriginator" : {  
"type" : "keyword"  
},  
"revision" : {  
"type" : "keyword"  
}  
}  
}  
},  
"aliases" : { }  
}  
}

Error message:  
{  
"error": {  
"root\_cause": [  
{  
"type": "mapper\_parsing\_exception",  
"reason": "Root mapping definition has unsupported parameters: [events : {properties={requestId={type=keyword}, logger={type=keyword}, host={type=keyword}, jwtOwner={type=keyword}, requestOriginator={type=keyword}, tag={analyzer=firsttoken, fields={disambiguator={analyzer=keyword, type=text}}}, jwtAuthenticatedUser={type=keyword}, thread={type=keyword}, requestChainOriginator={type=keyword}, revision={type=keyword}}}]"  
}  
],  
"type": "mapper\_parsing\_exception",  
"reason": "Failed to parse mapping [\_doc]: Root mapping definition has unsupported parameters: [events : {properties={requestId={type=keyword}, logger={type=keyword}, host={type=keyword}, jwtOwner={type=keyword}, requestOriginator={type=keyword}, tag={analyzer=firsttoken, fields={disambiguator={analyzer=keyword, type=text}}}, jwtAuthenticatedUser={type=keyword}, thread={type=keyword}, requestChainOriginator={type=keyword}, revision={type=keyword}}}]",  
"caused\_by": {  
"type": "mapper\_parsing\_exception",  
"reason": "Root mapping definition has unsupported parameters: [events : {properties={requestId={type=keyword}, logger={type=keyword}, host={type=keyword}, jwtOwner={type=keyword}, requestOriginator={type=keyword}, tag={analyzer=firsttoken, fields={disambiguator={analyzer=keyword, type=text}}}, jwtAuthenticatedUser={type=keyword}, thread={type=keyword}, requestChainOriginator={type=keyword}, revision={type=keyword}}}]"  
}  
},  
"status": 400  
}

The template is from elasticsearch 6 and trying to import to new version elasticsearch 7.

Could anyone help me? Thanks in advance.

---

<div class="post-metadata">

### Author: ![Rama\_Krishna\_S](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rama_krishna_s/32/63117_2.png) [@Rama\_Krishna\_S](https://discuss.elastic.co/u/Rama_Krishna_S)
#### Post date: [February 21, 2020, 7:16pm UTC](https://discuss.elastic.co/t/template-error-reason-root-mapping-definition-has-unsupported-parameters/220411/2 "2020-02-21T19:16:20Z")

</div>

I resolved the issue..

below is the updated template

```
PUT _template/logstash 

```

{  
"order" : 0,  
"index\_patterns" : [  
"logstash\*"  
],  
"settings" : {  
"index" : {  
"analysis" : {  
"filter" : {  
"firsttoken" : {  
"type" : "pattern\_capture",  
"preserve\_original" : "false",  
"patterns" : [  
"""^([^.]_).?._""" ] }, "secondtoken" : { "type" : "pattern\_capture", "preserve\_original" : "false", "patterns" : ["""^[^\.]\*\.([^\.]\*)\.?.\*"""  
]  
},  
"thirdtoken" : {  
"type" : "pattern\_capture",  
"preserve\_original" : "false",  
"patterns" : [  
"""^[^.]_.[^.]_.([^.]_).?._$"""  
]  
}  
},  
"analyzer" : {  
"firsttoken" : {  
"filter" : [  
"firsttoken"  
],  
"tokenizer" : "keyword"  
},  
"secondtoken" : {  
"filter" : [  
"secondtoken"  
],  
"tokenizer" : "keyword"  
},  
"thirdtoken" : {  
"filter" : [  
"thirdtoken"  
],  
"tokenizer" : "keyword"  
}  
}  
}  
}  
},  
"mappings" : {  
"dynamic" : false,

```
    "properties" : {
      "requestId" : {
        "type" : "keyword"
      },
      "logger" : {
        "type" : "keyword"
      },
      "host" : {
        "type" : "keyword"
      },
      "jwtOwner" : {
        "type" : "keyword"
      },
      "requestOriginator" : {
        "type" : "keyword"
      },
      "tag" : {
        "analyzer" : "firsttoken",
        "fields" : {
          "disambiguator" : {
            "analyzer" : "keyword",
            "type" : "text"
          }
        },
        "type" : "text"
      },
      "jwtAuthenticatedUser" : {
        "type" : "keyword"
      },
      "thread" : {
        "type" : "keyword"
      },
      "requestChainOriginator" : {
        "type" : "keyword"
      },
      "revision" : {
        "type" : "keyword"
      }
    }
  },
"aliases" : { }

```

}

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [March 20, 2020, 7:16pm UTC](https://discuss.elastic.co/t/template-error-reason-root-mapping-definition-has-unsupported-parameters/220411/3 "2020-03-20T19:16:26Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
