# Test fails on Travis but pass locally

**URL:** <https://discuss.elastic.co/t/test-fails-on-travis-but-pass-locally/84794>\
**Category:** Elasticsearch\
**Created:** [May 5, 2017, 11:33pm UTC](https://discuss.elastic.co/t/test-fails-on-travis-but-pass-locally/84794 "2017-05-05T23:33:34Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![Braulio\_Bhavamitra](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/braulio_bhavamitra/32/17987_2.png) [@Braulio\_Bhavamitra](https://discuss.elastic.co/u/Braulio_Bhavamitra)\
**Post date:** [May 5, 2017, 11:33pm UTC](https://discuss.elastic.co/t/test-fails-on-travis-but-pass-locally/84794/1 "2017-05-05T23:33:34Z")

</div>

Tried everything I could, but still tests don't pass on Travis. Locally everything is ok!

The error is `Caused by: org.elasticsearch.index.mapper.MapperParsingException: No handler for type [text] declared on field [identifier]`

Please see the travis log at [https://travis-ci.org/noosfero/noosfero/jobs/229318728](https://travis-ci.org/noosfero/noosfero/jobs/229318728)

---

<div class="post-metadata">

**Author:** ![jasontedor](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jasontedor/32/66992_2.png) [@jasontedor](https://discuss.elastic.co/u/jasontedor)\
**Post date:** [May 6, 2017, 2:43am UTC](https://discuss.elastic.co/t/test-fails-on-travis-but-pass-locally/84794/2 "2017-05-06T02:43:25Z")

</div>

That's hitting Elasticsearch 1.7.6 where `text` is indeed not a type. Are you hitting the wrong version and hitting a different version locally?

---

<div class="post-metadata">

**Author:** ![Braulio\_Bhavamitra](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/braulio_bhavamitra/32/17987_2.png) [@Braulio\_Bhavamitra](https://discuss.elastic.co/u/Braulio_Bhavamitra)\
**Post date:** [May 6, 2017, 3:16pm UTC](https://discuss.elastic.co/t/test-fails-on-travis-but-pass-locally/84794/3 "2017-05-06T15:16:42Z")

</div>

Hi Jason,

The local version is using exactly the same version from the tarball downloaded from the same address configured for travis.

Best  
Braulio

---

<div class="post-metadata">

**Author:** ![Braulio\_Bhavamitra](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/braulio_bhavamitra/32/17987_2.png) [@Braulio\_Bhavamitra](https://discuss.elastic.co/u/Braulio_Bhavamitra)\
**Post date:** [May 6, 2017, 3:19pm UTC](https://discuss.elastic.co/t/test-fails-on-travis-but-pass-locally/84794/4 "2017-05-06T15:19:08Z")

</div>

Also, the build was passing until [https://travis-ci.org/noosfero/noosfero/builds/218600342](https://travis-ci.org/noosfero/noosfero/builds/218600342), then stopped working only on travis without any change or apparent reason (next build that is failing is [https://travis-ci.org/noosfero/noosfero/builds/220672725](https://travis-ci.org/noosfero/noosfero/builds/220672725))

---

<div class="post-metadata">

**Author:** ![jasontedor](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jasontedor/32/66992_2.png) [@jasontedor](https://discuss.elastic.co/u/jasontedor)\
**Post date:** [May 6, 2017, 4:23pm UTC](https://discuss.elastic.co/t/test-fails-on-travis-but-pass-locally/84794/5 "2017-05-06T16:23:27Z")

</div>

I'm not sure what else to tell you: the version that you show running on CI is definitely 1.7.6, you are definitely sending it a field type that is simply not supported on 1.7.6. If that's working locally, you either have a different version or you've defined a custom field type (through a plugin).

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 3, 2017, 4:36pm UTC](https://discuss.elastic.co/t/test-fails-on-travis-but-pass-locally/84794/6 "2017-06-03T16:36:11Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
