# The client is not connected when Filebeat connects to Logstash

**URL:** https://discuss.elastic.co/t/the-client-is-not-connected-when-filebeat-connects-to-logstash/248654
**Category:** Logstash
**Tags:** docker
**Created:** [September 15, 2020, 10:30am UTC](https://discuss.elastic.co/t/the-client-is-not-connected-when-filebeat-connects-to-logstash/248654 "2020-09-15T10:30:45Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![XiaoyuZhann](https://avatars.discourse-cdn.com/v4/letter/x/3ec8ea/32.png) [@XiaoyuZhann](https://discuss.elastic.co/u/XiaoyuZhann)
#### Post date: [September 15, 2020, 10:30am UTC](https://discuss.elastic.co/t/the-client-is-not-connected-when-filebeat-connects-to-logstash/248654/1 "2020-09-15T10:30:45Z")

</div>

I use the container created by the Docker images [docker.io/sebp/elk](http://docker.io/sebp/elk). When Filebeat connects to Elasticsearch, the information is displayed perfectly in Kibana.But after Filebeat connected to Logstash, Filebeat logs reported some errors:

> 2020-09-15T18:16:25.207+0800 ERROR pipeline/output.go:121 Failed to publish events: client is not connected  
> 2020-09-15T18:16:25.207+0800 INFO pipeline/output.go:95 Connecting to backoff(async(tcp://localhost:5044))  
> 2020-09-15T18:16:25.207+0800 INFO pipeline/output.go:105 Connection to backoff(async(tcp://localhost:5044)) established  
> 2020-09-15T18:16:25.256+0800 ERROR logstash/async.go:256 Failed to publish events caused by: EOF  
> 2020-09-15T18:16:25.304+0800 ERROR logstash/async.go:256 Failed to publish events caused by: client is not connected

This is my instruction to create ELK:  
docker run -d -p 5601:5601 -p 9200:9200 -p 5044:5044 --name elk abce9b

Below is my Filebeat configuration file:

```auto
#-------------------------- Elasticsearch output ------------------------------
#output.elasticsearch:
  #hosts: ["localhost:9200"]
  #protocol: "https"
  #username: "elastic"
  #password: "changeme"
#----------------------------- Logstash output --------------------------------
output.logstash:
  hosts: ["localhost:5044"]
  #ssl.certificate_authorities: ["/etc/pki/root/ca.pem"]
  #ssl.certificate: "/etc/pki/client/cert.pem"
  #ssl.key: "/etc/pki/client/cert.key"

```

---

<div class="post-metadata">

### Author: ![XiaoyuZhann](https://avatars.discourse-cdn.com/v4/letter/x/3ec8ea/32.png) [@XiaoyuZhann](https://discuss.elastic.co/u/XiaoyuZhann)
#### Post date: [September 15, 2020, 10:32am UTC](https://discuss.elastic.co/t/the-client-is-not-connected-when-filebeat-connects-to-logstash/248654/2 "2020-09-15T10:32:27Z")

</div>

Hope to get your suggestions, thank you

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [October 13, 2020, 10:32am UTC](https://discuss.elastic.co/t/the-client-is-not-connected-when-filebeat-connects-to-logstash/248654/3 "2020-10-13T10:32:30Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
