# The error about data type filed

**URL:** <https://discuss.elastic.co/t/the-error-about-data-type-filed/46337>\
**Category:** Logstash\
**Created:** [April 5, 2016, 7:26am UTC](https://discuss.elastic.co/t/the-error-about-data-type-filed/46337 "2016-04-05T07:26:01Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![lester015](https://avatars.discourse-cdn.com/v4/letter/l/cc9497/32.png) [@lester015](https://discuss.elastic.co/u/lester015)\
**Post date:** [April 5, 2016, 7:26am UTC](https://discuss.elastic.co/t/the-error-about-data-type-filed/46337/1 "2016-04-05T07:26:01Z")

</div>

hi everyone,  
I foud the weird problem about my es mapping,it's as flows:  
curl -XPUT 'localhost:9200/v\_ajusted\_fund\_v1' -d '{  
"mappings" : {  
"v\_ajusted\_fund" : {  
"properties" : {  
"period" : {"type" : "integer"},  
"project\_code" : {"type" : "string","index" : "not\_analyzed"},  
"labor\_budget": {"type" : "double"},  
"year\_labor\_budget": {"type" : "double"},  
"total\_p\_project\_fund": {"type" : "double"},  
"year\_fund": {"type" : "double"},  
"total\_year\_fund": {"type" : "double"},  
"total\_f\_project\_fund": {"type" : "double"},  
"create\_time": {"type" : "date"}  
}  
}  
}  
}'

the table field create\_time is date type and the value is:"2013-09-28" .when I excute logstash order,is has an error in console:

ParsingException[failed to parse [create\_time]]; nested: IllegalArgumentException[Invalid format: "2014-09-28 00:00:00 +0800" is malformed at " 00:00:00 +0800"];  
at org.elasticsearch.index.mapper.FieldMapper.parse(FieldMapper.java:343)  
at org.elasticsearch.index.mapper.DocumentParser.parseObjectOrField(DocumentParser.java:318)  
at org.elasticsearch.index.mapper.DocumentParser.parseAndMergeUpdate(DocumentParser.java:765)  
at org.elasticsearch.index.mapper.DocumentParser.parseDynamicValue(DocumentParser.java:652)  
at org.elasticsearch.index.mapper.DocumentParser.parseValue(DocumentParser.java:451)  
at org.elasticsearch.index.mapper.DocumentParser.parseObject(DocumentParser.java:271)  
at org.elasticsearch.index.mapper.DocumentParser.innerParseDocument(DocumentParser.java:131)  
at org.elasticsearch.index.mapper.DocumentParser.parseDocument(DocumentParser.java:79)  
at org.elasticsearch.index.mapper.DocumentMapper.parse(DocumentMapper.java:304)  
at org.elasticsearch.index.shard.IndexShard.prepareCreate(IndexShard.java:500)  
at org.elasticsearch.index.shard.IndexShard.prepareCreateOnPrimary(IndexShard.java:481)  
at org.elasticsearch.action.index.TransportIndexAction.prepareIndexOperationOnPrimary(TransportIndexAction.java:214)  
at org.elasticsearch.action.index.TransportIndexAction.executeIndexRequestOnPrimary(TransportIndexAction.java:223)  
at org.elasticsearch.action.bulk.TransportShardBulkAction.shardIndexOperation(TransportShardBulkAction.java:326)  
at org.elasticsearch.action.bulk.TransportShardBulkAction.shardOperationOnPrimary(TransportShardBulkAction.java:119)  
at org.elasticsearch.action.bulk.TransportShardBulkAction.shardOperationOnPrimary(TransportShardBulkAction.java:68)  
at org.elasticsearch.action.support.replication.TransportReplicationAction$PrimaryPhase.doRun(TransportReplicationAction.java:595)  
at org.elasticsearch.common.util.concurrent.AbstractRunnable.run(AbstractRunnable.java:37)  
at org.elasticsearch.action.support.replication.TransportReplicationAction$PrimaryOperationTransportHandler.messageReceived(TransportReplicationAction.java:263)  
at org.elasticsearch.action.support.replication.TransportReplicationAction$PrimaryOperationTransportHandler.messageReceived(TransportReplicationAction.java:260)  
at org.elasticsearch.transport.TransportService$4.doRun(TransportService.java:350)  
at org.elasticsearch.common.util.concurrent.AbstractRunnable.run(AbstractRunnable.java:37)  
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)  
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)  
at java.lang.Thread.run(Thread.java:745)  
Caused by: java.lang.IllegalArgumentException: Invalid format: "2014-09-28 00:00:00 +0800" is malformed at " 00:00:00 +0800"  
at org.joda.time.format.DateTimeParserBucket.doParseMillis(DateTimeParserBucket.java:187)  
at org.joda.time.format.DateTimeFormatter.parseMillis(DateTimeFormatter.java:780)  
at org.elasticsearch.index.mapper.core.DateFieldMapper$DateFieldType.parseStringValue(DateFieldMapper.java:362)  
at org.elasticsearch.index.mapper.core.DateFieldMapper.innerParseCreateField(DateFieldMapper.java:528)  
at org.elasticsearch.index.mapper.core.NumberFieldMapper.parseCreateField(NumberFieldMapper.java:241)  
at org.elasticsearch.index.mapper.FieldMapper.parse(FieldMapper.java:335)

anyone who I has an solution? very appreciate!

Levi

---

<div class="post-metadata">

**Author:** ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)\
**Post date:** [April 7, 2016, 5:49am UTC](https://discuss.elastic.co/t/the-error-about-data-type-filed/46337/2 "2016-04-07T05:49:15Z")

</div>

This seems more like an ES question than a Logstash one, but I think the problem is quite clear: the `create_time` field is mapped as "date", which without further configuration requires a strict ISO8601 timestamp with or without a time but the timestamp you're trying to cram into the field doesn't conform to that definition. Either remove the time or map the `create_time` field with a time format that matches your input.

---

<div class="post-metadata">

**Author:** ![lester015](https://avatars.discourse-cdn.com/v4/letter/l/cc9497/32.png) [@lester015](https://discuss.elastic.co/u/lester015)\
**Post date:** [April 13, 2016, 6:40am UTC](https://discuss.elastic.co/t/the-error-about-data-type-filed/46337/3 "2016-04-13T06:40:05Z")

</div>

hi magnus,  
I try using the format just like as bellow:  
"create\_time": {"type" : "date","format":"yyyy-MM-dd"},But I found it still has the same error! thanks!

---

<div class="post-metadata">

**Author:** ![lester015](https://avatars.discourse-cdn.com/v4/letter/l/cc9497/32.png) [@lester015](https://discuss.elastic.co/u/lester015)\
**Post date:** [April 13, 2016, 6:46am UTC](https://discuss.elastic.co/t/the-error-about-data-type-filed/46337/4 "2016-04-13T06:46:32Z")

</div>

BTW,I learn from this url:  
[https://www.elastic.co/guide/en/elasticsearch/reference/2.3/date.html#multiple-date-formats](https://www.elastic.co/guide/en/elasticsearch/reference/2.3/date.html#multiple-date-formats)

I also try using this:  
"create\_time": {"type" : "date","format":"yyy-MM-dd HH:mm:ss||yyyy-MM-dd||epoch\_millis"}  
but it's not work!

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 5:02am UTC](https://discuss.elastic.co/t/the-error-about-data-type-filed/46337/5 "2017-07-06T05:02:33Z")

</div>


