# The error message "output.go:92: ERR Failed to publish events: temporary bulk send failure"

**URL:** https://discuss.elastic.co/t/the-error-message-output-go-92-err-failed-to-publish-events-temporary-bulk-send-failure/130239
**Category:** Beats
**Tags:** filebeat
**Created:** [May 2, 2018, 11:10am UTC](https://discuss.elastic.co/t/the-error-message-output-go-92-err-failed-to-publish-events-temporary-bulk-send-failure/130239 "2018-05-02T11:10:15Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![anson\_ch](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/anson_ch/32/26647_2.png) [@anson\_ch](https://discuss.elastic.co/u/anson_ch)
#### Post date: [May 2, 2018, 11:10am UTC](https://discuss.elastic.co/t/the-error-message-output-go-92-err-failed-to-publish-events-temporary-bulk-send-failure/130239/1 "2018-05-02T11:10:15Z")

</div>

I have some problem, the error log is being outputted by filebeat endlessly. please see the following detail message.  
**2018-05-02T09:27:21.879178437Z 2018/05/02 09:27:21.879028 output.go:92: ERR Failed to publish events: temporary bulk send failure**  
**2018-05-02T09:27:21.880330394Z 2018/05/02 09:27:21.880199 client.go:651: INFO Connected to Elasticsearch version 6.1.2**  
**2018-05-02T09:27:21.882671683Z 2018/05/02 09:27:21.882543 load.go:73: INFO Template already exists and will not be overwritten.**  
**2018-05-02T09:27:22.885488217Z 2018/05/02 09:27:22.885285 output.go:92: ERR Failed to publish events: temporary bulk send failure**  
**2018-05-02T09:27:22.886610836Z 2018/05/02 09:27:22.886513 client.go:651: INFO Connected to Elasticsearch version 6.1.2**  
**2018-05-02T09:27:22.888869339Z 2018/05/02 09:27:22.888749 load.go:73: INFO Template already exists and will not be overwritten.**  
**2018-05-02T09:27:23.891780722Z 2018/05/02 09:27:23.891512 output.go:92: ERR Failed to publish events: temporary bulk send failure**

and I collect some config in this environment. see below

1. Beat version 6.1.1
2. Beat config  
filebeat.prospectors:  
-type: log  
enabled: true  
paths:  
- "/var/log/containers/${_SYSTEM\_POD\_NAME}_${_SYSTEM\_NAMESPACE}_${\_SYSTEM\_APP\_NAME}-_.log"  
symlinks: true  
pipeline: haproxyId  
scan\_frequency: 1s  
fields:  
source: ${\_SYSTEM\_APP\_NAME:default}  
host: ${HOSTNAME:default}  
tags:  
-${\_SYSTEM\_NAMESPACE:default}  
fields\_under\_root: true  
json.keys\_under\_root: true  
json.add\_error\_key: true  
json.message\_key: log  
setup.template.name: "haproxy-%{[beat.version]}"  
setup.template.pattern: "haproxy-%{[beat.version]}-_"  
output.elasticsearch:  
hosts: ["elasticsearch-logging:9200"]  
enabled: true  
index: "haproxy-%{[beat.version]}-%{+yyyy.MM.dd}"
3. Elasticsearch logs  
elasticseaarch version: 6.1.2  
_no log output._
4. reproduce step  
(1) run filebeat in docker, harvest log in json-file  
(2) put pipeline in elasticsearch, which named ‘haproxyId’  
(3) access haproxy stats, produce the access log in json-file, then the error log is being outputted by filebeat endlessly.  
Can someone help me solve this problem?

---

<div class="post-metadata">

### Author: ![anson\_ch](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/anson_ch/32/26647_2.png) [@anson\_ch](https://discuss.elastic.co/u/anson_ch)
#### Post date: [May 2, 2018, 1:31pm UTC](https://discuss.elastic.co/t/the-error-message-output-go-92-err-failed-to-publish-events-temporary-bulk-send-failure/130239/2 "2018-05-02T13:31:58Z")

</div>

this problem have solved, which the reason is my elasticsearch pipeline config has error.  
there is detailed error information in filebeat's debug info, we can analyse it careful.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [May 30, 2018, 1:32pm UTC](https://discuss.elastic.co/t/the-error-message-output-go-92-err-failed-to-publish-events-temporary-bulk-send-failure/130239/3 "2018-05-30T13:32:08Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
