# The error reported is: - logstash error

**URL:** <https://discuss.elastic.co/t/the-error-reported-is-logstash-error/32945>\
**Category:** Logstash\
**Created:** [October 26, 2015, 3:17am UTC](https://discuss.elastic.co/t/the-error-reported-is-logstash-error/32945 "2015-10-26T03:17:17Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![tushar.hadoop](https://avatars.discourse-cdn.com/v4/letter/t/958977/32.png) [@tushar.hadoop](https://discuss.elastic.co/u/tushar.hadoop)\
**Post date:** [October 26, 2015, 3:17am UTC](https://discuss.elastic.co/t/the-error-reported-is-logstash-error/32945/1 "2015-10-26T03:17:17Z")

</div>

i am facing this issue for logstash 1.5.4

this is my configuration

output {  
rabbitmq {  
key =\> "ambari-key"  
exchange =\> "ambari-exchange-type"  
exchange\_type =\> "direct"  
user =\> "rabbit"  
password =\> "1234"  
host =\> "my.host.name"  
port =\> 5672  
durable =\> true  
persistent =\> true  
vhost =\> "/"  
}  
}

i error logs, only i can see is ....... {:timestamp=\>"2015-10-25T14:07:45.451000+0000", :message=\>"The error reported is: \n "}

Note - RabbitMQ is configured with the LDAP

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [October 26, 2015, 4:52am UTC](https://discuss.elastic.co/t/the-error-reported-is-logstash-error/32945/2 "2015-10-26T04:52:56Z")

</div>

What's your complete config look like?  
Also make sure you format it when you post, it makes it easier to read.

---

<div class="post-metadata">

**Author:** ![tushar.hadoop](https://avatars.discourse-cdn.com/v4/letter/t/958977/32.png) [@tushar.hadoop](https://discuss.elastic.co/u/tushar.hadoop)\
**Post date:** [October 26, 2015, 4:55am UTC](https://discuss.elastic.co/t/the-error-reported-is-logstash-error/32945/3 "2015-10-26T04:55:14Z")

</div>

```
input {
file {
    path => "/var/log/ambari-server/ambari-alerts.log"
    type => "ambari-log"
  }
}
filter {
  grok {
    match => { "message" => "%{DATE_EU:date} %{TIME:time} %{GREEDYDATA:ambari_message}" }
  }
if [ambari_message] == " [UNKNOWN] " {
    drop { }
  }
if [ambari_message] == " [OK] " {
    drop { }
  }
}
output {
    rabbitmq {
      key => "ambari-key"
      exchange => "ambari-exchange-type"
      exchange_type => "direct"
      user => "admin"
      password => "Is3+3=0??"
      host => "integration.dev.ida"
      port => 5672
      durable => true
      persistent => true
      vhost => "logging"
    }
}

```

i have removed rabbitmq from LDAP but still the same issue ☹

---

<div class="post-metadata">

**Author:** ![tushar.hadoop](https://avatars.discourse-cdn.com/v4/letter/t/958977/32.png) [@tushar.hadoop](https://discuss.elastic.co/u/tushar.hadoop)\
**Post date:** [October 26, 2015, 5:19am UTC](https://discuss.elastic.co/t/the-error-reported-is-logstash-error/32945/4 "2015-10-26T05:19:29Z")

</div>

Issue is resolved . . thanks for the comments ..

we had a same user (admin) in our FreeIPA (LDAP) and for rabbitmq also . .

and one more IMP thing is i changed vhost =\> "logging" to vhost =\> "/" . . now its working 😄

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 5:25am UTC](https://discuss.elastic.co/t/the-error-reported-is-logstash-error/32945/5 "2017-07-06T05:25:26Z")

</div>


