# The node name cannot be resolved using fieldPath: spec.nodeName, is there any solution?

**URL:** <https://discuss.elastic.co/t/the-node-name-cannot-be-resolved-using-fieldpath-spec-nodename-is-there-any-solution/243489>\
**Category:** Beats\
**Tags:** metricbeat\
**Created:** [August 3, 2020, 2:21am UTC](https://discuss.elastic.co/t/the-node-name-cannot-be-resolved-using-fieldpath-spec-nodename-is-there-any-solution/243489 "2020-08-03T02:21:59Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![wajika](https://avatars.discourse-cdn.com/v4/letter/w/977dab/32.png) [@wajika](https://discuss.elastic.co/u/wajika)\
**Post date:** [August 3, 2020, 2:21am UTC](https://discuss.elastic.co/t/the-node-name-cannot-be-resolved-using-fieldpath-spec-nodename-is-there-any-solution/243489/1 "2020-08-03T02:21:59Z")

</div>

metricbeat should be able to obtain kube-status-metric information, but cannot connect to metric-server (DNS lookup failure "[k8s-dev-node02.lonsid.cn](http://k8s-dev-node02.lonsid.cn)": lookup [k8s-dev-node02.lonsid.cn](http://k8s-dev-node02.lonsid.cn): no such host ), I see most people use nodename, how did they solve the whole problem?

metric-server is running healthy

metricbeat.yml  
[https://paste.ubuntu.com/p/zjG6nPkS5m/](https://paste.ubuntu.com/p/zjG6nPkS5m/)

> ```
> 2020-08-03T02:15:48.852Z WARN [transport] transport/tcp.go:52 DNS lookup failure "k8s-dev-node02.lonsid.cn": lookup k8s-dev-node02.lonsid.cn: no such host
> 
> 2020/8/3 上午10:15:48 2020-08-03T02:15:48.852Z INFO module/wrapper.go:259 Error fetching data for metricset kubernetes.node: error doing HTTP request to fetch 'node' Metricset data: error making http request: Get https://k8s-dev-node02.lonsid.cn:10250/stats/summary: lookup k8s-dev-node02.lonsid.cn: no such host
> 
> 2020/8/3 上午10:15:58 2020-08-03T02:15:58.791Z WARN [transport] transport/tcp.go:52 DNS lookup failure "k8s-dev-node02.lonsid.cn": lookup k8s-dev-node02.lonsid.cn: no such host
> 
> 2020/8/3 上午10:15:58 2020-08-03T02:15:58.791Z INFO module/wrapper.go:259 Error fetching data for metricset kubernetes.volume: error doing HTTP request to fetch 'volume' Metricset data: error making http request: Get https://k8s-dev-node02.lonsid.cn:10250/stats/summary: lookup k8s-dev-node02.lonsid.cn: no such host
> 
> 2020/8/3 上午10:15:58 2020-08-03T02:15:58.792Z WARN [transport] transport/tcp.go:52 DNS lookup failure "k8s-dev-node02.lonsid.cn": lookup k8s-dev-node02.lonsid.cn: no such host
> 
> 2020/8/3 上午10:15:58 2020-08-03T02:15:58.792Z INFO module/wrapper.go:259 Error fetching data for metricset kubernetes.system: error doing HTTP request to fetch 'system' Metricset data: error making http request: Get https://k8s-dev-node02.lonsid.cn:10250/stats/summary: lookup k8s-dev-node02.lonsid.cn: no such host
> 
> 2020/8/3 上午10:15:58 2020-08-03T02:15:58.853Z WARN [transport] transport/tcp.go:52 DNS lookup failure "k8s-dev-node02.lonsid.cn": lookup k8s-dev-node02.lonsid.cn: no such host
> 
> 2020/8/3 上午10:15:58 2020-08-03T02:15:58.853Z INFO module/wrapper.go:259 Error fetching data for metricset kubernetes.node: error doing HTTP request to fetch 'node' Metricset data: error making http request: Get https://k8s-dev-node02.lonsid.cn:10250/stats/summary: lookup k8s-dev-node02.lonsid.cn: no such host
> 
> 2020/8/3 上午10:15:58 2020-08-03T02:15:58.853Z WARN [transport] transport/tcp.go:52 DNS lookup failure "k8s-dev-node02.lonsid.cn": lookup k8s-dev-node02.lonsid.cn: no such host
> 
> 2020/8/3 上午10:15:58 2020-08-03T02:15:58.853Z INFO module/wrapper.go:259 Error fetching data for metricset kubernetes.pod: error doing HTTP request to fetch 'pod' Metricset data: error making http request: Get https://k8s-dev-node02.lonsid.cn:10250/stats/summary: lookup k8s-dev-node02.lonsid.cn: no such host
> 
> 2020/8/3 上午10:15:58 2020-08-03T02:15:58.857Z WARN [transport] transport/tcp.go:52 DNS lookup failure "k8s-dev-node02.lonsid.cn": lookup k8s-dev-node02.lonsid.cn: no such host
> 
> ```

> ```
> 2020/8/3 上午10:15:58 2020-08-03T02:15:58.857Z INFO module/wrapper.go:259 Error fetching data for metricset kubernetes.container: error doing HTTP request to fetch 'container' Metricset data: error making http request: Get https://k8s-dev-node02.lonsid.cn:10250/stats/summary: lookup k8s-dev-node02.lonsid.cn: no such host
> 
> 2020/8/3 上午10:16:08 2020-08-03T02:16:08.721Z INFO [monitoring] log/log.go:145 Non-zero metrics in the last 30s {"monitoring": {"metrics": {"beat":{"cpu":{"system":{"ticks":44690,"time":{"ms":425}},"total":{"ticks":79660,"time":{"ms":743},"value":79660},"user":{"ticks":34970,"time":{"ms":318}}},"handles":{"limit":{"hard":1048576,"soft":1048576},"open":11},"info":{"ephemeral_id":"802d74a5-c209-4de0-8b63-767cee91fa00","uptime":{"ms":3060090}},"memstats":{"gc_next":28603184,"memory_alloc":21248360,"memory_total":10155611304,"rss":962560},"runtime":{"goroutines":118}},"libbeat":{"config":{"module":{"running":0}},"output":{"events":{"acked":189,"batches":9,"total":189}},"pipeline":{"clients":14,"events":{"active":0,"published":189,"total":189},"queue":{"acked":189}}},"metricbeat":{"kubernetes":{"container":{"events":3,"failures":3},"node":{"events":3,"failures":3},"pod":{"events":3,"failures":3},"proxy":{"events":9,"success":9},"system":{"events":3,"failures":3},"volume":{"events":3,"failures":3}},"system":{"cpu":{"events":3,"success":3},"load":{"events":3,"success":3},"memory":{"events":3,"success":3},"network":{"events":123,"success":123},"process":{"events":30,"success":30},"process_summary":{"events":3,"success":3}}},"system":{"load":{"1":0.15,"15":0.39,"5":0.29,"norm":{"1":0.0375,"15":0.0975,"5":0.0725}}}}}}
> 
> ```

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 31, 2020, 4:22am UTC](https://discuss.elastic.co/t/the-node-name-cannot-be-resolved-using-fieldpath-spec-nodename-is-there-any-solution/243489/2 "2020-08-31T04:22:04Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
