# The request for this panel failed

**URL:** https://discuss.elastic.co/t/the-request-for-this-panel-failed/155359
**Category:** Kibana
**Created:** [November 5, 2018, 8:35am UTC](https://discuss.elastic.co/t/the-request-for-this-panel-failed/155359 "2018-11-05T08:35:01Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![aabababba](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/aabababba/32/36732_2.png) [@aabababba](https://discuss.elastic.co/u/aabababba)
#### Post date: [November 5, 2018, 8:35am UTC](https://discuss.elastic.co/t/the-request-for-this-panel-failed/155359/1 "2018-11-05T08:35:01Z")

</div>

The request for this panel failed.

The aggregations key is missing from the response, check your permissions for this request.

 ![metricbeaterror](https://us1.discourse-cdn.com/elastic/original/3X/0/a/0a8d192b9fa68db95caab436a11828c919954623.jpeg)

---

<div class="post-metadata">

### Author: ![Nathan\_Reese](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nathan_reese/32/84829_2.png) [@Nathan\_Reese](https://discuss.elastic.co/u/Nathan_Reese)
#### Post date: [November 5, 2018, 2:28pm UTC](https://discuss.elastic.co/t/the-request-for-this-panel-failed/155359/2 "2018-11-05T14:28:38Z")

</div>

Can you provide some more information? Are you using Security? Did you log into Kibana? Does the user have permissions to view all fields of the index? Are there any errors in the Kibana server logs? Are there any errors in the Elasticsearch logs?

---

<div class="post-metadata">

### Author: ![aabababba](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/aabababba/32/36732_2.png) [@aabababba](https://discuss.elastic.co/u/aabababba)
#### Post date: [November 6, 2018, 2:50am UTC](https://discuss.elastic.co/t/the-request-for-this-panel-failed/155359/3 "2018-11-06T02:50:37Z")

</div>

I don't have security. how to log into kibana? in Discover metribeat index is fine.

Elasticsearch logs

```auto
Fielddata is disabled on text fields by default. Set fielddata=true on [system.network.name] in order to load fielddata in memory by uninverting the inverted index. Note that this can however use significant memory. Alternatively use a keyword field instead

```

/var/log don't have kibana log.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [December 4, 2018, 2:50am UTC](https://discuss.elastic.co/t/the-request-for-this-panel-failed/155359/4 "2018-12-04T02:50:37Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
