# The unit elasticsearch.service has entered the 'failed' state with result 'exit-code'

**URL:** <https://discuss.elastic.co/t/the-unit-elasticsearch-service-has-entered-the-failed-state-with-result-exit-code/282129>\
**Category:** Elasticsearch\
**Created:** [August 21, 2021, 4:15am UTC](https://discuss.elastic.co/t/the-unit-elasticsearch-service-has-entered-the-failed-state-with-result-exit-code/282129 "2021-08-21T04:15:26Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Atif\_Hussain](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/atif_hussain/32/93529_2.png) [@Atif\_Hussain](https://discuss.elastic.co/u/Atif_Hussain)\
**Post date:** [August 21, 2021, 4:15am UTC](https://discuss.elastic.co/t/the-unit-elasticsearch-service-has-entered-the-failed-state-with-result-exit-code/282129/1 "2021-08-21T04:15:26Z")

</div>

After new installation of 7.14, I am getting this error when I try to start the service.  
Tried different solutions on from this forum without any luck.  
I am new to Elasticsearch so need help.  
Following are the logs from

> `journalctl -xe`

```auto
Aug 21 04:07:48 ip-172-31-28-3 sudo[2909988]: root : TTY=pts/0 ; PWD=/var/www/html ; USER=root ; COMMAND=/usr/bin/systemctl start elasticse>
Aug 21 04:07:48 ip-172-31-28-3 sudo[2909988]: pam_unix(sudo:session): session opened for user root by ubuntu(uid=0)
Aug 21 04:07:48 ip-172-31-28-3 systemd[1]: Starting Elasticsearch...
-- Subject: A start job for unit elasticsearch.service has begun execution
-- Defined-By: systemd
-- Support: http://www.ubuntu.com/support
-- 
-- A start job for unit elasticsearch.service has begun execution.
-- 
-- The job identifier is 598096.
Aug 21 04:07:48 ip-172-31-28-3 systemd-entrypoint[2909991]: /usr/share/elasticsearch/bin/elasticsearch-env: line 87: /etc/default/elasticsearch>
Aug 21 04:07:48 ip-172-31-28-3 systemd[1]: elasticsearch.service: Main process exited, code=exited, status=1/FAILURE
-- Subject: Unit process exited
-- Defined-By: systemd
-- Support: http://www.ubuntu.com/support
-- 
-- An ExecStart= process belonging to unit elasticsearch.service has exited.
-- 
-- The process' exit code is 'exited' and its exit status is 1.
Aug 21 04:07:48 ip-172-31-28-3 systemd[1]: elasticsearch.service: Failed with result 'exit-code'.
-- Subject: Unit failed
-- Defined-By: systemd
-- Support: http://www.ubuntu.com/support
-- 
-- The unit elasticsearch.service has entered the 'failed' state with result 'exit-code'.
Aug 21 04:07:48 ip-172-31-28-3 systemd[1]: Failed to start Elasticsearch.
-- Subject: A start job for unit elasticsearch.service has failed
-- Defined-By: systemd
-- Support: http://www.ubuntu.com/support
-- 
-- A start job for unit elasticsearch.service has finished with a failure.
-- 
-- The job identifier is 598096 and the job result is failed.
Aug 21 04:07:48 ip-172-31-28-3 sudo[2909988]: pam_unix(sudo:session): session closed for user root
Aug 21 04:08:01 ip-172-31-28-3 CRON[2910044]: pam_unix(cron:session): session opened for user root by (uid=0)
Aug 21 04:08:01 ip-172-31-28-3 CRON[2910045]: pam_unix(cron:session): session opened for user root by (uid=0)
Aug 21 04:08:01 ip-172-31-28-3 CRON[2910046]: (root) CMD (cd /var/www/html/panavid; php -f cron.php > /dev/null 1>&1)
Aug 21 04:08:01 ip-172-31-28-3 CRON[2910048]: (root) CMD (cd /var/www/html/preprod; php -f cron.php > /dev/null 2>&1)
Aug 21 04:08:02 ip-172-31-28-3 CRON[2910044]: pam_unix(cron:session): session closed for user root
Aug 21 04:08:02 ip-172-31-28-3 CRON[2910045]: (CRON) info (No MTA installed, discarding output)
Aug 21 04:08:02 ip-172-31-28-3 CRON[2910045]: pam_unix(cron:session): session closed for user root

```

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [August 21, 2021, 6:45am UTC](https://discuss.elastic.co/t/the-unit-elasticsearch-service-has-entered-the-failed-state-with-result-exit-code/282129/2 "2021-08-21T06:45:44Z")

</div>

Please share the Elasticsearch logs.

---

<div class="post-metadata">

**Author:** ![Atif\_Hussain](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/atif_hussain/32/93529_2.png) [@Atif\_Hussain](https://discuss.elastic.co/u/Atif_Hussain)\
**Post date:** [August 21, 2021, 7:06am UTC](https://discuss.elastic.co/t/the-unit-elasticsearch-service-has-entered-the-failed-state-with-result-exit-code/282129/3 "2021-08-21T07:06:59Z")

</div>

Hi @Christian_Dahlqvist,  
Thanks for your response.

I ended up uninstalling the Elasticsearch completely and re installing it. Now its working fine. Thanks for looking into it.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 18, 2021, 7:07am UTC](https://discuss.elastic.co/t/the-unit-elasticsearch-service-has-entered-the-failed-state-with-result-exit-code/282129/4 "2021-09-18T07:07:34Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
