# This driver is not configured for integrated authentication

**URL:** <https://discuss.elastic.co/t/this-driver-is-not-configured-for-integrated-authentication/135940>\
**Category:** Logstash\
**Created:** [June 14, 2018, 1:51pm UTC](https://discuss.elastic.co/t/this-driver-is-not-configured-for-integrated-authentication/135940 "2018-06-14T13:51:57Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Sourav\_Saha](https://avatars.discourse-cdn.com/v4/letter/s/c68b51/32.png) [@Sourav\_Saha](https://discuss.elastic.co/u/Sourav_Saha)\
**Post date:** [June 14, 2018, 1:51pm UTC](https://discuss.elastic.co/t/this-driver-is-not-configured-for-integrated-authentication/135940/1 "2018-06-14T13:51:57Z")

</div>

I am trying to connect SQL SERVER in window authentication mode from logstash and my connection string is given below:  
input {  
jdbc {  
jdbc\_driver\_class =\> "com.microsoft.sqlserver.jdbc.SQLServerDriver"  
jdbc\_driver\_library =\> "_**\pipeline\ISMS\sqljdbc\_6.2\enu\jdbc-6.2.2.jar"  
jdbc\_connection\_string =\> "jdbc:sqlserver://PMICHLAUSQL44\MSS2012;databaseName=Poland\_PRD\_MD;integratedSecurity=true"  
jdbc\_user =\> " **_**"  
# jdbc\_password =\> "**\*\*\*"  
statement\_filepath =\> "\*\*\*\*\*\DateWiseHHDownloadDetails.txt"  
tags =\> ["DOWNLOAD"]  
}  
}

But after execution of logstash.conf file I have got a error message which is :  
[2018-06-14T13:04:28,441][ERROR][logstash.inputs.jdbc] Unable to connect to database. Tried 1 times {:error\_message=\>"Java::ComMicrosoftSqlserverJdbc::SQLServerException: This driver is not configured for integrated authentication. ClientConnectionId:679f6e20-67f8-4d7c-bf46-ef30ec0edaaf"}

Need a solution regarding this issue.

---

<div class="post-metadata">

**Author:** ![yaauie](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/yaauie/32/23363_2.png) [@yaauie](https://discuss.elastic.co/u/yaauie)\
**Post date:** [June 14, 2018, 5:52pm UTC](https://discuss.elastic.co/t/this-driver-is-not-configured-for-integrated-authentication/135940/2 "2018-06-14T17:52:31Z")

</div>

> [@Sourav\_Saha](#):
>
> This driver is not configured for integrated authentication

Is the machine on which Logstash is running also Windows, or is it Linux? I'm seeing a support article on MSDN about needing to specify `authenticationScheme=JavaKerberos` when connecting from a non-Windows host: [JDBC: This driver is not configured for integrated authentication | Microsoft Learn](https://blogs.msdn.microsoft.com/psssql/2015/01/09/jdbc-this-driver-is-not-configured-for-integrated-authentication/)

---

<div class="post-metadata">

**Author:** ![yaauie](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/yaauie/32/23363_2.png) [@yaauie](https://discuss.elastic.co/u/yaauie)\
**Post date:** [June 14, 2018, 5:59pm UTC](https://discuss.elastic.co/t/this-driver-is-not-configured-for-integrated-authentication/135940/3 "2018-06-14T17:59:16Z")

</div>

If running on Windows, this [article](https://blogs.msdn.microsoft.com/jdbcteam/2007/06/18/com-microsoft-sqlserver-jdbc-sqlserverexception-this-driver-is-not-configured-for-integrated-authentication/) seems to indicate that the problem can also occur if the `sqljdbc_auth.dll` is not on the JVM library path, which I believe to be more likely.

JVM Options can be set using the `${LS_HOME}/config/jvm.options` file, as documented [here](https://www.elastic.co/guide/en/elasticsearch/reference/current/jvm-options.html)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 12, 2018, 5:59pm UTC](https://discuss.elastic.co/t/this-driver-is-not-configured-for-integrated-authentication/135940/4 "2018-07-12T17:59:34Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
