# This site can’t be reached xxx.xxx.xx refused to connect

**URL:** <https://discuss.elastic.co/t/this-site-can-t-be-reached-xxx-xxx-xx-refused-to-connect/134293>\
**Category:** Kibana\
**Created:** [June 2, 2018, 5:17pm UTC](https://discuss.elastic.co/t/this-site-can-t-be-reached-xxx-xxx-xx-refused-to-connect/134293 "2018-06-02T17:17:20Z")\
**Posts on this page:** 13\
**Page:** 1

<div class="post-metadata">

**Author:** ![krishnan\_radhakrishn](https://avatars.discourse-cdn.com/v4/letter/k/34f0e0/32.png) [@krishnan\_radhakrishn](https://discuss.elastic.co/u/krishnan_radhakrishn)\
**Post date:** [June 2, 2018, 5:17pm UTC](https://discuss.elastic.co/t/this-site-can-t-be-reached-xxx-xxx-xx-refused-to-connect/134293/1 "2018-06-02T17:17:21Z")

</div>

[http://public-ip:5601](http://public-ip:5601), i get below error

This site can’t be reached  
xxx.xxx.xx refused to connect.

please help me to resolve

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [June 2, 2018, 5:39pm UTC](https://discuss.elastic.co/t/this-site-can-t-be-reached-xxx-xxx-xx-refused-to-connect/134293/2 "2018-06-02T17:39:51Z")

</div>

Sounds like a firewall or networking problem, but you will need to provide more details around setup and configuration for anyone to be able to help beyond that.

---

<div class="post-metadata">

**Author:** ![krishnan\_radhakrishn](https://avatars.discourse-cdn.com/v4/letter/k/34f0e0/32.png) [@krishnan\_radhakrishn](https://discuss.elastic.co/u/krishnan_radhakrishn)\
**Post date:** [June 2, 2018, 6:00pm UTC](https://discuss.elastic.co/t/this-site-can-t-be-reached-xxx-xxx-xx-refused-to-connect/134293/3 "2018-06-02T18:00:54Z")

</div>

etstat -natp | grep 5601(Not all processes could be identified, non-owned process info  
will not be shown, you would have to be root to see it all.)  
tcp 0 0 127.0.0.1:5601 0.0.0.0:\* LISTEN

## installting in ubuntu 16.04 virtual machine in azure and trying to access from my local machine

## kibana.service - Kibana Loaded: loaded (/etc/systemd/system/kibana.service; enabled; vendor preset: e Active: active (running) since Sat 2018-06-02 11:48:09 UTC; 5h 0min ago

just show kibana is running but when called from internet with public ip:5601 , i get above error

when i tried to access from internet [http://public-ip:5601](http://public-ip:5601), i get that error , can some one help please

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [June 2, 2018, 7:36pm UTC](https://discuss.elastic.co/t/this-site-can-t-be-reached-xxx-xxx-xx-refused-to-connect/134293/4 "2018-06-02T19:36:58Z")

</div>

> [@krishnan\_radhakrishn](#):
>
> tcp 0 0 127.0.0.1:5601 0.0.0.0:\* LISTEN

Kibana is listening to 127.0.1 which is only accessible from within the VM. Change it to bind to `0.0.0.0` (or the public IP) in the `kibana.yml` file and you should be able to access it from another machine.

---

<div class="post-metadata">

**Author:** ![krishnan\_radhakrishn](https://avatars.discourse-cdn.com/v4/letter/k/34f0e0/32.png) [@krishnan\_radhakrishn](https://discuss.elastic.co/u/krishnan_radhakrishn)\
**Post date:** [June 3, 2018, 1:08am UTC](https://discuss.elastic.co/t/this-site-can-t-be-reached-xxx-xxx-xx-refused-to-connect/134293/5 "2018-06-03T01:08:06Z")

</div>

still same . not able to load , below is my yml file

# Kibana is served by a back end server. This controls which port to use.

server.port:5601

# The host to bind the server to.

server.host:"0.0.0.0"

# running kibana behind a proxy, and want to mount it at a path,

# specify that path here. The basePath can't end in a slash.

# server.basePath:"/kibana"

# The maximum payload size in bytes on incoming server requests.

server.maxPayloadBytes: 1048576

# The Elasticsearch instance to use for all your queries.

elasticsearch.url:"[http://104.211.229.94:9200](http://104.211.229.94:9200)"

# preserve\_elasticsearch\_host true will send the hostname specified in `elasticsearch`. If you set it to false,

# then the host you use to connect to _this_ Kibana instance will be sent.

elasticsearch.preserveHost:true

# Kibana uses an index in Elasticsearch to store saved searches, visualizations

Type :quit to exit Vim

---

<div class="post-metadata">

**Author:** ![krishnan\_radhakrishn](https://avatars.discourse-cdn.com/v4/letter/k/34f0e0/32.png) [@krishnan\_radhakrishn](https://discuss.elastic.co/u/krishnan_radhakrishn)\
**Post date:** [June 3, 2018, 8:15am UTC](https://discuss.elastic.co/t/this-site-can-t-be-reached-xxx-xxx-xx-refused-to-connect/134293/6 "2018-06-03T08:15:39Z")

</div>

BINDING TO 0.0.0.0 NOT working when changed in yml file can some one help please

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [June 3, 2018, 8:25am UTC](https://discuss.elastic.co/t/this-site-can-t-be-reached-xxx-xxx-xx-refused-to-connect/134293/7 "2018-06-03T08:25:15Z")

</div>

In that case it sounds like you have firewall or networking issue. Check the firewall as well as any local VM settings.

---

<div class="post-metadata">

**Author:** ![krishnan\_radhakrishn](https://avatars.discourse-cdn.com/v4/letter/k/34f0e0/32.png) [@krishnan\_radhakrishn](https://discuss.elastic.co/u/krishnan_radhakrishn)\
**Post date:** [June 3, 2018, 9:20am UTC](https://discuss.elastic.co/t/this-site-can-t-be-reached-xxx-xxx-xx-refused-to-connect/134293/8 "2018-06-03T09:20:28Z")

</div>

no LUCK, VM machine is in azure , firewall is disabled with below command  
sudo ufw disable  
Firewall stopped and disabled on system startup

still i see this, Can some one help

tcp 0 0 127.0.0.1:5601 0.0.0.0:\* LISTEN

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [June 3, 2018, 9:58am UTC](https://discuss.elastic.co/t/this-site-can-t-be-reached-xxx-xxx-xx-refused-to-connect/134293/9 "2018-06-03T09:58:51Z")

</div>

That still looks the same. Have you restarted Kibana?

---

<div class="post-metadata">

**Author:** ![krishnan\_radhakrishn](https://avatars.discourse-cdn.com/v4/letter/k/34f0e0/32.png) [@krishnan\_radhakrishn](https://discuss.elastic.co/u/krishnan_radhakrishn)\
**Post date:** [June 3, 2018, 10:10am UTC](https://discuss.elastic.co/t/this-site-can-t-be-reached-xxx-xxx-xx-refused-to-connect/134293/10 "2018-06-03T10:10:37Z")

</div>

sudo service kibana restart

did this but still same, something is not right

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [June 3, 2018, 10:32am UTC](https://discuss.elastic.co/t/this-site-can-t-be-reached-xxx-xxx-xx-refused-to-connect/134293/11 "2018-06-03T10:32:24Z")

</div>

It seems like it is not loading the config file you edited. Try shutting down the service and then make sure you have updated the right config file. Check the logs when starting up to see what it picks up.

---

<div class="post-metadata">

**Author:** ![krishnan\_radhakrishn](https://avatars.discourse-cdn.com/v4/letter/k/34f0e0/32.png) [@krishnan\_radhakrishn](https://discuss.elastic.co/u/krishnan_radhakrishn)\
**Post date:** [June 3, 2018, 12:45pm UTC](https://discuss.elastic.co/t/this-site-can-t-be-reached-xxx-xxx-xx-refused-to-connect/134293/12 "2018-06-03T12:45:49Z")

</div>

the log is empty , when restarted this is what my yml file, can some one help

 ![Screenshot%20from%202018-06-03%2018-14-46](https://us1.discourse-cdn.com/elastic/original/3X/d/c/dcaf1f375a5c6eea6992c0a8cc486d5b4411ce5b.png)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 1, 2018, 12:45pm UTC](https://discuss.elastic.co/t/this-site-can-t-be-reached-xxx-xxx-xx-refused-to-connect/134293/13 "2018-07-01T12:45:55Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
