# \_tier\_preference when prefered nodes are full

**URL:** <https://discuss.elastic.co/t/tier-preference-when-prefered-nodes-are-full/322325>\
**Category:** Elasticsearch\
**Created:** [January 2, 2023, 3:10pm UTC](https://discuss.elastic.co/t/tier-preference-when-prefered-nodes-are-full/322325 "2023-01-02T15:10:35Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![lduvnjak](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/lduvnjak/32/77724_2.png) [@lduvnjak](https://discuss.elastic.co/u/lduvnjak)\
**Post date:** [January 2, 2023, 3:10pm UTC](https://discuss.elastic.co/t/tier-preference-when-prefered-nodes-are-full/322325/1 "2023-01-02T15:10:35Z")

</div>

Hey Everyone,

I'll try to be as brief and precise with my question as possible.

When an index has a tier preference set to let's say `data_warm,data_hot`, and both the warm and hot nodes are full... will it reject new messages, or will it failover to whatever node has available space (aka the cold nodes)?

Cheers,  
Luka

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [January 2, 2023, 3:41pm UTC](https://discuss.elastic.co/t/tier-preference-when-prefered-nodes-are-full/322325/2 "2023-01-02T15:41:38Z")

</div>

If the hot nodes fill up new messages will be rejected.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 30, 2023, 3:41pm UTC](https://discuss.elastic.co/t/tier-preference-when-prefered-nodes-are-full/322325/3 "2023-01-30T15:41:42Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
