# Timelion 5.0 split is not working for me

**URL:** https://discuss.elastic.co/t/timelion-5-0-split-is-not-working-for-me/64897
**Category:** Kibana
**Tags:** timelion
**Created:** [November 3, 2016, 3:48pm UTC](https://discuss.elastic.co/t/timelion-5-0-split-is-not-working-for-me/64897 "2016-11-03T15:48:54Z")
**Posts on this page:** 9
**Page:** 1

<div class="post-metadata">

### Author: ![srpatatas](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/srpatatas/32/9113_2.png) [@srpatatas](https://discuss.elastic.co/u/srpatatas)
#### Post date: [November 3, 2016, 3:48pm UTC](https://discuss.elastic.co/t/timelion-5-0-split-is-not-working-for-me/64897/1 "2016-11-03T15:48:54Z")

</div>

Hi guys, I'm having trouble with the Timelion plugin on Elastic 5.0. I was using Kibana 4.5.4 and had no issues with this query in timelion: .es(q=\*,split="env.prd:2") to split all my documents by the key env.prd (it only has 2 possible values)

This is my query in Kibana 4.5.4:

 ![](https://us1.discourse-cdn.com/elastic/original/2X/6/61d260bcddd7657c695602fb6f807fa0f5c7c29f.png)

And on Kibana 5

 ![](https://us1.discourse-cdn.com/elastic/original/2X/8/8ae93a3f25dcf766e591a6874f74c64c5905e1c6.png)

![](https://us1.discourse-cdn.com/elastic/original/2X/7/75fc7cad584828e11df92c1804795eac78373a9d.png)

Any ideas what could be wrong? Has the syntax changed for Kibana 5?

---

<div class="post-metadata">

### Author: ![jbudz](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jbudz/32/45922_2.png) [@jbudz](https://discuss.elastic.co/u/jbudz)
#### Post date: [November 3, 2016, 9:46pm UTC](https://discuss.elastic.co/t/timelion-5-0-split-is-not-working-for-me/64897/2 "2016-11-03T21:46:01Z")

</div>

The syntax should be the same, a quick test shows it working for me. Did your field name change? I see "env.prd" and env\_prd". The blank chart is consistent for me with a field name that doesn't exist.

---

<div class="post-metadata">

### Author: ![srpatatas](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/srpatatas/32/9113_2.png) [@srpatatas](https://discuss.elastic.co/u/srpatatas)
#### Post date: [November 4, 2016, 2:27pm UTC](https://discuss.elastic.co/t/timelion-5-0-split-is-not-working-for-me/64897/3 "2016-11-04T14:27:23Z")

</div>

Hi Jon, yes, sorry I forgot to mention that I re-indexed my data and now the field env\_prd is called env.prd. Here you can see that there is data for this field yet the split argument doesn't like it:

![](https://us1.discourse-cdn.com/elastic/original/2X/b/b55b0b79aba9ccf052c98b943c35766248951c9c.png)

Just in case I tried with another field that doesn't contain dots but I get the same result:

![](https://us1.discourse-cdn.com/elastic/original/2X/a/ade21b18f77ad03790810ba19b28daecd699f67d.png)

![](https://us1.discourse-cdn.com/elastic/original/2X/0/0ff425fc674fe0b68538e51ac5c01fbd5bae297f.png)

---

<div class="post-metadata">

### Author: ![jbudz](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jbudz/32/45922_2.png) [@jbudz](https://discuss.elastic.co/u/jbudz)
#### Post date: [November 4, 2016, 6:05pm UTC](https://discuss.elastic.co/t/timelion-5-0-split-is-not-working-for-me/64897/4 "2016-11-04T18:05:25Z")

</div>

Is your field analyzed/mapped as as text field? I was able to make a silent failure under those circumstances. Specifying an `index=` in my function made the error show up, if you're able to reproduce that.

---

<div class="post-metadata">

### Author: ![srpatatas](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/srpatatas/32/9113_2.png) [@srpatatas](https://discuss.elastic.co/u/srpatatas)
#### Post date: [November 4, 2016, 6:24pm UTC](https://discuss.elastic.co/t/timelion-5-0-split-is-not-working-for-me/64897/5 "2016-11-04T18:24:01Z")

</div>

Not sure how to use the index parameter, I tried this:

`.es(q=*, index="logstash-*", split="env.prd:2")`

but it gives me an error "Timelion: Error: in cell #1: [illegal\_argument\_exception] Fielddata is disabled on text fields by default. Set fielddata=true on [env.prd] in order to load fielddata in memory by uninverting the inverted index. Note that this can however use significant memory."

This is the field mapping, it's text and analyzed:

```
      "env" : {
        "properties" : {
          "prd" : {
            "type" : "text",
            "norms" : false,
            "fields" : {
              "keyword" : {
                "type" : "keyword"
              }
            }
          },
```

---

<div class="post-metadata">

### Author: ![jbudz](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jbudz/32/45922_2.png) [@jbudz](https://discuss.elastic.co/u/jbudz)
#### Post date: [November 4, 2016, 6:27pm UTC](https://discuss.elastic.co/t/timelion-5-0-split-is-not-working-for-me/64897/6 "2016-11-04T18:27:09Z")

</div>

Okay, you'll want to split on the keyword field:  
`.es(q=, index="logstash-", split="env.prd.keyword:2")`

env.prd is ran through elasticsearch's analyzer, which from the error text is disabled by default. If this works for you, I'll open up an issue for not showing an error without an index.

---

<div class="post-metadata">

### Author: ![srpatatas](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/srpatatas/32/9113_2.png) [@srpatatas](https://discuss.elastic.co/u/srpatatas)
#### Post date: [November 4, 2016, 6:33pm UTC](https://discuss.elastic.co/t/timelion-5-0-split-is-not-working-for-me/64897/7 "2016-11-04T18:33:40Z")

</div>

Yes!!!!!! That's it!

![](https://us1.discourse-cdn.com/elastic/original/2X/c/cf329899731fb5be3b3fb99b23971f11b8180259.png)

So it seems that version 5 introduced this requirement since on Kibana 4.5.4 I didn't have to use the not\_analyzed value, the analyzed field worked fine without expliciting the index...

Thank you very much for your help!

---

<div class="post-metadata">

### Author: ![jbudz](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jbudz/32/45922_2.png) [@jbudz](https://discuss.elastic.co/u/jbudz)
#### Post date: [November 4, 2016, 6:39pm UTC](https://discuss.elastic.co/t/timelion-5-0-split-is-not-working-for-me/64897/8 "2016-11-04T18:39:19Z")

</div>

Glad to hear it, we have an issue for the error messsage being tracked [here](https://github.com/elastic/kibana/issues/8911)

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 6, 2017, 1:34pm UTC](https://discuss.elastic.co/t/timelion-5-0-split-is-not-working-for-me/64897/9 "2017-07-06T13:34:28Z")

</div>


