# Timeout and failure in creating ECK in kubernetes version 1.14.4

**URL:** <https://discuss.elastic.co/t/timeout-and-failure-in-creating-eck-in-kubernetes-version-1-14-4/231122>\
**Category:** Elastic Cloud on Kubernetes (ECK)\
**Created:** [May 5, 2020, 10:14am UTC](https://discuss.elastic.co/t/timeout-and-failure-in-creating-eck-in-kubernetes-version-1-14-4/231122 "2020-05-05T10:14:46Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![wajika](https://avatars.discourse-cdn.com/v4/letter/w/977dab/32.png) [@wajika](https://discuss.elastic.co/u/wajika)\
**Post date:** [May 5, 2020, 10:14am UTC](https://discuss.elastic.co/t/timeout-and-failure-in-creating-eck-in-kubernetes-version-1-14-4/231122/1 "2020-05-05T10:14:46Z")

</div>

The same yaml can be created successfully under version 1.16.3

kubectl create -f test.yaml  
Error from server (Timeout): error when creating "test.yaml": Timeout: request did not complete within requested timeout 30s

kubectl -n elastic-system logs -f statefulset.apps/elastic-operator  
Check the operator log and find no errors

```
> kind: StorageClass
> apiVersion: storage.k8s.io/v1
> metadata:
> name: elastic-local-volume
> provisioner: kubernetes.io/no-provisioner
> volumeBindingMode: WaitForFirstConsumer
> 
> ---
> apiVersion: v1
> kind: PersistentVolume
> metadata:
> name: es-data-pv-0
> spec:
> capacity:
> storage: 5Gi
> accessModes:
> - ReadWriteOnce
> persistentVolumeReclaimPolicy: Recycle
> storageClassName: elastic-local-volume
> local:
> path: /data/elastic-pv0/
> nodeAffinity:
> required:
> nodeSelectorTerms:
> - matchExpressions:
> - key: kubernetes.io/hostname
> operator: In
> values:
> - '192.168.10.184'
> ---
> apiVersion: v1
> kind: PersistentVolume
> metadata:
> name: es-data-pv-1
> spec:
> capacity:
> storage: 50Gi
> accessModes:
> - ReadWriteOnce
> persistentVolumeReclaimPolicy: Recycle
> storageClassName: elastic-local-volume
> local:
> path: /data/elastic-pv1/
> nodeAffinity:
> required:
> nodeSelectorTerms:
> - matchExpressions:
> - key: kubernetes.io/hostname
> operator: In
> values:
> - '192.168.10.184'

> apiVersion: elasticsearch.k8s.elastic.co/v1
> kind: Elasticsearch
> metadata:
> name: elastic
> spec:
> version: 7.6.2
> image: ccr.ccs.tencentyun.com/elk-oss/elasticsearch:7.6.2
> nodeSets:
> - name: elastic-master
> count: 1
> config:
> node.master: true
> node.data: false
> node.ingest: false
> node.ml: false
> node.store.allow_mmap: false
> index.store.type: niofs
> cluster.remote.connect: false
> podTemplate:
> spec:
> containers:
> - name: elasticsearch
> resources:
> limits:
> memory: 2Gi
> cpu: 2
> env:
> - name: ES_JAVA_OPTS
> value: "-Xms2g -Xmx2g"
> volumeClaimTemplates:
> - metadata:
> name: elasticsearch-data
> spec:
> accessModes:
> - ReadWriteOnce
> resources:
> requests:
> storage: 5Gi
> storageClassName: elastic-local-volume
> 
> - name: elastic-node
> count: 1
> config:
> node.master: false
> node.data: true
> node.ingest: true
> node.ml: false
> node.store.allow_mmap: false
> index.store.type: niofs
> cluster.remote.connect: false
> PodTemplate:
> spec:
> containers:
> - name: elasticsearch
> resources:
> limits:
> memory: 4Gi
> cpu: 2
> env:
> - name: ES_JAVA_OPTS
> value: "-Xms4g -Xmx4g"
> volumeClaimTemplates:
> - metadata:
> name: elasticsearch-data
> spec:
> accessModes:
> - ReadWriteOnce
> resources:
> requests:
> storage: 5Gi
> storageClassName: elastic-local-volume
```

---

<div class="post-metadata">

**Author:** ![abrx](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/abrx/32/43881_2.png) [@abrx](https://discuss.elastic.co/u/abrx)\
**Post date:** [May 6, 2020, 6:44am UTC](https://discuss.elastic.co/t/timeout-and-failure-in-creating-eck-in-kubernetes-version-1-14-4/231122/2 "2020-05-06T06:44:19Z")

</div>

Hi,  
Maybe you should first create PV/PVC, check them and then create the elasticsearch cluster?

---

<div class="post-metadata">

**Author:** ![wajika](https://avatars.discourse-cdn.com/v4/letter/w/977dab/32.png) [@wajika](https://discuss.elastic.co/u/wajika)\
**Post date:** [May 6, 2020, 6:56am UTC](https://discuss.elastic.co/t/timeout-and-failure-in-creating-eck-in-kubernetes-version-1-14-4/231122/3 "2020-05-06T06:56:34Z")

</div>

@abrx Thank you for your reply. The problem has been solved

reference: [https://github.com/elastic/cloud-on-k8s/issues/1673](https://github.com/elastic/cloud-on-k8s/issues/1673)

---

<div class="post-metadata">

**Author:** ![pebrc](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/pebrc/32/101790_2.png) [@pebrc](https://discuss.elastic.co/u/pebrc)\
**Post date:** [May 6, 2020, 7:12am UTC](https://discuss.elastic.co/t/timeout-and-failure-in-creating-eck-in-kubernetes-version-1-14-4/231122/4 "2020-05-06T07:12:55Z")

</div>

We have since updated our documentation which now contains a section to troubleshoot the validating webhook [https://www.elastic.co/guide/en/cloud-on-k8s/1.1/k8s-webhook-troubleshooting.html](https://www.elastic.co/guide/en/cloud-on-k8s/1.1/k8s-webhook-troubleshooting.html)

---

<div class="post-metadata">

**Author:** ![wajika](https://avatars.discourse-cdn.com/v4/letter/w/977dab/32.png) [@wajika](https://discuss.elastic.co/u/wajika)\
**Post date:** [May 6, 2020, 7:23am UTC](https://discuss.elastic.co/t/timeout-and-failure-in-creating-eck-in-kubernetes-version-1-14-4/231122/5 "2020-05-06T07:23:13Z")

</div>

Thanks for the tips

---

<div class="post-metadata">

**Author:** ![wajika](https://avatars.discourse-cdn.com/v4/letter/w/977dab/32.png) [@wajika](https://discuss.elastic.co/u/wajika)\
**Post date:** [May 8, 2020, 8:44am UTC](https://discuss.elastic.co/t/timeout-and-failure-in-creating-eck-in-kubernetes-version-1-14-4/231122/6 "2020-05-08T08:44:48Z")

</div>

I am a little curious, why only elasticsearch will be affected by the admission webhook, and after deleting the admission webhook, the operator log will always prompt error, is there no problem?

> ```
> kubectl create -f .
> Error from server (Timeout): error when creating "1master-2node.yaml": Timeout: request did not complete within requested timeout 30s
> Error from server (AlreadyExists): error when creating "operator-apm.yaml": apmservers.apm.k8s.elastic.co "apm-server" already exists
> Error from server (AlreadyExists): error when creating "operator-kibana.yaml": kibanas.kibana.k8s.elastic.co "kibana" already exists
> Error from server (AlreadyExists): error when creating "pv-3c-30g.yaml": storageclasses.storage.k8s.io "elastic-local-volume" already exists
> Error from server (AlreadyExists): error when creating "pv-3c-30g.yaml": persistentvolumes "es-data-pv-0" already exists
> Error from server (AlreadyExists): error when creating "pv-3c-30g.yaml": persistentvolumes "es-data-pv-1" already exists
> Error from server (AlreadyExists): error when creating "pv-3c-30g.yaml": persistentvolumes "es-data-pv-2" already exists
> 
> ```

---

<div class="post-metadata">

**Author:** ![sebgl](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sebgl/32/48702_2.png) [@sebgl](https://discuss.elastic.co/u/sebgl)\
**Post date:** [May 11, 2020, 8:40am UTC](https://discuss.elastic.co/t/timeout-and-failure-in-creating-eck-in-kubernetes-version-1-14-4/231122/7 "2020-05-11T08:40:26Z")

</div>

> why only elasticsearch will be affected by the admission webhook

IIRC, before ECK 1.2 only Elasticsearch has an admission webhook, not other resources.

> kubectl create -f .

You can use `kubectl apply` instead if you don't want the `already exists ` errors.

> Timeout: request did not complete within requested timeout 30s

It looks like something is still wrong. Have you deleted the webhook entirely?

---

<div class="post-metadata">

**Author:** ![wajika](https://avatars.discourse-cdn.com/v4/letter/w/977dab/32.png) [@wajika](https://discuss.elastic.co/u/wajika)\
**Post date:** [May 12, 2020, 5:05am UTC](https://discuss.elastic.co/t/timeout-and-failure-in-creating-eck-in-kubernetes-version-1-14-4/231122/8 "2020-05-12T05:05:02Z")

</div>

@sebgl Thank you for your reply.  
Before I used kubectl apply, it kept showing "Timeout: request did not complete within requested timeout 30s", but now it works normally.

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/9/8/98e6e36d0a12a5beb2784263d50483a10336eca4.png)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 4, 2022, 7:56am UTC](https://discuss.elastic.co/t/timeout-and-failure-in-creating-eck-in-kubernetes-version-1-14-4/231122/9 "2022-11-04T07:56:51Z")

</div>


