# Timeout/Connection error

**URL:** <https://discuss.elastic.co/t/timeout-connection-error/63455>\
**Category:** Elasticsearch\
**Created:** [October 20, 2016, 12:11am UTC](https://discuss.elastic.co/t/timeout-connection-error/63455 "2016-10-20T00:11:18Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![mattj83](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mattj83/32/97361_2.png) [@mattj83](https://discuss.elastic.co/u/mattj83)\
**Post date:** [October 20, 2016, 12:11am UTC](https://discuss.elastic.co/t/timeout-connection-error/63455/1 "2016-10-20T00:11:18Z")

</div>

I have an error that I hope I some one in the group can help. In my client log I get the following error:

\_Caused by: org.elasticsearch.discovery.MasterNotDiscoveredException: waited for [30s]  
at org.elasticsearch.action.support.master.TransportMasterNodeOperationAction$4.onTimeout(TransportMasterNodeOperationAction.java:170) ~[na:na]  
at org.elasticsearch.cluster.ClusterStateObserver$ObserverClusterStateListener.onTimeout(ClusterStateObserver.java:239) ~[na:na]  
at org.elasticsearch.cluster.service.InternalClusterService$NotifyTimeout.run(InternalClusterService.java:494) ~[na:na]  
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) [na:1.8.0\_66]  
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) [na:1.8.0\_66]  
at java.lang.Thread.run(Thread.java:745) [na:1.8.0\_66]

In my elasticsearch node I have the following error:

[2016-10-20 00:02:36,144][WARN][cluster.service] [Sin] failed to reconnect to node [[prd-use1b-pr-15-epsapp-03x01x00-0009.prv-openclass.com](http://prd-use1b-pr-15-epsapp-03x01x00-0009.prv-openclass.com)][SxvqPTfzR8uUvlsCPFGAww][[prd-use1b-pr-15-epsapp-03x01x00-0009.prv-openclass.com](http://prd-use1b-pr-15-epsapp-03x01x00-0009.prv-openclass.com)][inet[/127.0.1.1:9300]]{data=false, client=true, zone=use1b}  
org.elasticsearch.transport.ConnectTransportException: [[prd-use1b-pr-15-epsapp-03x01x00-0009.prv-openclass.com](http://prd-use1b-pr-15-epsapp-03x01x00-0009.prv-openclass.com)][inet[/127.0.1.1:9300]] connect\_timeout[30s]  
at org.elasticsearch.transport.netty.NettyTransport.connectToChannels(NettyTransport.java:727)  
at org.elasticsearch.transport.netty.NettyTransport.connectToNode(NettyTransport.java:656)  
at org.elasticsearch.transport.netty.NettyTransport.connectToNode(NettyTransport.java:624)  
at org.elasticsearch.transport.TransportService.connectToNode(TransportService.java:146)  
at org.elasticsearch.cluster.service.InternalClusterService$ReconnectToNodes.run(InternalClusterService.java:518)  
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)  
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)  
at java.lang.Thread.run(Thread.java:745)  
Caused by: java.net.ConnectException: Connection refused: /127.0.1.1:9300  
at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method)  
at sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:739)  
at org.elasticsearch.common.netty.channel.socket.nio.NioClientBoss.connect(NioClientBoss.java:150)  
at org.elasticsearch.common.netty.channel.socket.nio.NioClientBoss.processSelectedKeys(NioClientBoss.java:105)  
at org.elasticsearch.common.netty.channel.socket.nio.NioClientBoss.process(NioClientBoss.java:79)  
at org.elasticsearch.common.netty.channel.socket.nio.AbstractNioSelector.run(AbstractNioSelector.java:318)  
at org.elasticsearch.common.netty.channel.socket.nio.NioClientBoss.run(NioClientBoss.java:42)  
at org.elasticsearch.common.netty.util.ThreadRenamingRunnable.run(ThreadRenamingRunnable.java:108)  
at org.elasticsearch.common.netty.util.internal.DeadLockProofWorker$1.run(DeadLockProofWorker.java:42)  
... 3 more  
~

My configuration looks like the following:

[cluster.name](http://cluster.name): epselastic  
cluster.routing.allocation.awareness.attributes: zone  
cluster.routing.allocation.awareness.force.zone.values: use1b,use1c,use1d

node.zone: use1b

path.data: /mnt/es

network.host: xxx.xxx.xx.67

discovery:  
type: com.sonian.elasticsearch.zookeeper.discovery.ZooKeeperDiscoveryModule  
sonian.elasticsearch.zookeeper:  
client.host: [prd-use1b-pr-15-epszookeeper-1x0x1083-0001.prv-openclass.com:2181](http://prd-use1b-pr-15-epszookeeper-1x0x1083-0001.prv-openclass.com:2181),[prd-use1c-pr-15-epszookeeper-1x0x1083-0001.prv-openclass.com:2181](http://prd-use1c-pr-15-epszookeeper-1x0x1083-0001.prv-openclass.com:2181),[prd-use1d-pr-15-epszookeeper-1x0x1083-0001.prv-openclass.com:2181](http://prd-use1d-pr-15-epszookeeper-1x0x1083-0001.prv-openclass.com:2181)

script.disable\_dynamic: false

I am not sure what is causing this error. Thanks in advance for any help.

---

<div class="post-metadata">

**Author:** ![polyfractal](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/polyfractal/32/48162_2.png) [@polyfractal](https://discuss.elastic.co/u/polyfractal)\
**Post date:** [October 20, 2016, 12:20am UTC](https://discuss.elastic.co/t/timeout-connection-error/63455/2 "2016-10-20T00:20:45Z")

</div>

I'm not sure we can really provide any help, since you're using the Zookeeper plugin. Basically, the error says the node couldn't find a new master node to talk to. Master detection and discovery are normally controlled via the internal Zen service, but the Zookeeper plugin replaces it with Zookeeper.

Replacing something as large/complicated as discovery in Elasticsearch with an external service is bound to be difficult and/or buggy. It may have been a transient network blip, or it may have been some bug in the unofficial plugin. It's hard to say since we don't maintain it.

I'd say open a ticket with the maintainers of the plugin, or revert back to the regular Zen discovery service.

---

<div class="post-metadata">

**Author:** ![mattj83](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mattj83/32/97361_2.png) [@mattj83](https://discuss.elastic.co/u/mattj83)\
**Post date:** [October 20, 2016, 12:24am UTC](https://discuss.elastic.co/t/timeout-connection-error/63455/3 "2016-10-20T00:24:52Z")

</div>

Thanks for the prompt replied

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 5, 2017, 10:11pm UTC](https://discuss.elastic.co/t/timeout-connection-error/63455/4 "2017-07-05T22:11:05Z")

</div>


