# Timeout errors Elastic GitHub Workflow Runner

**URL:** https://discuss.elastic.co/t/timeout-errors-elastic-github-workflow-runner/353064
**Category:** Elasticsearch
**Tags:** docker
**Created:** [February 12, 2024, 12:17pm UTC](https://discuss.elastic.co/t/timeout-errors-elastic-github-workflow-runner/353064 "2024-02-12T12:17:44Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![christos-P](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christos-p/32/131647_2.png) [@christos-P](https://discuss.elastic.co/u/christos-P)
#### Post date: [February 12, 2024, 12:17pm UTC](https://discuss.elastic.co/t/timeout-errors-elastic-github-workflow-runner/353064/1 "2024-02-12T12:17:44Z")

</div>

Hi all,

We have our code hosted in GitHub, and we utilize GitHub workflows for our CI/CD pipeline. On each push in a feature branch, based on a docker compose file , in which we describe two services, two services are started and some tests are running. One of the two services is elasticsearch, and we use the image [docker.elastic.co/elasticsearch/elasticsearch:8.5.3](http://docker.elastic.co/elasticsearch/elasticsearch:8.5.3). The other depends on Elasticsearch service and starts only when the Elasticsearch service is healthy. Below you can see the description of elasticsearch

```auto
 elasticsearch:
    image: docker.elastic.co/elasticsearch/elasticsearch:8.5.3
    environment:
      discovery.type: single-node
      ELASTIC_PASSWORD: ******
      ELASTIC_USERNAME: *******
      xpack.security.enabled: "false"
      xpack.security.enrollment.enabled: "false"
      xpack.security.http.ssl.enabled: "false"
      xpack.security.transport.ssl.enabled: "false"
      action.destructive_requires_name: "false"
    healthcheck:
      test: curl -s http://elasticsearch:9200 >/dev/null || exit 1
      interval: 10s
      timeout: 5s
      retries: 10
    ports:
      - 9200:9200
    ulimits:
      memlock:
        soft: -1
        hard: -1

```

On each push in Github those two service are up and running, and some tests that have been written using the pytest framework are running. In some of them we access the Elasticsearch and we do some stuff.

Until very recently, almost a week ago, everything was ok, the tests were running and passing. Out of the blue, we have started experiencing timeout errors, and essentially are tests are failing because of this.

`failed on setup with "elastic_transport.ConnectionTimeout: Connection timeout caused by: ConnectionTimeout(Connection timeout caused by: ReadTimeoutError(HTTPConnectionPool(host='elasticsearch', port=9200): Read timed out. (read timeout=30)))"`

We increased gradually the timeout from 10 to 30, but nothing.

Have anyone else experienced such a problem in a similar setup (GitHub, Docker-Compose, Elastisearch, etc.) ?

Do you have any idea on how we can find the real underlying reason for this ?

Any suggestions more than welcome 🙂

Thanks !!

---

<div class="post-metadata">

### Author: ![Dimitris\_Mavroeidis](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dimitris_mavroeidis/32/125012_2.png) [@Dimitris\_Mavroeidis](https://discuss.elastic.co/u/Dimitris_Mavroeidis)
#### Post date: [February 12, 2024, 12:25pm UTC](https://discuss.elastic.co/t/timeout-errors-elastic-github-workflow-runner/353064/2 "2024-02-12T12:25:56Z")

</div>

We have the same issue as well. This is so annoying.

---

<div class="post-metadata">

### Author: ![christos-P](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christos-p/32/131647_2.png) [@christos-P](https://discuss.elastic.co/u/christos-P)
#### Post date: [February 13, 2024, 2:18pm UTC](https://discuss.elastic.co/t/timeout-errors-elastic-github-workflow-runner/353064/3 "2024-02-13T14:18:58Z")

</div>

So, the problem was related to the available space in the machine that the GitHub runner is running. I am going to elaborate on how we found this, and afterwards how we fixed it.

Using an awesome tool called [GitHub - tmate-io/tmate: Instant Terminal Sharing](https://github.com/tmate-io/tmate), and plugin this to our workflow, using the action: [Debugging with tmate · Actions · GitHub Marketplace · GitHub](https://github.com/marketplace/actions/debugging-with-tmate), we managed to start our services using docker compose and we checked the logs. We saw the following:

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/9/c/9cf778d6defac059779ca8b00bdb1a971256dff0.png)

which indicates clearly that there is a problem with the available space on the hard drive.

They way we fixed that is by using another action [GitHub - ShubhamTatvamasi/free-disk-space-action](https://github.com/ShubhamTatvamasi/free-disk-space-action), via which we managed to reclaim some space. By doing so, we managed to launch both of our services and the tests ran successfully.

Hope that is going to help in the future anyone is going to experience anything similar.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [March 12, 2024, 2:19pm UTC](https://discuss.elastic.co/t/timeout-errors-elastic-github-workflow-runner/353064/4 "2024-03-12T14:19:46Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
